extra/js78 to 78.15.0-2

This commit is contained in:
Kevin Mihelich 2022-01-12 00:20:00 +00:00
parent 559465e0cc
commit e2821c7888
4 changed files with 1480 additions and 5 deletions

View file

@ -10,7 +10,7 @@ Cherry-picked from Firefox Nightly.
2 files changed, 22 insertions(+), 6 deletions(-)
diff --git a/build/moz.configure/lto-pgo.configure b/build/moz.configure/lto-pgo.configure
index 366c6691f7d11..e5342a037ee92 100644
index 366c6691f7d1..e5342a037ee9 100644
--- a/build/moz.configure/lto-pgo.configure
+++ b/build/moz.configure/lto-pgo.configure
@@ -229,7 +229,10 @@ def lto(value, c_compiler, ld64_known_good, target, instrumented_build):
@ -34,7 +34,7 @@ index 366c6691f7d11..e5342a037ee92 100644
add_old_configure_assignment('MOZ_LTO_CFLAGS', lto.cflags)
add_old_configure_assignment('MOZ_LTO_LDFLAGS', lto.ldflags)
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
index f4475054f8979..f19dfbc72fad0 100644
index f4475054f897..f19dfbc72fad 100644
--- a/config/makefiles/rust.mk
+++ b/config/makefiles/rust.mk
@@ -59,17 +59,19 @@ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)

File diff suppressed because it is too large Load diff

File diff suppressed because one or more lines are too long

View file

@ -6,7 +6,7 @@
pkgname=js78
pkgver=78.15.0
pkgrel=1
pkgrel=2
pkgdesc="JavaScript interpreter and libraries - Version 78"
arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
@ -14,13 +14,18 @@ license=(MPL)
depends=(gcc-libs readline zlib sh)
makedepends=(zip autoconf2.13 python-setuptools python-psutil rust llvm clang lld)
checkdepends=(mercurial git)
options=(!lto)
_relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
0001-Fixes-for-LTO-PGO-support.patch
0002-Fixes-for-Python-3.10.patch
0003-Fixes-for-Rust-1.56.patch
arm.patch)
sha256sums=('a4438d84d95171a6d4fea9c9f02c2edbf0475a9c614d968ebe2eedc25a672151'
'SKIP'
'926a573eabe3b6177363b795ed5e5641b4a4ebc6d7cfa093f11e1779ac0f897c'
'606ef0a2faeffd52cd3d4564146a95eef2b0e58e610d3af8d203753ed27e5a00'
'b723277864c8afad1db007963f8e1090b352ced7bb312b2e7e2f11f448e8432d'
'cb5f1a0551f55c12562c1f384e9d0a011dd13993039e65aa69b5345a5951af9f'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
@ -34,6 +39,12 @@ prepare() {
# Post-78 fixes to fix LTO with LLVM 11
patch -Np1 -i ../0001-Fixes-for-LTO-PGO-support.patch
# Fix build with Python 3.10
patch -Np1 -i ../0002-Fixes-for-Python-3.10.patch
# Fix build with Rust 1.56
patch -Np1 -i ../0003-Fixes-for-Rust-1.56.patch
}
build() {
@ -63,6 +74,10 @@ build() {
export NM=llvm-nm
export RANLIB=llvm-ranlib
CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
CXXFLAGS="${CXXFLAGS/-O2/-O3} -fno-semantic-interposition"
LDFLAGS+=" -Wl,-Bsymbolic-functions"
cd firefox-$pkgver/obj
# Do 3-tier PGO
@ -127,4 +142,4 @@ package() {
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +
}
# vim:set ts=2 sw=2 et:
# vim:set sw=2 et: