core/linux-chromebook2 to 20140619-1

This commit is contained in:
Kevin Mihelich 2014-06-20 00:30:07 +00:00
parent 98f6f326a5
commit e2af2a6fd6
2 changed files with 35 additions and 3 deletions

View file

@ -0,0 +1,26 @@
From dd277c9a851cc4b5b6521cc2c6d79ce407488910 Mon Sep 17 00:00:00 2001
From: "S.J.R. van Schaik" <stephan@synkhronix.com>
Date: Thu, 19 Jun 2014 17:08:06 +0100
Subject: [PATCH] exynos DRM: have exynos_drm_fbdev_update() set smem_start and
smem_len.
---
drivers/gpu/drm/exynos/exynos_drm_fbdev.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/exynos/exynos_drm_fbdev.c b/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
index 5a7cd8b..6b96fd4 100644
--- a/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
+++ b/drivers/gpu/drm/exynos/exynos_drm_fbdev.c
@@ -125,6 +125,8 @@ static int exynos_drm_fbdev_update(struct drm_fb_helper *helper,
fbi->screen_base = buffer->kvaddr;
fbi->screen_size = size;
+ fbi->fix.smem_start = buffer->dma_addr;
+ fbi->fix.smem_len = size;
return 0;
}
--
1.8.5.5

View file

@ -1,11 +1,12 @@
# Samsung Chromebook 2 Kernel
# Samsung/HP Chromebook Kernel
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
# Maintainer: stratum nine <strata@dropswitch.net>
buildarch=4
pkgbase=linux-chromebook2
pkgname=('linux-chromebook2' 'linux-headers-chromebook2')
pkgver=20140615
pkgver=20140619
_kernelname=${pkgname#linux}
pkgdesc="ChromiumOS kernel with ArchLinux ARM tweaks"
_basever=3.8
@ -15,14 +16,16 @@ url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'dtc' 'inetutils' 'kmod' 'vboot-utils')
options=('!strip')
_commit=4f4fe0909e77d2fdf7b72d56b91cd7629e831b8e
_commit=b4854861a443c069f4335538c80e9d9118e7e34a
source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archive/${_commit}.tar.gz"
'0001-exynos-drm-smem-start-len.patch'
'config'
'kernel.its'
'kernel.keyblock'
'kernel_data_key.vbprivk')
noextract=("${_commit}.tar.gz")
md5sums=('SKIP'
'dc8c3ffa65edd9ee30a1f9805d2b3460'
'a5d06241e13c11fae3eff39aa737dddf'
'1e66637b4771568d2dfa161f5e0357f7'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -36,6 +39,9 @@ prepare() {
cd ${srcdir}/chromeos-${_basever}
# fix for using xf86-video-fbturbo
git apply ../0001-exynos-drm-smem-start-len.patch
# Kernel configuration
cp "${srcdir}/config" .config