mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-aarch64-rc to 4.19.rc6-1
This commit is contained in:
parent
9a3b4d9dd7
commit
e2caf2a477
6 changed files with 70 additions and 24 deletions
|
@ -1,7 +1,7 @@
|
|||
From 0cd8e7546b92dfadcb1cb072e755af05e3bf8a35 Mon Sep 17 00:00:00 2001
|
||||
From f05cffafeea2a0023b06622453b7dc07305c464d Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 1/5] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
|
||||
|
@ -91,5 +91,5 @@ index 06b4d290784d..3be3b5a4a176 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.18.0
|
||||
2.19.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 99984002189abb7822f71cc8844e263bb591f75b Mon Sep 17 00:00:00 2001
|
||||
From 73ae77ed31ba290cb09611096fd9960c4302ce9d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
||||
Subject: [PATCH 2/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||
Subject: [PATCH 2/5] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||
|
||||
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
|
||||
---
|
||||
|
@ -9,10 +9,10 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
index 2a352763c848..b986aef1d7fd 100644
|
||||
index 38336ab57cc4..d52e93f3e705 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
@@ -630,7 +630,7 @@
|
||||
@@ -634,7 +634,7 @@
|
||||
};
|
||||
|
||||
&pwm0 {
|
||||
|
@ -22,5 +22,5 @@ index 2a352763c848..b986aef1d7fd 100644
|
|||
|
||||
&pwm2 {
|
||||
--
|
||||
2.18.0
|
||||
2.19.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From c8c5f3c2bcbc8121ac7f2e2b88bdd5d8672c2c49 Mon Sep 17 00:00:00 2001
|
||||
From a96dd1d8b09c809dc1f78a1c5c45fcfe5f810ede Mon Sep 17 00:00:00 2001
|
||||
From: William Wu <william.wu@rock-chips.com>
|
||||
Date: Mon, 4 Dec 2017 10:40:39 +0100
|
||||
Subject: [PATCH 3/4] arm64: dts: rockchip: add usb3 controller node for RK3328
|
||||
Subject: [PATCH 3/5] arm64: dts: rockchip: add usb3 controller node for RK3328
|
||||
SoCs
|
||||
|
||||
RK3328 has one USB 3.0 OTG controller which uses DWC_USB3
|
||||
|
@ -16,10 +16,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
|
|||
1 file changed, 27 insertions(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3328.dtsi b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
|
||||
index b8e9da15e00c..60b3ed5918e7 100644
|
||||
index 3f5a2944300f..c8cd0cc6070e 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3328.dtsi
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3328.dtsi
|
||||
@@ -862,6 +862,33 @@
|
||||
@@ -828,6 +828,33 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
|
@ -54,5 +54,5 @@ index b8e9da15e00c..60b3ed5918e7 100644
|
|||
compatible = "arm,gic-400";
|
||||
#interrupt-cells = <3>;
|
||||
--
|
||||
2.18.0
|
||||
2.19.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From b772d09de7feaa9b6783fbad461d2d2f5aeb70e1 Mon Sep 17 00:00:00 2001
|
||||
From bc381ddd900bac910b262bca5539030b2f5ac31b Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Stuebner <heiko@sntech.de>
|
||||
Date: Mon, 4 Dec 2017 10:40:41 +0100
|
||||
Subject: [PATCH 4/4] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
|
||||
Subject: [PATCH 4/5] arm64: dts: rockchip: enable usb3 nodes on rk3328-rock64
|
||||
|
||||
Enable the nodes to make the usb3 port usable on that board.
|
||||
|
||||
|
@ -11,10 +11,10 @@ Signed-off-by: Heiko Stuebner <heiko@sntech.de>
|
|||
1 file changed, 9 insertions(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
|
||||
index 28257724a56e..5c43a61d3178 100644
|
||||
index 5272e887a434..ad82bf39e268 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3328-rock64.dts
|
||||
@@ -332,3 +332,12 @@
|
||||
@@ -295,3 +295,12 @@
|
||||
&usb_host0_ohci {
|
||||
status = "okay";
|
||||
};
|
||||
|
@ -28,5 +28,5 @@ index 28257724a56e..5c43a61d3178 100644
|
|||
+ status = "okay";
|
||||
+};
|
||||
--
|
||||
2.18.0
|
||||
2.19.0
|
||||
|
||||
|
|
|
@ -0,0 +1,44 @@
|
|||
From fa043c693efab65d3caa02cbaf93813531040eb1 Mon Sep 17 00:00:00 2001
|
||||
From: Hal Emmerich <hal@halemmerich.com>
|
||||
Date: Thu, 19 Jul 2018 21:48:08 -0500
|
||||
Subject: [PATCH 5/5] usb: dwc2: disable power_down on rockchip devices
|
||||
|
||||
The bug would let the usb controller enter partial power down,
|
||||
which was formally known as hibernate, upon boot if nothing was plugged
|
||||
in to the port. Partial power down couldn't be exited properly, so any
|
||||
usb devices plugged in after boot would not be usable.
|
||||
|
||||
Before the name change, params.hibernation was false by default, so
|
||||
_dwc2_hcd_suspend() would skip entering hibernation. With the
|
||||
rename, _dwc2_hcd_suspend() was changed to use params.power_down
|
||||
to decide whether or not to enter partial power down.
|
||||
|
||||
Since params.power_down is non-zero by default, it needs to be set
|
||||
to 0 for rockchip devices to restore functionality.
|
||||
|
||||
This bug was reported in the linux-usb thread:
|
||||
REGRESSION: usb: dwc2: USB device not seen after boot
|
||||
|
||||
The commit that caused this regression is:
|
||||
6d23ee9caa6790aea047f9aca7f3c03cb8d96eb6
|
||||
|
||||
Signed-off-by: Hal Emmerich <hal@halemmerich.com>
|
||||
---
|
||||
drivers/usb/dwc2/params.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/drivers/usb/dwc2/params.c b/drivers/usb/dwc2/params.c
|
||||
index bf7052e037d6..09292dc977e4 100644
|
||||
--- a/drivers/usb/dwc2/params.c
|
||||
+++ b/drivers/usb/dwc2/params.c
|
||||
@@ -81,6 +81,7 @@ static void dwc2_set_rk_params(struct dwc2_hsotg *hsotg)
|
||||
p->host_perio_tx_fifo_size = 256;
|
||||
p->ahbcfg = GAHBCFG_HBSTLEN_INCR16 <<
|
||||
GAHBCFG_HBSTLEN_SHIFT;
|
||||
+ p->power_down = 0;
|
||||
}
|
||||
|
||||
static void dwc2_set_ltq_params(struct dwc2_hsotg *hsotg)
|
||||
--
|
||||
2.19.0
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=8
|
||||
|
||||
_rcver=4.19
|
||||
_rcrel=5
|
||||
_rcrel=6
|
||||
|
||||
pkgbase=linux-aarch64-rc
|
||||
_srcname=linux-${_rcver}-rc${_rcrel}
|
||||
|
@ -22,6 +22,7 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
|
|||
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
|
||||
'0003-arm64-dts-rockchip-add-usb3-controller-node-for-RK33.patch'
|
||||
'0004-arm64-dts-rockchip-enable-usb3-nodes-on-rk3328-rock6.patch'
|
||||
'0005-usb-dwc2-disable-power_down-on-rockchip-devices.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
|
@ -29,11 +30,12 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
|
|||
'linux.preset'
|
||||
'60-linux.hook'
|
||||
'90-linux.hook')
|
||||
md5sums=('5a3109e96d992abf0771de7327a412b5'
|
||||
'be4199c685434f12190bb627bb714ff2'
|
||||
'b4d613a58a28445ce8363d734be3b971'
|
||||
'b9bec2a58df6dff282df758edf8f526e'
|
||||
'9915046e15f82e917bc98c7721e63ac4'
|
||||
md5sums=('d8e6eeb55b1530052641853ed15a59bc'
|
||||
'649c026be704355946a4f008754f3dc5'
|
||||
'3269181ce2a9d63a85cef0db36d80189'
|
||||
'9dee22229f3dc8ebe2f12077b4577ac6'
|
||||
'40b04a13d7ae9d3dc8971812610362a9'
|
||||
'203a6aa1d775a737d28d2ad4a13a4f1f'
|
||||
'8132cc9def786988941adbf9c31643b3'
|
||||
'7f1a96e24f5150f790df94398e9525a3'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
|
|
Loading…
Reference in a new issue