added community/unrealircd

This commit is contained in:
Kevin Mihelich 2016-01-09 01:03:07 +00:00
parent 292dee71b8
commit e2f7d8aa25
7 changed files with 146 additions and 0 deletions

View file

@ -0,0 +1,27 @@
From 7939096e5be2547c415d32942b4db179f77c08c1 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 8 Jan 2016 17:57:41 -0700
Subject: [PATCH] run autoreconf on TRE library
Fixes AArch64 build due to outdated config.{sub,guess}.
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
configure | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure b/configure
index 73cde93..40667e6 100755
--- a/configure
+++ b/configure
@@ -6683,6 +6683,7 @@ fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: configuring TRE regex library" >&5
$as_echo "configuring TRE regex library" >&6; }
cd tre-$tre_version
+autoreconf -fi
./configure --disable-agrep --disable-shared --disable-system-abi --disable-wchar --disable-multibyte --prefix=$cur_dir/extras/regexp || exit 1
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: compiling TRE regex library" >&5
$as_echo "compiling TRE regex library" >&6; }
--
2.6.2

View file

@ -0,0 +1,61 @@
# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Zerial <fernando@zerial.org>
# ALAMR: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix AArch64 FTBFS
pkgname=unrealircd
pkgver=4.0.0
pkgrel=4
pkgdesc="Open Source IRC Server"
arch=('i686' 'x86_64')
url="http://unrealircd.com"
license=('GPL2')
depends=('openssl' 'curl' 'c-ares')
conflicts=('ircd')
provides=('ircd')
backup=('etc/unrealircd/unrealircd.conf')
install=unrealircd.install
source=(https://www.unrealircd.org/unrealircd4/unrealircd-$pkgver.tar.gz
unrealircd.service
unrealircd.tmpfiles.d
config.settings
install.pl
0001-run-autoreconf-on-TRE-library.patch)
md5sums=('ea5922554cda40e39a2d6fd7520284f1'
'677d8de0bae770488a2c1730f9475a51'
'3ec519ea7dbe99696eb6c51dfc0d382a'
'11ce231048c92651e76fdeb58609d0ba'
'3a23792b03420fc578cf6688b1574ae3'
'28bd33be158f5c494601b6b3026803fa')
prepare() {
cd $srcdir/unrealircd-$pkgver
cp $srcdir/config.settings .
sed -i \
-e 's|$(INSTALL) -m 0700|$(INSTALL) -m 0755|g' \
-e 's|$(INSTALL) -m 0600|$(INSTALL) -m 0644|g' \
Makefile.in
sed -i 's|ARG=" "|ARG="--with-pidfile=/run/unrealircd/ircd.pid "|' Config
patch -p1 -i ../0001-run-autoreconf-on-TRE-library.patch
}
build() {
cd $srcdir/unrealircd-$pkgver
./Config -quick
make
}
package() {
cd $srcdir/unrealircd-$pkgver
export pkgdir
make INSTALL=$srcdir/install.pl install
mv $pkgdir/usr/unrealircd $pkgdir/etc/unrealircd/unrealircd
cp $pkgdir/etc/unrealircd/examples/example.conf $pkgdir/etc/unrealircd/unrealircd.conf
rm -rf $pkgdir/tmp
install -Dm0644 $srcdir/unrealircd.service $pkgdir/usr/lib/systemd/system/unrealircd.service
install -Dm0644 $srcdir/unrealircd.tmpfiles.d $pkgdir/usr/lib/tmpfiles.d/unrealircd.conf
}

View file

@ -0,0 +1,28 @@
#
BASEPATH="/usr"
BINDIR="/usr/bin"
DATADIR="/var/lib/unrealircd"
CONFDIR="/etc/unrealircd"
MODULESDIR="/usr/lib/unrealircd"
LOGDIR="/var/log/unrealircd"
CACHEDIR="/var/cache/unrealircd"
DOCDIR="/usr/share/doc/unrealircd"
TMPDIR="/tmp"
PREFIXAQ="1"
MAXSENDQLENGTH="3000000"
MAXCONNECTIONS="1024"
NICKNAMEHISTORYLENGTH="2000"
DEFPERM="0644"
SSLDIR="/usr"
REMOTEINC=""
CURLDIR="/usr"
SHOWLISTMODES="1"
TOPICNICKISNUH=""
SHUNNOTICES=""
NOOPEROVERRIDE=""
DISABLEUSERMOD=""
OPEROVERRIDEVERIFY=""
DISABLEEXTBANSTACKING=""
GENCERTIFICATE="1"
EXTRAPARA=""
ADVANCED=""

View file

@ -0,0 +1,5 @@
#!/usr/bin/perl -w
use Env qw(pkgdir);
my $last = pop @ARGV;
my $cmd = "/usr/bin/install ".(join ' ',@ARGV)." $pkgdir/$last";
system($cmd);

View file

@ -0,0 +1,12 @@
post_install() {
getent passwd ircd >/dev/null || useradd -r ircd
chown -R ircd {etc,var/{cache,log,lib}}/unrealircd
systemd-tmpfiles --create unrealircd.conf
echo "SSL is enabled by default, so you need to create pem files"
echo "unrealircd.conf needs adjustments"
echo "See also: https://wiki.archlinux.org/index.php/UnrealIRCd"
}
post_upgrade() {
post_install
}

View file

@ -0,0 +1,12 @@
[Unit]
Description=IRC daemon
After=network.target remote-fs.target nss-lookup.target
[Service]
Type=forking
User=ircd
PIDFile=/run/unrealircd/ircd.pid
ExecStart=/usr/bin/unrealircd
[Install]
WantedBy=multi-user.target

View file

@ -0,0 +1 @@
d /run/unrealircd 0755 ircd root -