community/giac to 1.9.0.33-1

This commit is contained in:
Kevin Mihelich 2022-12-18 13:07:11 +00:00
parent c6443d0075
commit e33b6c17a6
2 changed files with 3 additions and 59 deletions

View file

@ -4,7 +4,7 @@
# - delete shipped x86 binary src/mkjs to force rebuild for ARM
pkgname=giac
_pkgver=1.9.0-29
_pkgver=1.9.0-33
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc='A free computer algebra system'
@ -18,8 +18,8 @@ replaces=(libgiac xcas)
provides=(libgiac xcas)
source=(http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/${pkgname}_$_pkgver.tar.gz
format-security.patch)
sha256sums=('f6351572cad5f2331faab9a7ca6678bc869695a6c5f69a42baaed50e56790b0e'
'4a5278dc6196b2e9642eed8550f940b0fb08f837ec8fa4dffabade31fdafc4da')
sha256sums=('056b5941d0b0e86162f16e727e0722460e07496ea1a02d5cddb713eda7720d02'
'04288944e408807a15aa502e1215087870d8921229c9f9890d862d3c9de337cd')
prepare() {
cd $pkgname-${pkgver%.*}

View file

@ -10,59 +10,3 @@ diff -ru giac-1.9.0.orig/src/Graph.cc giac-1.9.0/src/Graph.cc
if (!ch) return false;
gen g(ch,contextptr);
g=evalf_double(g,1,contextptr);
@@ -5779,14 +5779,14 @@
if (operation==2){ // root near curt
sol=newton(y,t,curt,NEWTON_DEFAULT_ITERATION,eps,1e-12,true,tmin._DOUBLE_val,tmax._DOUBLE_val,1,0,1,contextptr);
if (sol.type==_DOUBLE_){
- fl_alert((gettext("Root at ")+sol.print(contextptr)).c_str());
+ fl_alert("%s",(gettext("Root at ")+sol.print(contextptr)).c_str());
sto(sol,gen("Zero",contextptr),contextptr);
}
}
if (operation==4){ // horizontal tangent near curt
sol=newton(y1,t,curt,NEWTON_DEFAULT_ITERATION,eps,1e-12,true,tmin._DOUBLE_val,tmax._DOUBLE_val,1,0,1,contextptr);
if (sol.type==_DOUBLE_){
- fl_alert((gettext("y'=0, extremum/singular pt at ")+sol.print(contextptr)).c_str());
+ fl_alert("%s",(gettext("y'=0, extremum/singular pt at ")+sol.print(contextptr)).c_str());
sto(sol,gen("Extremum",contextptr),contextptr);
}
}
@@ -5796,7 +5796,7 @@
else {
sol=newton(x1,t,curt,NEWTON_DEFAULT_ITERATION,eps,1e-12,true,tmin._DOUBLE_val,tmax._DOUBLE_val,1,0,1,contextptr);
if (sol.type==_DOUBLE_){
- fl_alert((gettext("x'=0, vertical or singular: ")+sol.print(contextptr)).c_str());
+ fl_alert("%s",(gettext("x'=0, vertical or singular: ")+sol.print(contextptr)).c_str());
sto(sol,gen("Vertical",contextptr),contextptr);
}
}
@@ -5804,7 +5804,7 @@
if (operation==6){ // inflexion
sol=newton(x1*y2-x2*y1,t,curt,NEWTON_DEFAULT_ITERATION,eps,1e-12,true,tmin._DOUBLE_val,tmax._DOUBLE_val,1,0,1,contextptr);
if (sol.type==_DOUBLE_){
- fl_alert(("x'*y''-x''*y'=0: "+sol.print(contextptr)).c_str());
+ fl_alert("%s",("x'*y''-x''*y'=0: "+sol.print(contextptr)).c_str());
sto(sol,gen("Inflexion",contextptr),contextptr);
}
}
@@ -5826,9 +5826,9 @@
tracemode_disp.push_back(giac::eval(res,1,contextptr));
string ss=res.print(contextptr);
if (!tegral(f,t,a,b,1e-6,1<<10,res,false,contextptr))
- fl_alert((gettext("Numerical Integration Error: ")+ss).c_str());
+ fl_alert("%s",(gettext("Numerical Integration Error: ")+ss).c_str());
else {
- fl_alert((ss+": "+res.print(contextptr)).c_str());
+ fl_alert("%s",(ss+": "+res.print(contextptr)).c_str());
sto(res,gen((operation==9?"Area":"Arclength"),contextptr),contextptr);
}
}
@@ -5938,7 +5938,7 @@
curve_infos1 = f.print(contextptr)+": "+curve_infos1;
}
}
- fl_alert((curve_infos1+'\n'+curve_infos2).c_str());
+ fl_alert("%s",(curve_infos1+'\n'+curve_infos2).c_str());
}
tracemode_add="";
if (Gx.type==_DOUBLE_ && Gy.type==_DOUBLE_){