removed extra/glib

This commit is contained in:
Kevin Mihelich 2015-07-10 18:16:26 +00:00
parent 226c52d411
commit e35070f98f
5 changed files with 0 additions and 138 deletions

View file

@ -1,59 +0,0 @@
# $Id$
# Maintainer: Eric Bélanger <eric@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - added our architectures to set CONFIGFLAG
pkgname=glib
pkgver=1.2.10
pkgrel=11
pkgdesc="Common C routines used by Gtk+ and other libs"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc' 'sh')
options=('!makeflags')
install=glib.install
source=(ftp://ftp.gtk.org/pub/gtk/v1.2/${pkgname}-${pkgver}.tar.gz
gcc340.patch aclocal-fixes.patch glib1-autotools.patch)
sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'
'a2cc224a66aeffdcac16ebd9e8af18143cf54918'
'ae4438cf56c0c9264ee36f6973fb445f9a820be0'
'8a25fde3c79567262b3024f4e74c9ca4ee8a6279')
prepare() {
cd ${pkgname}-${pkgver}
patch -Np1 -i "${srcdir}/gcc340.patch"
patch -Np0 -i "${srcdir}/aclocal-fixes.patch"
patch -Np1 -i "${srcdir}/glib1-autotools.patch"
}
build() {
cd ${pkgname}-${pkgver}
if [[ $CARCH = "i686" ]]; then
CONFIGFLAG='--host=i686-pc-linux-gnu --target=i686-pc-linux-gnu'
elif [[ $CARCH = "x86_64" ]]; then
CONFIGFLAG='--host=x86_64-unknown-linux-gnu --target=x86_64-unknown-linux-gnu'
elif [[ $CARCH = "arm" ]]; then
CONFIGFLAG='--host=armv5tel-unknown-linux-gnueabi --target=armv5tel-unknown-linux-gnueabi'
elif [[ $CARCH = "armv6h" ]]; then
CONFIGFLAG='--host=armv6l-unknown-linux-gnueabi --target=armv6l-unknown-linux-gnueabi'
elif [[ $CARCH = "armv7h" ]]; then
CONFIGFLAG='--host=armv7l-unknown-linux-gnueabi --target=armv7l-unknown-linux-gnueabi'
fi
autoreconf --force --install
./configure --prefix=/usr --mandir=/usr/share/man \
--infodir=/usr/share/info $CONFIGFLAG
make
}
check() {
cd ${pkgname}-${pkgver}
make check
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
}

View file

@ -1,11 +0,0 @@
--- glib.m4.orig 2006-03-05 13:13:24.000000000 +0000
+++ glib.m4 2006-03-05 13:13:35.000000000 +0000
@@ -5,7 +5,7 @@
dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or
dnl gthread is specified in MODULES, pass to glib-config
dnl
-AC_DEFUN(AM_PATH_GLIB,
+AC_DEFUN([AM_PATH_GLIB],
[dnl
dnl Get the cflags and libraries from the glib-config script
dnl

View file

@ -1,15 +0,0 @@
diff -Naur glib-1.2.10.orig/glib.h glib-1.2.10/glib.h
--- glib-1.2.10.orig/glib.h 2001-02-27 04:44:38.000000000 +0100
+++ glib-1.2.10/glib.h 2004-05-27 15:50:32.436527848 +0200
@@ -271,8 +271,10 @@
/* Wrap the gcc __PRETTY_FUNCTION__ and __FUNCTION__ variables with
* macros, so we can refer to them as strings unconditionally.
+ *
+ * Unfortunately these are _not_ treated as strings anymore in GCC3.4.
*/
-#ifdef __GNUC__
+#if defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ < 4)
#define G_GNUC_FUNCTION __FUNCTION__
#define G_GNUC_PRETTY_FUNCTION __PRETTY_FUNCTION__
#else /* !__GNUC__ */

View file

@ -1,20 +0,0 @@
infodir=usr/share/info
filelist=(glib.info.gz)
post_install() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info $infodir/$file $infodir/dir 2> /dev/null
done
}
post_upgrade() {
post_install $1
}
pre_remove() {
[ -x usr/bin/install-info ] || return 0
for file in ${filelist[@]}; do
install-info --delete $infodir/$file $infodir/dir 2> /dev/null
done
}

View file

@ -1,33 +0,0 @@
diff -Naur glib-1.2.10-orig/configure.in glib-1.2.10/configure.in
--- glib-1.2.10-orig/configure.in 2013-07-22 01:33:26.930091236 -0400
+++ glib-1.2.10/configure.in 2013-07-22 01:35:19.988776415 -0400
@@ -17,7 +17,7 @@
dnl we need to AC_DIVERT_PUSH/AC_DIVERT_POP these variable definitions so they
dnl are available for $ac_help expansion (don't we all *love* autoconf?)
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+AC_DIVERT_PUSH()dnl
#
# The following version number definitions apply to GLib, GModule and GThread
# as a whole, so if changes occoured in any of them, they are all
@@ -81,7 +81,7 @@
dnl figure debugging default, prior to $ac_help setup
dnl
-AC_DIVERT_PUSH(AC_DIVERSION_NOTICE)dnl
+AC_DIVERT_PUSH()dnl
if test `expr $GLIB_MINOR_VERSION \% 2` = 1 ; then
debug_default=yes
else
diff -Naur glib-1.2.10-orig/gmodule/Makefile.am glib-1.2.10/gmodule/Makefile.am
--- glib-1.2.10-orig/gmodule/Makefile.am 2013-07-22 01:33:26.933424531 -0400
+++ glib-1.2.10/gmodule/Makefile.am 2013-07-22 01:38:46.553041607 -0400
@@ -42,7 +42,7 @@
libgplugin_b_la_LIBADD = @G_MODULE_LIBS@ # $(libglib)
noinst_PROGRAMS = testgmodule
-testgmodule_LDFLAGS += @G_MODULE_LDFLAGS@
+testgmodule_LDFLAGS = @G_MODULE_LDFLAGS@
testgmodule_LDADD = libgmodule.la $(libglib) @G_MODULE_LIBS@
.PHONY: files release