mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/libdrm to 2.4.61-1
This commit is contained in:
parent
b509eed6f6
commit
e356d2d8ce
2 changed files with 7 additions and 39 deletions
|
@ -1,28 +0,0 @@
|
|||
From 7d8f5e019505f5bda67ad8d2b25077eade90fbe8 Mon Sep 17 00:00:00 2001
|
||||
From: Connor Behan <connor.behan@gmail.com>
|
||||
Date: Tue, 24 Mar 2015 13:47:26 -0400
|
||||
Subject: [PATCH] xf86drm: Fix ioctl struct clearing in drmAgpEnable
|
||||
|
||||
This one is a bit harder to notice.
|
||||
|
||||
Signed-off-by: Connor Behan <connor.behan@gmail.com>
|
||||
---
|
||||
xf86drm.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xf86drm.c b/xf86drm.c
|
||||
index e73cddd..ffc53b8 100644
|
||||
--- a/xf86drm.c
|
||||
+++ b/xf86drm.c
|
||||
@@ -1719,7 +1719,7 @@ int drmAgpEnable(int fd, unsigned long mode)
|
||||
{
|
||||
drm_agp_mode_t m;
|
||||
|
||||
- memclear(mode);
|
||||
+ memclear(m);
|
||||
m.mode = mode;
|
||||
if (drmIoctl(fd, DRM_IOCTL_AGP_ENABLE, &m))
|
||||
return -errno;
|
||||
--
|
||||
2.3.3
|
||||
|
|
@ -6,32 +6,28 @@
|
|||
# - drop valgrind makdepend
|
||||
|
||||
pkgname=libdrm
|
||||
pkgver=2.4.60
|
||||
pkgrel=2
|
||||
pkgver=2.4.61
|
||||
pkgrel=1
|
||||
pkgdesc="Userspace interface to kernel DRM services"
|
||||
arch=(i686 x86_64)
|
||||
license=('custom')
|
||||
depends=('glibc' 'libpciaccess')
|
||||
makedepends=('xorg-util-macros')
|
||||
checkdepends=('cairo')
|
||||
replaces=('libdrm-new' 'libdrm-nouveau')
|
||||
url="http://dri.freedesktop.org/"
|
||||
source=(http://dri.freedesktop.org/$pkgname/$pkgname-$pkgver.tar.bz2{,.sig}
|
||||
COPYING
|
||||
0001-xf86drm-Fix-ioctl-struct-clearing-in-drmAgpEnable.patch)
|
||||
sha256sums=('99575fc6c8e31f59193f5320fd4db7a5478e2641b5266147caab9aa875b59889'
|
||||
COPYING)
|
||||
sha256sums=('8b549092c8961a393a7e1d9a1bccddcea8e2af67c0d7d7c67babb9fc3b47699c'
|
||||
'SKIP'
|
||||
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93'
|
||||
'b9a4e77e50a0c11fbdf95b277fe4a6943eba3a63b5b90c548cbc5159db1d32f3')
|
||||
'9631d4f694952e3e6ae5a05534c2e93e994e47d3413677a3a00e45c8cef6db93')
|
||||
validpgpkeys=('B97BD6A80CAC4981091AE547FE558C72A67013C3') # Maarten Lankhorst <maarten.lankhorst@canonical.com>
|
||||
validpgpkeys+=('215DEE688925CCB965BE5DA97C03D7797B6E1AE2') # Damien Lespiau <damien.lespiau@intel.c
|
||||
validpgpkeys+=('10A6D91DA1B05BD29F6DEBAC0C74F35979C486BE') # David Airlie <airlied@redhat.com>
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
# fix permission issue on r128 cards, pushed by Connor Behan
|
||||
# tested by Tobias Powalowski
|
||||
patch -Np1 -i ${srcdir}/0001-xf86drm-Fix-ioctl-struct-clearing-in-drmAgpEnable.patch
|
||||
|
||||
# pthread is useless in Linux
|
||||
sed -i "/pthread-stubs/d" configure.ac
|
||||
autoreconf --force --install
|
||||
|
|
Loading…
Reference in a new issue