mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
community/freerdp to 1.2.0_beta1+android9-2
This commit is contained in:
parent
ee2ff9ca38
commit
e35db8b460
7 changed files with 23 additions and 161 deletions
|
@ -1,79 +0,0 @@
|
|||
--- a/libfreerdp-core/license.h 2013-01-03 05:46:59.000000000 +0800
|
||||
+++ b/libfreerdp-core/license.h 2014-04-09 19:11:59.593507658 +0800
|
||||
@@ -177,9 +177,9 @@
|
||||
|
||||
SCOPE_LIST* license_new_scope_list();
|
||||
void license_free_scope_list(SCOPE_LIST* scopeList);
|
||||
-void license_read_scope_list(STREAM* s, SCOPE_LIST* scopeList);
|
||||
+boolean license_read_scope_list(STREAM* s, SCOPE_LIST* scopeList);
|
||||
|
||||
-void license_read_license_request_packet(rdpLicense* license, STREAM* s);
|
||||
+boolean license_read_license_request_packet(rdpLicense* license, STREAM* s);
|
||||
void license_read_platform_challenge_packet(rdpLicense* license, STREAM* s);
|
||||
void license_read_new_license_packet(rdpLicense* license, STREAM* s);
|
||||
void license_read_upgrade_license_packet(rdpLicense* license, STREAM* s);
|
||||
--- a/libfreerdp-core/license.c 2013-01-03 05:46:59.000000000 +0800
|
||||
+++ b/libfreerdp-core/license.c 2014-04-09 19:11:59.593507658 +0800
|
||||
@@ -199,7 +199,8 @@
|
||||
switch (bMsgType)
|
||||
{
|
||||
case LICENSE_REQUEST:
|
||||
- license_read_license_request_packet(license, s);
|
||||
+ if(!license_read_license_request_packet(license, s))
|
||||
+ return false;
|
||||
license_send_new_license_request_packet(license);
|
||||
break;
|
||||
|
||||
@@ -533,13 +534,16 @@
|
||||
* @param scopeList scope list
|
||||
*/
|
||||
|
||||
-void license_read_scope_list(STREAM* s, SCOPE_LIST* scopeList)
|
||||
+boolean license_read_scope_list(STREAM* s, SCOPE_LIST* scopeList)
|
||||
{
|
||||
uint32 i;
|
||||
uint32 scopeCount;
|
||||
|
||||
stream_read_uint32(s, scopeCount); /* ScopeCount (4 bytes) */
|
||||
|
||||
+ if (scopeCount > stream_get_length(s) / 4) /* every blob is at least 4 bytes */
|
||||
+ return false;
|
||||
+
|
||||
scopeList->count = scopeCount;
|
||||
scopeList->array = (LICENSE_BLOB*) xmalloc(sizeof(LICENSE_BLOB) * scopeCount);
|
||||
|
||||
@@ -549,6 +553,7 @@
|
||||
scopeList->array[i].type = BB_SCOPE_BLOB;
|
||||
license_read_binary_blob(s, &scopeList->array[i]);
|
||||
}
|
||||
+ return true;
|
||||
}
|
||||
|
||||
/**
|
||||
@@ -593,7 +598,7 @@
|
||||
* @param s stream
|
||||
*/
|
||||
|
||||
-void license_read_license_request_packet(rdpLicense* license, STREAM* s)
|
||||
+boolean license_read_license_request_packet(rdpLicense* license, STREAM* s)
|
||||
{
|
||||
/* ServerRandom (32 bytes) */
|
||||
stream_read(s, license->server_random, 32);
|
||||
@@ -608,7 +613,8 @@
|
||||
license_read_binary_blob(s, license->server_certificate);
|
||||
|
||||
/* ScopeList */
|
||||
- license_read_scope_list(s, license->scope_list);
|
||||
+ if(!license_read_scope_list(s, license->scope_list))
|
||||
+ return false;
|
||||
|
||||
/* Parse Server Certificate */
|
||||
certificate_read_server_certificate(license->certificate,
|
||||
@@ -617,6 +623,7 @@
|
||||
license_generate_keys(license);
|
||||
license_generate_hwid(license);
|
||||
license_encrypt_premaster_secret(license);
|
||||
+ return true;
|
||||
}
|
||||
|
||||
/**
|
|
@ -9,33 +9,25 @@ pkgname=freerdp
|
|||
pkgver=1.2.0_beta1+android9
|
||||
_pkgver=${pkgver/_/-}
|
||||
_pkgver=${_pkgver/+/-}
|
||||
pkgrel=1.1
|
||||
pkgrel=2
|
||||
pkgdesc="Free RDP client"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://freerdp.sourceforge.net"
|
||||
license=('GPL')
|
||||
depends=('openssl' 'libxcursor' 'libcups' 'alsa-lib' 'libxext' 'libxdamage'
|
||||
'ffmpeg' 'libxkbfile' 'libxinerama' 'libxv' 'libpulse')
|
||||
makedepends=('krb5' 'cmake' 'damageproto' 'xmlto' 'docbook-xsl')
|
||||
'ffmpeg' 'libxkbfile' 'libxinerama' 'libxv' 'libpulse' 'libxkbfile'
|
||||
'libxrender' 'libxfixes' 'gst-plugins-base-libs')
|
||||
makedepends=('krb5' 'cmake' 'damageproto' 'fixesproto' 'renderproto'
|
||||
'xmlto' 'docbook-xsl')
|
||||
conflicts=('freerdp-git')
|
||||
changelog=${pkgname}.changelog
|
||||
source=($pkgname-$pkgver.tar.gz::https://github.com/FreeRDP/FreeRDP/archive/${pkgver/_/-}.tar.gz
|
||||
ffmpeg2.0.patch
|
||||
patch_numblock.patch
|
||||
CVE-2014-0791.patch
|
||||
stuck_winkey.patch)
|
||||
build-fix.patch)
|
||||
md5sums=('a4a0a4f6e69c871aeab0600091ca6118'
|
||||
'ce01b9a60f8c57154de425e20f5884ca'
|
||||
'ac581d445ded7cdbd59082a48d9c28ac'
|
||||
'62d0ab241c16ee5d85ff89183df9bbc0'
|
||||
'1c1a8f77ebcaa7256968a9506ed3e772')
|
||||
'9e9488538fe5ab74c25e2fb69e3edf62')
|
||||
|
||||
prepare() {
|
||||
cd $srcdir/FreeRDP-${_pkgver}
|
||||
# patch -Np1 -i ../ffmpeg2.0.patch
|
||||
# patch -Np1 -i ../patch_numblock.patch
|
||||
# patch -Np1 -i ../CVE-2014-0791.patch
|
||||
# patch -Np1 -i ../stuck_winkey.patch
|
||||
patch -p1 <$srcdir/build-fix.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -48,10 +40,11 @@ build() {
|
|||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=lib \
|
||||
-DWITH_PULSEAUDIO=ON \
|
||||
-DWITH_CUPS=ON -DCHANNEL_PRINTER=ON \
|
||||
-DWITH_NEON=OFF \
|
||||
-DARM_FP_ABI=${ABI} \
|
||||
.
|
||||
make VERBOSE=1
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
13
community/freerdp/build-fix.patch
Normal file
13
community/freerdp/build-fix.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -wbBur FreeRDP-1.2.0-beta1-android9/channels/client/CMakeLists.txt FreeRDP-1.2.0-beta1-android9.my/channels/client/CMakeLists.txt
|
||||
--- FreeRDP-1.2.0-beta1-android9/channels/client/CMakeLists.txt 2014-09-12 02:46:32.000000000 +0400
|
||||
+++ FreeRDP-1.2.0-beta1-android9.my/channels/client/CMakeLists.txt 2015-02-25 14:05:27.840874974 +0300
|
||||
@@ -24,7 +24,9 @@
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/addin.c
|
||||
${CMAKE_CURRENT_SOURCE_DIR}/addin.h)
|
||||
|
||||
+if(CHANNEL_STATIC_CLIENT_ENTRIES)
|
||||
list(REMOVE_DUPLICATES CHANNEL_STATIC_CLIENT_ENTRIES)
|
||||
+endif()
|
||||
|
||||
foreach(STATIC_ENTRY ${CHANNEL_STATIC_CLIENT_ENTRIES})
|
||||
foreach(STATIC_MODULE ${CHANNEL_STATIC_CLIENT_MODULES})
|
|
@ -1,38 +0,0 @@
|
|||
diff -wbBur FreeRDP-1.1.0-beta-2013071101.org/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c FreeRDP-1.1.0-beta-2013071101/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c
|
||||
--- FreeRDP-1.1.0-beta-2013071101.org/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c 2013-07-10 12:00:21.000000000 +0400
|
||||
+++ FreeRDP-1.1.0-beta-2013071101/channels/tsmf/client/ffmpeg/tsmf_ffmpeg.c 2014-10-14 13:31:27.545141407 +0400
|
||||
@@ -37,6 +37,8 @@
|
||||
#include "tsmf_constants.h"
|
||||
#include "tsmf_decoder.h"
|
||||
|
||||
+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000
|
||||
+
|
||||
/* Compatibility with older FFmpeg */
|
||||
#if LIBAVUTIL_VERSION_MAJOR < 50
|
||||
#define AVMEDIA_TYPE_VIDEO 0
|
||||
@@ -48,7 +50,7 @@
|
||||
ITSMFDecoder iface;
|
||||
|
||||
int media_type;
|
||||
- enum CodecID codec_id;
|
||||
+ enum AVCodecID codec_id;
|
||||
AVCodecContext* codec_context;
|
||||
AVCodec* codec;
|
||||
AVFrame* frame;
|
||||
@@ -98,16 +100,6 @@
|
||||
mdecoder->codec_context->channels = media_type->Channels;
|
||||
mdecoder->codec_context->block_align = media_type->BlockAlign;
|
||||
|
||||
-#ifdef AV_CPU_FLAG_SSE2
|
||||
- mdecoder->codec_context->dsp_mask = AV_CPU_FLAG_SSE2 | AV_CPU_FLAG_MMX2;
|
||||
-#else
|
||||
-#if LIBAVCODEC_VERSION_MAJOR < 53
|
||||
- mdecoder->codec_context->dsp_mask = FF_MM_SSE2 | FF_MM_MMXEXT;
|
||||
-#else
|
||||
- mdecoder->codec_context->dsp_mask = FF_MM_SSE2 | FF_MM_MMX2;
|
||||
-#endif
|
||||
-#endif
|
||||
-
|
||||
return TRUE;
|
||||
}
|
||||
|
|
@ -1,2 +0,0 @@
|
|||
0.7.1-1 to 0.7.1-2
|
||||
* Added x86_64 to supported architectures (tested by figue).
|
|
@ -1,12 +0,0 @@
|
|||
diff -u -r -N old/include/freerdp/kbd/vkcodes.h new/include/freerdp/kbd/vkcodes.h
|
||||
--- old/include/freerdp/kbd/vkcodes.h 2013-09-19 12:46:07.124339712 +0200
|
||||
+++ new/include/freerdp/kbd/vkcodes.h 2013-09-19 12:45:51.621005583 +0200
|
||||
@@ -434,7 +434,7 @@
|
||||
{ 0x00, 0, "VK_SEPARATOR" , NULL },
|
||||
{ 0x4A, 0, "VK_SUBTRACT" , "KPSU" },
|
||||
{ 0x53, 0, "VK_DECIMAL" , "KPDL" },
|
||||
- { 0x35, 0, "VK_DIVIDE" , "KPDV" },
|
||||
+ { 0x35, 1, "VK_DIVIDE" , "KPDV" },
|
||||
{ 0x3B, 0, "VK_F1" , "FK01" },
|
||||
{ 0x3C, 0, "VK_F2" , "FK02" },
|
||||
{ 0x3D, 0, "VK_F3" , "FK03" },
|
|
@ -1,13 +0,0 @@
|
|||
diff -rup FreeRDP-1.0.2-old/client/X11/xf_keyboard.c FreeRDP-1.0.2-new/client/X11/xf_keyboard.c
|
||||
--- FreeRDP-1.0.2-old/client/X11/xf_keyboard.c 2013-01-02 22:46:59.000000000 +0100
|
||||
+++ FreeRDP-1.0.2-new/client/X11/xf_keyboard.c 2014-06-24 17:45:44.062728740 +0200
|
||||
@@ -169,6 +169,9 @@ void xf_kbd_focus_in(xfInfo* xfi)
|
||||
/* on focus in send a tab up like mstsc.exe */
|
||||
input->KeyboardEvent(input, KBD_FLAGS_RELEASE, 0x0F);
|
||||
|
||||
+ /* release windows key */
|
||||
+ input->KeyboardEvent(input, KBD_FLAGS_EXTENDED|KBD_FLAGS_RELEASE, 0x5B);
|
||||
+
|
||||
/* synchronize toggle keys */
|
||||
syncFlags = xf_kbd_get_toggle_keys_state(xfi);
|
||||
input->SynchronizeEvent(input, syncFlags);
|
Loading…
Reference in a new issue