mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
added alarm/xf86-video-armada
This commit is contained in:
parent
dedb706ddd
commit
e36d6dcc69
2 changed files with 71 additions and 0 deletions
|
@ -0,0 +1,26 @@
|
|||
From fbc0cc200f1cc2b0fd8abc6de1dbd053d45f3321 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 2 Apr 2017 01:10:04 -0600
|
||||
Subject: [PATCH] fix drm_fourcc.h include path
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
common/fourcc.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/common/fourcc.h b/common/fourcc.h
|
||||
index efe2d62..74f5c6d 100644
|
||||
--- a/common/fourcc.h
|
||||
+++ b/common/fourcc.h
|
||||
@@ -1,7 +1,7 @@
|
||||
#ifndef COMMON_FOURCC_H
|
||||
#define COMMON_FOURCC_H
|
||||
|
||||
-#include <drm/drm_fourcc.h>
|
||||
+#include <drm_fourcc.h>
|
||||
/* pick up on the Xorg fourcc.h. */
|
||||
#include <fourcc.h>
|
||||
|
||||
--
|
||||
2.12.0
|
||||
|
45
alarm/xf86-video-armada/PKGBUILD
Normal file
45
alarm/xf86-video-armada/PKGBUILD
Normal file
|
@ -0,0 +1,45 @@
|
|||
# Xorg video driver for Marvell Armada DRM and Freescale i.MX
|
||||
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
|
||||
buildarch=4
|
||||
|
||||
pkgname=xf86-video-armada
|
||||
pkgver=396.fc05021
|
||||
pkgrel=1
|
||||
pkgdesc='X.org graphics driver for Marvell Armada DRM and Freescale i.MX'
|
||||
arch=('armv7h')
|
||||
url="http://git.arm.linux.org.uk/cgit/xf86-video-armada.git/"
|
||||
license=('GPL2')
|
||||
depends=('libdrm-armada')
|
||||
makedepends=('xorg-server-devel' 'X-ABI-VIDEODRV_VERSION=23' 'git' 'libdrm')
|
||||
conflicts=('xorg-server<1.16' 'X-ABI-VIDEODRV_VERSION<23' 'X-ABI-VIDEODRV_VERSION>=24')
|
||||
options=('!libtool')
|
||||
backup=('etc/X11/xorg.conf.d/99-armada.conf')
|
||||
source=("$pkgname::git://git.arm.linux.org.uk/xf86-video-armada.git#branch=unstable-devel"
|
||||
'git+https://github.com/laanwj/etna_viv.git'
|
||||
'0001-fix-drm_fourcc.h-include-path.patch')
|
||||
md5sums=('SKIP'
|
||||
'SKIP'
|
||||
'7660a23a5204189f166e1b521eb584e7')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
echo $(git rev-list --count makepkg).$(git rev-parse --short makepkg)
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../0001-fix-drm_fourcc.h-include-path.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
./autogen.sh --prefix=/usr --disable-vivante --disable-etnaviv --with-etnaviv-source="${srcdir}/etna_viv"
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname
|
||||
make DESTDIR="${pkgdir}" install
|
||||
install -Dm644 conf/xorg-sample.conf "${pkgdir}/etc/X11/xorg.conf.d/99-armada.conf"
|
||||
}
|
Loading…
Reference in a new issue