aur updates

This commit is contained in:
Kevin Mihelich 2013-01-12 00:24:04 +00:00
parent 40cca911bd
commit e37cdd8d55
20 changed files with 357 additions and 160 deletions

View file

@ -2,16 +2,17 @@
# Maintainer: Nathan Owe <ndowens.aur at gmail dot com>
pkgname=flexget
_pkgname=FlexGet
pkgver=1.0r3208
pkgrel=1
pkgver=1.0r3214
pkgrel=2
pkgdesc="Automate downloading or processing content (torrents, podcasts, etc.)"
arch=(any)
url="http://flexget.com/"
depends=('python2' 'python2-cherrypy' 'python2-progressbar' \
'python2-pynzb' 'pyrss2gen' 'python2-sqlalchemy' 'python2-html5lib' \
'python2-beautifulsoup4>=4.1' 'python2-beautifulsoup3>=3.2' 'python2-yaml' 'python2-feedparser'
'python2-flask' 'python2-requests>=0.14' 'python2-certifi>=0.0.7'
'python2-flask' 'python2-requests-0.14' 'python2-certifi>=0.0.7'
'python2-chardet>=1.0.0' 'python2-dateutil')
optdepends=('pytransmissionrpc: Transmission support')
makedepends=('python2-distribute')
license=('MIT')
#install=('flexget.install')
@ -27,4 +28,5 @@ package() {
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
md5sums=('5bf1f41543b2a9fbe0d56dba9f110086')
md5sums=('60a6ca61dc34ba2d0cde44eb13cbca38')

View file

@ -3,7 +3,7 @@
pkgname=hd-idle
pkgver=1.04
pkgrel=1
pkgrel=2
pkgdesc='Utility program for spinning-down external disks after a period of idle time.'
arch=(i686 x86_64)
backup=(etc/conf.d/hd-idle)
@ -11,9 +11,11 @@ url="http://hd-idle.sourceforge.net/"
license=('GPL')
install="hd-idle.install"
source=("http://downloads.sf.net/$pkgname/$pkgname-$pkgver.tgz"
"hd-idle.init")
"hd-idle.init"
"hd-idle.service")
md5sums=('41e52e669fc59fa82ee0c2bcce1336d3'
'19c07682085d7fa99527c0f35073d331')
'19c07682085d7fa99527c0f35073d331'
'82cd5beede4cd11f94e61f6c8332d07c')
build() {
cd "$srcdir/$pkgname"
@ -29,6 +31,7 @@ package() {
# Install custom init script and stock defaults file:
install -Do 0 -g 0 "$srcdir/hd-idle.init" "$pkgdir/etc/rc.d/hd-idle"
install -Dpm 644 -o 0 -g 0 debian/hd-idle.default "$pkgdir/etc/conf.d/hd-idle"
install -Dm 644 "$srcdir/hd-idle.service" "$pkgdir/usr/lib/systemd/system/hd-idle.service"
# Install README:
install -Dm 644 -o 0 -g 0 README "$pkgdir/usr/share/doc/$pkgname/README"

View file

@ -0,0 +1,10 @@
[Unit]
Description=Hard drive idling daemon
[Service]
Type=forking
EnvironmentFile=/etc/conf.d/hd-idle
ExecStart=/usr/sbin/hd-idle $HD_IDLE_OPTS
[Install]
WantedBy=multi-user.target

View file

@ -6,7 +6,7 @@
pkgname=netatalk
pkgver=3.0.1
pkgrel=4
pkgrel=5
pkgdesc='A kernel-level implementation of AFP services'
arch=('i686' 'x86_64')
url='http://netatalk.sourceforge.net'
@ -26,7 +26,8 @@ build() {
sed -i 's/x"linux/x"generic/' macros/netatalk.m4
sed -i 's:/lib:/usr/lib:' distrib/initscripts/Makefile.{am,in}
sed -i 's:model=%s:model:' etc/afpd/afp_mdns.c
autoreconf &>/dev/null
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' {configure.ac,libevent/configure.in}
autoreconf -i >/dev/null
msg2 'Configuring...'
CFLAGS="-Wno-unused-result" ./configure --prefix=/usr --localstatedir=/var/state --sysconfdir=/etc --with-init-style=systemd \
--with-cracklib --with-cnid-cdb-backend --enable-pgp-uam --without-libevent-header --without-libevent-lib

View file

@ -1,3 +1,9 @@
2013-01-05 SJ_UnderWater
* 3.0.1-5:
fixed AM deprecations
minor install fix
2012-11-28 SJ_UnderWater
* 3.0.1-4 :

View file

@ -2,12 +2,13 @@ post_install() {
post_upgrade
}
post_upgrade() {
if [ -f /etc/rc.conf ] && [ "`grep -E '(cnid|atalkd|afpd)' /etc/rc.conf`" ];then
if [ -f /etc/rc.conf ];then
if [ "`grep -E '(cnid|atalkd|afpd)' /etc/rc.conf`" ];then
echo '>>> Detected old netatalk daemon entries in';
echo '>>> /etc/rc.conf, please replace these with';
echo '>>> "netatalk" before restarting!';
else echo '>>> Add "netatalk" to your DAEMONS list';fi
echo '>>>';
fi
if [ -f /etc/avahi/services/adisk.service ] ||
[ -f /etc/avahi/services/afpd.service ];then
echo '>>> Detected old netatalk service files in';

View file

@ -3,16 +3,15 @@
_pkgname=pithos
pkgname=pithos-git
pkgver=20121024
pkgver=20130108
pkgrel=1
pkgdesc='Pandora Internet Radio player for GNOME'
arch=('any')
url="http://kevinmehall.net/p/pithos/"
license=('GPL3')
depends=('python2' 'pygtk' 'python2-notify' 'dbus-python' 'gstreamer0.10-python' 'gstreamer0.10-good-plugins' 'gstreamer0.10-bad-plugins' 'gstreamer0.10-base-plugins' 'pyxdg' 'hicolor-icon-theme')
depends=('python2' 'pygtk' 'python2-notify' 'python2-dbus' 'gstreamer0.10-python' 'gstreamer0.10-good-plugins' 'gstreamer0.10-bad-plugins' 'gstreamer0.10-base-plugins' 'python2-xdg' 'hicolor-icon-theme')
makedepends=('git' 'python2-distribute' 'python2-distutils-extra')
#makedepends=('git' 'python2-distribute')
optdepends=('python-keybinder: for media keys plugin'
optdepends=('python2-keybinder2: for media keys plugin'
'gstreamer0.10-ugly-plugins: MP3 playback support')
provides=("$_pkgname")
conflicts=("$_pkgname-bzr" "$_pkgname")

View file

@ -1,32 +1,28 @@
pkgname=sabnzbd
_pkgname=SABnzbd
pkgver=0.7.6
pkgver=0.7.9
pkgrel=1
pkgdesc="A web-interface based binary newsgrabber with NZB file support"
url="http://www.sabnzbd.org"
arch=("any")
license=("GPL")
depends=("curl" "par2cmdline"
"python2" "python2-cheetah" "python2-feedparser" "python2-pyopenssl" "python2-yenc"
"python2" "python2-cheetah" "python2-yenc"
"sqlite" "unrar" "unzip")
optdepends=("xdg-utils: registration of .nzb files")
optdepends=("xdg-utils: registration of .nzb files" "python2-feedparser: rss support" "python2-pyopenssl: ssl support")
install="${pkgname}.install"
backup=("etc/conf.d/${pkgname}" "opt/${pkgname}/${pkgname}.ini" "etc/conf.d/${pkgname}_systemd")
backup=("etc/conf.d/sabnzbd" "opt/${pkgname}/${pkgname}.ini")
source=("http://downloads.sourceforge.net/sabnzbdplus/${_pkgname}-${pkgver}-src.tar.gz"
"${pkgname}" "${pkgname}.confd" "${pkgname}.init" "${pkgname}.desktop"
"addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}_systemd.confd" "${pkgname}.tmp")
md5sums=('2d88fc29b65caec28d57ba7de36d31b0'
"${pkgname}" "${pkgname}.desktop" "addnzb.sh" "nzb-2.png" "sab2_64.png" "x-nzb.xml" "${pkgname}.service" "${pkgname}.confd")
md5sums=('175edddbdcc8b2be51f0987c19bff0ae'
'48d60a1c626503c7fef1bc5374390513'
'7d7ae7cca08e90582587773da3b55de8'
'848c7b117388671f243bd0833ff41f89'
'f9bd5485072714b11f8c30a28024dc4d'
'c0d52ba8d47f731790cd717fde46b829'
'69b9bcbcf67ff3e7a4cdd9f26e001341'
'2a49c07b1e3e6448eabe92644315f983'
'fdc878dd0f6f25617e627b04409abbbd'
'11fb2cd1451e3725b08bfc2bd045be54'
'cc154e71046495c5768d2998b4b0fb0f'
'321a56d66a971c833677a54bc3f1060d'
'1ced962fabe7f5392e32828429b93d04')
'd64b7a6609279a6ba1fcb04e8f36dcd1'
'8fc2607a7961fc643ef4f6640166322a')
package() {
mkdir -p "${pkgdir}/opt/${pkgname}"
@ -41,10 +37,7 @@ package() {
chmod 755 "${pkgdir}/opt/${pkgname}/Sample-PostProc.sh"
install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm755 "${srcdir}/${pkgname}.init" "${pkgdir}/etc/rc.d/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}.confd" "${pkgdir}/etc/conf.d/${pkgname}"
install -Dm644 "${srcdir}/${pkgname}_systemd.confd" "${pkgdir}/etc/conf.d/${pkgname}_systemd"
install -Dm644 "${srcdir}/${pkgname}.tmp" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm755 "${srcdir}/${pkgname}.desktop" \
"${pkgdir}/usr/share/applications/${pkgname}.desktop"

View file

@ -1,14 +1,4 @@
#!/bin/bash
set -a # export all variables
#!/bin/sh
. /etc/conf.d/sabnzbd
# SABnzbd must be able to read the file, so we copy it to a directory where it
# certainly has rights.
nzbname=$(basename "$1")
TEMP_NZB="/var/tmp/$nzbname"
curl -s $(python2 -c 'import urlparse,urllib,sys; print sys.argv[1] if urlparse.urlparse(sys.argv[1]).scheme else urlparse.urlparse(urllib.pathname2url(sys.argv[1]),"file").geturl()' "$1") -o "$TEMP_NZB"
curl -f $(python2 -c 'import urllib,os; print os.environ["SABNZBD_PROTOCOL"]+"://"+urllib.quote(os.environ["SABNZBD_USPW"]+os.environ["SABNZBD_IP"])+":"+os.environ["SABNZBD_PORT"]+"/sabnzbd/api?mode=addlocalfile&name="+urllib.quote(os.environ["TEMP_NZB"])+"&apikey="+urllib.quote(os.environ["NZB_KEY"])')
rm "$TEMP_NZB"
exit 0
. /etc/conf.d/sabnzbd
curl -s -F apikey="$API_KEY" -F mode="addfile" -F name=@"$1" $URL/sabnzbd/api &> /dev/null

View file

@ -1,23 +1,8 @@
# Set the protocol, IP and port
SABNZBD_PROTOCOL="http"
SABNZBD_IP="127.0.0.1"
SABNZBD_PORT="8080"
# This file is used to make association of .nzb files with SABnzbd possible.
# If you do not want this feature, you do no have to fill in these settings.
# Set your default user/group(id), startarguments and your configfile
USE_SYSTEM_IDS="1"
SABNZBD_DIR="/opt/sabnzbd"
#SABNZBD_UID="423"
#SABNZBD_GID="423"
SABNZBD_USER="sabnzbd"
SABNZBD_GROUP="sabnzbd"
#SABNZBD_AGROUP="users" # separate groups by ,
SABNZBD_CONF="${SABNZBD_DIR}/sabnzbd.ini"
SABNZBD_ARGS="-f ${SABNZBD_CONF} -s ${SABNZBD_IP}:${SABNZBD_PORT} -d"
# The SABnzbd url. Make sure to add a username and password if required
URL="http://127.0.0.1:8080"
# Put the session keys from Config > General here
SABNZBD_KEY=""
NZB_KEY=""
# If you use a username and password, change the following variable to
# "user:pass@"
SABNZBD_USPW=""
# Put the API key from Config > General here
API_KEY=""

View file

@ -1,7 +1,13 @@
# Change these to modify the ownership of sabnzbd
# If you change this here, you also have to change
# the user and group in the systemd service file.
SABNZBD_USER="sabnzbd"
SABNZBD_GROUP="sabnzbd"
SABNZBD_DIR="/opt/sabnzbd" # should not be changed
## arg 1: the new package version
post_install() {
. /etc/conf.d/sabnzbd
# add x-nzb mimetype
xdg-mime install --mode system "${SABNZBD_DIR}/x-nzb.xml"
xdg-icon-resource install --context mimetypes --size 64 "${SABNZBD_DIR}/nzb-2.png" application-x-nzb
@ -9,8 +15,6 @@ post_install() {
post_upgrade
cat << "EOM"
==> Don't forget to edit /etc/conf.d/sabnzbd or /etc/conf.d/sabnzbd_systemd!
==> Add your Session key and if necessary your username and password to ensure a proper shutdown.
==> If you want to associate .nzb-files with SABnzbd, run 'xdg-mime default sabnzbd.desktop applications/x-nzb'
EOM
}
@ -19,76 +23,31 @@ EOM
## arg 2: the old package version
pre_upgrade() {
PID="$(pgrep -f SABnzbd.py)"
if [ -f /run/daemons/sabnzbd ]; then
/etc/rc.d/sabnzbd stop # kill the daemon
if [ -n "${PID}" ];then
kill "${PID}" # kill the daemon finaly
fi
fi
if [[ -d "/run/sabnzbd/" && "$(ls -A /run/sabnzbd/)" ]]; then
if [ -n "${PID}" ];then
systemctl stop sabnzbd.service
fi
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
. /etc/conf.d/sabnzbd
# if the group or user already exists, the request will be denied
# and all original settings will be retained
if [ "$SABNZBD_GROUP" == "sabnzbd" ]; then
groupadd -r sabnzbd &> /dev/null
fi
if [ "${USE_SYSTEM_IDS}" == "1" ]; then
if grep -q "^sabnzbd:" /etc/group &> /dev/null; then
if grep -q "^SABNZBD_GID=" /etc/conf.d/sabnzbd &> /dev/null; then
groupmod -g "${SABNZBD_GID}" -n sabnzbd sabnzbd &> /dev/null
else
groupmod -r -n sabnzbd sabnzbd &> /dev/null
fi
else
if grep -q "^SABNZBD_GID=" /etc/conf.d/sabnzbd &> /dev/null; then
groupadd -g "${SABNZBD_GID}" sabnzbd &> /dev/null
else
groupadd -r sabnzbd &> /dev/null
fi
fi
if grep -q "^SABNZBD_AGROUP=" /etc/conf.d/sabnzbd &> /dev/null; then
SABNZBD_GS="-G ${SABNZBD_AGROUP}"
else
SABNZBD_GS=""
fi
if grep -q "^sabnzbd:" /etc/passwd 2> /dev/null; then
if grep -q "^SABNZBD_UID=" /etc/conf.d/sabnzbd &> /dev/null; then
usermod -s /sbin/nologin -c "SABnzbd user" -d "${SABNZBD_DIR}" \
-u "${SABNZBD_UID}" -g sabnzbd ${SABNZBD_GS} sabnzbd &> /dev/null
else
usermod -s /sbin/nologin -c "SABnzbd user" -d "${SABNZBD_DIR}" \
-g sabnzbd ${SABNZBD_GS} -r sabnzbd &> /dev/null
fi
else
if grep -q "^SABNZBD_UID=" /etc/conf.d/sabnzbd &> /dev/null; then
useradd -s /sbin/nologin -c "SABnzbd user" -d "${SABNZBD_DIR}" \
-u ${SABNZBD_UID} -g sabnzbd "${SABNZBD_GS}" -r sabnzbd &> /dev/null
else
useradd -s /sbin/nologin -c "SABnzbd user" -d "${SABNZBD_DIR}" \
-g sabnzbd ${SABNZBD_GS} -r sabnzbd &> /dev/null
fi
fi
if [ "$SABNZBD_USER" == "sabnzbd" ]; then
useradd -s /sbin/nologin -c "SABnzbd user" -d "${SABNZBD_DIR}" \
-g sabnzbd -r sabnzbd &> /dev/null
fi
chown -R "${SABNZBD_USER}:${SABNZBD_GROUP}" "${SABNZBD_DIR}"
if command -v "systemd-tmpfiles" &> /dev/null; then
systemd-tmpfiles --create /usr/lib/tmpfiles.d/sabnzbd.conf
fi
}
## arg 1: the old package version
pre_remove() {
. /etc/conf.d/sabnzbd
pre_upgrade
xdg-mime uninstall --mode system "${SABNZBD_DIR}/x-nzb.xml"
@ -97,9 +56,10 @@ pre_remove() {
## arg 1: the old package version
post_remove() {
userdel sabnzbd &> /dev/null
# only delete if user is sabnzbd
userdel sabnzbd &> /dev/null
groupdel sabnzbd &> /dev/null || /bin/true
echo "==> There may be some files left in /opt/sabnzbd."
echo "==> There may be some files left in ${SABNZBD_DIR}."
}
# vim:set ts=2 sw=2 et:

View file

@ -3,11 +3,8 @@ Description=SABnzbd binary newsreader
After=network.target
[Service]
EnvironmentFile=/etc/conf.d/sabnzbd_systemd
ExecStart=/bin/sh -c "python2 ${SABNZBD_DIR}/SABnzbd.py ${SABNZBD_ARGS} --pid /run/sabnzbd"
ExecStop=/usr/bin/curl -f "${SABNZBD_PROTOCOL}://${SABNZBD_USPW}${SABNZBD_IP}:${SABNZBD_PORT}/sabnzbd/api?mode=shutdown&apikey=${SABNZBD_KEY}"
Type=forking
PIDFile=/run/sabnzbd/sabnzbd-8080.pid
Type=simple
ExecStart=/bin/sh -c "python2 /opt/sabnzbd/SABnzbd.py -l0"
User=sabnzbd
Group=sabnzbd

View file

@ -1,11 +1,11 @@
# Maintainer: sudokode <sudokode@gmail.com>>
# Maintainer: sudokode <sudokode@gmail.com>
# Previous Maintainer: Crass00 <crass00 at hotmail dot com>
# Previous Maintainer: Superstar655 <choman000 at hotmail dot com>
# Contributor: Augusto Born de Oliveira <augustoborn at gmail dot com>
pkgname=sickbeard-git
pkgver=20120724
pkgrel=1
pkgver=20121109
pkgrel=2
pkgdesc="A PVR application that downloads and manages your TV shows"
arch=(any)
url="http://code.google.com/p/sickbeard/"
@ -13,15 +13,15 @@ license=(GPL3)
depends=(python2 python2-cheetah)
makedepends=(git)
optdepends=('sabnzbd: NZB downloader'
'python-notify: desktop notifications')
'python-notify: desktop notifications')
install=sickbeard.install
backup=('etc/conf.d/sickbeard')
conflicts=(sickbeard)
source=('sickbeard' 'sickbeard.init' 'sickbeard.confd' 'sickbeard.service' 'sickbeard.tmpfile')
md5sums=('67f346e3e217c38db3f5f9250a2f3fa2'
'276747cb646524bbee02e1b1c7cd537c'
'b9ab9c22027905338b8edda3531f48f2'
'17964f6ca27e2fe7936888edd447d2d7'
source=('sickbeard.init' 'sickbeard.confd' 'sickbeard-system.service' 'sickbeard-user.service' 'sickbeard.tmpfile')
md5sums=('276747cb646524bbee02e1b1c7cd537c'
'b98110609108a554e8349552dc84ea9f'
'a80cd5ff963fd75b5d65a8671b21d831'
'2455963553a4ca61957fc61e509a9d15'
'08bbd75c6cf2ef3e4797d9221f0ce385')
_gitroot="git://github.com/midgetspy/Sick-Beard.git"
@ -45,14 +45,15 @@ build() {
package() {
mkdir -p "${pkgdir}/opt/"
cp -r "$srcdir/$_gitname" "${pkgdir}/opt/sickbeard"
chmod 775 "${pkgdir}/opt/sickbeard"
sed -i 's/python/python2/g' "${pkgdir}/opt/sickbeard/autoProcessTV/sabToSickBeard.py"
sed -i 's/python/python2/g' "${pkgdir}/opt/sickbeard/autoProcessTV/hellaToSickBeard.py"
install -D -m755 "${srcdir}/sickbeard" "${pkgdir}/usr/bin/sickbeard"
install -D -m755 "${srcdir}/sickbeard.init" "${pkgdir}/etc/rc.d/sickbeard"
install -D -m644 "${srcdir}/sickbeard.confd" "${pkgdir}/etc/conf.d/sickbeard"
install -D -m644 "${srcdir}/sickbeard.service" "${pkgdir}/usr/lib/systemd/system/sickbeard.service"
install -D -m644 "${srcdir}/sickbeard-system.service" "${pkgdir}/usr/lib/systemd/system/sickbeard.service"
install -D -m644 "${srcdir}/sickbeard-user.service" "${pkgdir}/usr/lib/systemd/user/sickbeard.service"
install -D -m644 "${srcdir}/sickbeard.tmpfile" "${pkgdir}/usr/lib/tmpfiles.d/sickbeard.conf"
}

View file

@ -0,0 +1,11 @@
[Unit]
Description=SickBeard Daemon
After=network.target
[Service]
User=sickbeard
Group=sickbeard
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config /opt/sickbeard/config.ini --datadir /opt/sickbeard
[Install]
WantedBy=multi-user.target

View file

@ -0,0 +1,8 @@
[Unit]
Description=SickBeard Daemon
[Service]
ExecStart=/usr/bin/env python2 /opt/sickbeard/SickBeard.py --config %h/.sickbeard/config.ini --datadir %h/.sickbeard
[Install]
WantedBy=default.target

View file

@ -4,6 +4,7 @@
# Leave blank to run as the current user (likely root).
# If you change the user, you must now modify the sickbeard tmpfiles config file.
# To do that, copy /usr/lib/tmpfiles.d/sickbeard.conf to /etc/tmpfiles.d/sickbeard.conf and modify the user in that file.
# You also need to change the datadir to somewhere writable by that user by adding it to the SB_ARGS, e.g. --datadir=/home/$USER/.sickbeard
SB_USER="sickbeard"
# Sick Beard arguments

View file

@ -13,7 +13,7 @@ post_install() {
groupadd sickbeard &> /dev/null
useradd -g sickbeard -d /opt/sickbeard -s /bin/false sickbeard &> /dev/null
chown -R sickbeard:sickbeard /opt/sickbeard
chgrp -R sickbeard /opt/sickbeard
# sed -i 's/^if isinstance(sys.version_info, tuple):$/if isinstance(sys.version_info[:], tuple):/g' "/usr/lib/python2.7/site-packages/Cheetah/Template.py"
# Create a directory in /run if it does not exist
@ -22,11 +22,17 @@ post_install() {
chown sickbeard:sickbeard /run/sickbeard
chmod 775 /run/sickbeard
fi
echo "You can now run sickbeard as a user service with 'systemctl --user start sickbeard'."
echo "To make this work, first run 'mkdir ~/.sickbeard'. This will run sickbeard as your user."
echo "The system service will run it as the sickbeard user."
echo "If you have a previous install and want to keep the same show database, cache, etc., you can"
echo "run 'cp -r /opt/sickbeard/{Logs,cache,cache.db,config.ini,sickbeard.db} ~/.sickbeard'."
}
## arg 1: the new package version
## arg 2: the old package version
post_upgrade() {
chown -R sickbeard:sickbeard /opt/sickbeard
chgrp -R sickbeard /opt/sickbeard
sed -i 's/^if isinstance(sys.version_info, tuple):$/if isinstance(sys.version_info[:], tuple):/g' "/usr/lib/python2.7/site-packages/Cheetah/Template.py"
# Create a directory in /run if it does not exist
@ -36,6 +42,11 @@ post_upgrade() {
chmod 775 /run/sickbeard
fi
echo "You can now run sickbeard as a user service with 'systemctl --user start sickbeard'."
echo "To make this work, first run 'mkdir ~/.sickbeard'. This will run sickbeard as your user."
echo "The system service will run it as the sickbeard user."
echo "If you have a previous install and want to keep the same show database, cache, etc., you can"
echo "run 'cp -r /opt/sickbeard/{Logs,cache,cache.db,config.ini,sickbeard.db} ~/.sickbeard'."
}
## arg 1: the old package version

View file

@ -1,13 +1,13 @@
# Maintainer: Michael Frey <mail@mfrey.net>
pkgname=uthash
pkgver=1.9.6
pkgver=1.9.7
pkgrel=1
pkgdesc="uthash provides C preprocessor implementations of a hash table and a linked list"
arch=('any')
url="http://uthash.sourceforge.net/"
license=('BSD')
source=(http://downloads.sourceforge.net/uthash/$pkgname-$pkgver.tar.bz2)
sha512sums=('ff03644b5e7cdf59a87e856052c84f68ee15c343b6d83a286f68a1b5aabed40e1f4bebc063602e0840954db391354c9078a29811a47aa901aac1cc23ab35018f')
sha512sums=('8c02f9ac846a6bfd7292724a3683ae360ff37bba8e3ca98fca106da84976cac9c61766069989ee2c633b20bf82b64658400687a7cfbccab5e98e5fb6cb2e5caa')
package() {
cd "${srcdir}/${pkgname}-${pkgver}/src"

View file

@ -1,34 +1,45 @@
buildarch=6
# Maintainer: Jeff Cook <jeff@deserettechnology.com>
# Contributor: Jeff Cook <jeff@deserettechnology.com>
# Contributor: Michael Asher < michael at we solve every thing dot com >
# Contributor: William Díaz <wdiaz@archlinux.us>
# Contributor: William Díaz <wdiaz@archlinux.us>
# Maintainer: vwyodajl <donjuansjiz GmaIL com>
### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
### Please ask support questions about this software in one of:
### 1) The AUR comments; OR
### 2) Upstream forums/maillist etc; OR
### 3) The ArchLinux forums
### I do not always know enough about the software itself, or don't have the
### time to promptly respond to direct emails.
### If you have found a problem with the package/PKGBUILD (as opposed to
### the software) then please do email me or post an AUR comment.
pkgname=uuid
pkgver=1.6.2
pkgrel=8
pkgrel=11
pkgdesc="OSSP Universally Unique Identifier"
arch=('i686' 'x86_64')
url="http://www.ossp.org/pkg/lib/uuid"
license=('MIT')
depends=('sh')
makedepends=('perl')
options=('libtool')
options=('!libtool')
source=("http://old-www.mirrorservice.org/sites/ftp.ossp.org/pkg/lib/${pkgname}/${pkgname}-${pkgver}.tar.gz"
makefile.patch)
ossp.patch)
md5sums=('5db0d43a9022a6ebbbc25337ae28942f'
'6936c429a4ed735ebc36adcf66bb1637')
'6f0591cfa3e6d5f70c290963d2c5a0a0')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -p1 < ${srcdir}/makefile.patch
cd ${pkgname}-${pkgver}
# Rename because conflicts with util-linux
patch -p1 -i "${srcdir}"/ossp.patch
./configure --prefix=/usr --with-perl
make
}
package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
install -Dm644 README \
"${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}

207
aur/uuid/ossp.patch Normal file
View file

@ -0,0 +1,207 @@
diff -up uuid-1.6.1/uuid-config.in.BAD uuid-1.6.1/uuid-config.in
--- uuid-1.6.1/uuid-config.in.BAD 2008-03-06 11:56:13.000000000 -0500
+++ uuid-1.6.1/uuid-config.in 2008-03-06 11:56:25.000000000 -0500
@@ -121,7 +121,7 @@ do
output_extra="$output_extra $uuid_ldflags"
;;
--libs)
- output="$output -luuid"
+ output="$output -lossp-uuid"
output_extra="$output_extra $uuid_libs"
;;
* )
diff -up uuid-1.6.1/Makefile.in.BAD uuid-1.6.1/Makefile.in
--- uuid-1.6.1/Makefile.in.BAD 2008-03-06 11:10:13.000000000 -0500
+++ uuid-1.6.1/Makefile.in 2008-03-06 11:11:39.000000000 -0500
@@ -62,13 +62,13 @@ PERL = @PERL@
PHP = @PHP@
PG_CONFIG = @PG_CONFIG@
-LIB_NAME = libuuid.la
+LIB_NAME = libossp-uuid.la
LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
-DCE_NAME = libuuid_dce.la
+DCE_NAME = libossp-uuid_dce.la
DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
-CXX_NAME = libuuid++.la
+CXX_NAME = libossp-uuid++.la
CXX_OBJS = uuid++.lo $(LIB_OBJS)
PRG_NAME = uuid
@@ -79,10 +79,10 @@ MAN_NAME = uuid.3 uuid++.3 uuid.1
PERL_NAME = $(S)/perl/blib/lib/OSSP/uuid.pm
PERL_OBJS = $(S)/perl/uuid.pm
-PHP_NAME = $(S)/php/modules/uuid.so
+PHP_NAME = $(S)/php/modules/ossp-uuid.so
PHP_OBJS = $(S)/php/uuid.c
-PGSQL_NAME = $(S)/pgsql/libuuid.so
+PGSQL_NAME = $(S)/pgsql/libossp-uuid.so
PGSQL_OBJS = $(S)/pgsql/uuid.c
TARGETS = $(LIB_NAME) @DCE_NAME@ @CXX_NAME@ $(PRG_NAME) @PERL_NAME@ @PHP_NAME@ @PGSQL_NAME@
@@ -231,7 +231,7 @@ install:
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
$(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
$(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/
+ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
$(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
-@if [ ".$(WITH_DCE)" = .yes ]; then \
echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
@@ -241,7 +241,7 @@ install:
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
fi
- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
+ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
-@if [ ".$(WITH_CXX)" = .yes ]; then \
echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
@@ -276,7 +276,7 @@ uninstall:
-@if [ ".$(WITH_CXX)" = .yes ]; then \
$(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/$(CXX_NAME); \
fi
- -$(RM) $(DESTDIR)$(mandir)/man3/uuid.3
+ -$(RM) $(DESTDIR)$(mandir)/man3/ossp-uuid.3
-@if [ ".$(WITH_CXX)" = .yes ]; then \
echo "$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3"; \
$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3; \
@@ -290,7 +290,7 @@ uninstall:
echo "$(RM) $(DESTDIR)$(includedir)/uuid++.hh"; \
$(RM) $(DESTDIR)$(includedir)/uuid++.hh; \
fi
- -$(RM) $(DESTDIR)$(libdir)/pkgconfig/uuid.pc
+ -$(RM) $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
-$(RM) $(DESTDIR)$(mandir)/man1/uuid-config.1
-$(RM) $(DESTDIR)$(bindir)/uuid-config
-$(RMDIR) $(DESTDIR)$(mandir)/man1 >/dev/null 2>&1 || $(TRUE)
diff -up uuid-1.6.1/pgsql/Makefile.BAD uuid-1.6.1/pgsql/Makefile
--- uuid-1.6.1/pgsql/Makefile.BAD 2008-03-06 11:53:26.000000000 -0500
+++ uuid-1.6.1/pgsql/Makefile 2008-03-06 11:54:14.000000000 -0500
@@ -18,13 +18,13 @@ POSTGRES := $(shell $(PG_CONFIG
top_builddir := $(dir $(PGXS))../..
include $(top_builddir)/src/Makefile.global
-NAME = uuid
+NAME = ossp-uuid
OBJS = uuid.o
SO_MAJOR_VERSION = 1
SO_MINOR_VERSION = 0
override CPPFLAGS := -I.. $(CPPFLAGS)
-SHLIB_LINK := -L../.libs -luuid
+SHLIB_LINK := -L../.libs -lossp-uuid
SHLIB_LINK += $(shell test $(shell uname -s) = FreeBSD && echo "-Wl,-Bsymbolic")
SHLIB_LINK += $(shell test $(shell uname -s) = Darwin && echo "-bundle_loader $(POSTGRES)")
rpath :=
@@ -35,16 +35,16 @@ enable_shared = yes
include $(top_builddir)/src/Makefile.shlib
uuid.sql: uuid.sql.in
- sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
+ sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
install: all
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)
$(mkinstalldirs) $(DESTDIR)$(datadir)
- $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
+ $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
$(INSTALL_DATA) uuid.sql $(DESTDIR)$(datadir)/uuid.sql
uninstall:
- -rm -f $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
+ -rm -f $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
-rm -f $(DESTDIR)$(datadir)/uuid.sql
clean distclean: clean-lib
diff -up uuid-1.6.1/uuid.pc.in.BAD uuid-1.6.1/uuid.pc.in
--- uuid-1.6.1/uuid.pc.in.BAD 2008-03-06 11:57:29.000000000 -0500
+++ uuid-1.6.1/uuid.pc.in 2008-03-06 11:57:36.000000000 -0500
@@ -37,6 +37,6 @@ Description: Universally Unique Identifi
Version: @UUID_VERSION_RAW@
URL: http://www.ossp.org/pkg/lib/uuid/
Cflags: -I${includedir}
-Libs: -L${libdir} -luuid
+Libs: -L${libdir} -lossp-uuid
Libs.private: @LIBS@
diff -up uuid-1.6.1/perl/Makefile.PL.BAD uuid-1.6.1/perl/Makefile.PL
--- uuid-1.6.1/perl/Makefile.PL.BAD 2008-03-06 11:12:05.000000000 -0500
+++ uuid-1.6.1/perl/Makefile.PL 2008-03-06 11:49:25.000000000 -0500
@@ -33,9 +33,9 @@ use Config;
use ExtUtils::MakeMaker;
# determine source directory
-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
- or die "no source directory found (where libuuid.la is located)";
+my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
+ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
+ or die "no source directory found (where libossp-uuid.la is located)";
# determine extra build options
my $compat = 0;
@@ -47,7 +47,7 @@ WriteMakefile(
VERSION_FROM => 'uuid.pm',
ABSTRACT_FROM => 'uuid.pod',
PREREQ_PM => {},
- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
+ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
DEFINE => '',
INC => "-I. -I$srcdir",
PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
diff -up uuid-1.6.1/Makefile.PL.BAD uuid-1.6.1/Makefile.PL
--- uuid-1.6.1/Makefile.PL.BAD 2008-03-06 11:09:49.000000000 -0500
+++ uuid-1.6.1/Makefile.PL 2008-03-06 11:10:01.000000000 -0500
@@ -44,7 +44,7 @@ ARGS = $ARGS
all pure_all:
\@if [ ! -d build ]; then mkdir build; fi
\@if [ ! -f build/Makefile ]; then (cd build && ../configure --disable-shared); fi
- \@if [ ! -f build/libuuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libuuid.la); fi
+ \@if [ ! -f build/libossp-uuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libossp-uuid.la); fi
\@if [ ! -f perl/Makefile ]; then (cd perl && \$(PERL) Makefile.PL \$(ARGS)); fi
\@cd perl && \$(MAKE) \$(MFLAGS) \$\@
diff -up uuid-1.6.1/php/config.m4.BAD uuid-1.6.1/php/config.m4
--- uuid-1.6.1/php/config.m4.BAD 2008-03-06 11:54:55.000000000 -0500
+++ uuid-1.6.1/php/config.m4 2008-03-06 11:55:07.000000000 -0500
@@ -34,7 +34,7 @@ if test "$PHP_UUID" != "no"; then
PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
PHP_ADD_LIBPATH([..], )
- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
+ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
PHP_ADD_INCLUDE([..])
PHP_SUBST(UUID_SHARED_LIBADD)
diff -up uuid-1.6.1/php/Makefile.local.BAD uuid-1.6.1/php/Makefile.local
--- uuid-1.6.1/php/Makefile.local.BAD 2008-03-06 11:54:39.000000000 -0500
+++ uuid-1.6.1/php/Makefile.local 2008-03-06 11:54:49.000000000 -0500
@@ -48,7 +48,7 @@ install: build
@version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
echo "installing PHP$$version API into $$extdir"; \
./build/shtool mkdir -f -p -m 755 $(DESTDIR)$$extdir; \
- ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/uuid.so; \
+ ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/ossp-uuid.so; \
./build/shtool install -c -m 644 uuid.php$$version $(DESTDIR)$$extdir/uuid.php
clean:
diff -up uuid-1.6.1/php/uuid.ts.BAD uuid-1.6.1/php/uuid.ts
--- uuid-1.6.1/php/uuid.ts.BAD 2008-03-06 11:55:38.000000000 -0500
+++ uuid-1.6.1/php/uuid.ts 2008-03-06 11:56:03.000000000 -0500
@@ -34,9 +34,9 @@
$php_version = $argv[1];
-print "++ loading DSO uuid.so (low-level API)\n";
+print "++ loading DSO ossp-uuid.so (low-level API)\n";
if (!extension_loaded('uuid')) {
- dl('modules/uuid.so');
+ dl('modules/ossp-uuid.so');
}
print "++ loading PHP uuid.php${php_version} (high-level API)\n";