mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5-webkit to 5.212.0alpha2-7
This commit is contained in:
parent
b9226f46fe
commit
e385326eea
2 changed files with 22 additions and 1 deletions
|
@ -12,7 +12,7 @@ highmem=1
|
|||
pkgname=qt5-webkit
|
||||
_qtver=5.212.0-alpha2
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=6
|
||||
pkgrel=7
|
||||
arch=(i686 x86_64)
|
||||
url='http://qt-project.org/'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
|
@ -26,11 +26,13 @@ groups=(qt qt5)
|
|||
_pkgfqn="${pkgname/5-/}-opensource-src-${_qtver}"
|
||||
source=("https://github.com/annulen/webkit/releases/download/qtwebkit-$_qtver/qtwebkit-$_qtver.tar.xz"
|
||||
qt5-webkit-gcc7.patch
|
||||
qt5-webkit-null-pointer-dereference.patch
|
||||
qt5-webkit-trojita-1.patch::"https://github.com/annulen/webkit/commit/6faf1121.patch"
|
||||
qt5-webkit-trojita-2.patch::"https://github.com/annulen/webkit/commit/76420459.patch"
|
||||
atomic.patch)
|
||||
sha256sums=('f8f901de567e11fc5659402b6b827eac75505ff9c5072d8e919aa306003f8f8a'
|
||||
'f108833562d766d4c086026f9202b2ebc8c19e97fddedce952afed78df3c0720'
|
||||
'510e1f78c2bcd76909703a097dbc1d5c9c6ce4cd94883c26138f09cc10121f43'
|
||||
'bd22bd7842d5ad1cb1f5a4b6acb2674509732274d5f9dc51943144dff76996ae'
|
||||
'b42b70fd2a4a36b0ff48fc4e0dc386b3dda373e6fec18f3be9f5e2d3b04e0aa3'
|
||||
'23fbd785daf116c71b3ce87d40860f0a6c56ab1065ee98ec41634626ca961129')
|
||||
|
@ -44,6 +46,8 @@ prepare() {
|
|||
# Fix layout issues in trojita https://github.com/annulen/webkit/issues/511
|
||||
patch -p1 -i ../qt5-webkit-trojita-1.patch
|
||||
patch -p1 -i ../qt5-webkit-trojita-2.patch
|
||||
# Fix null point dereference (Fedora) https://github.com/annulen/webkit/issues/573
|
||||
patch -p1 -i ../qt5-webkit-null-pointer-dereference.patch
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
|
|
17
extra/qt5-webkit/qt5-webkit-null-pointer-dereference.patch
Normal file
17
extra/qt5-webkit/qt5-webkit-null-pointer-dereference.patch
Normal file
|
@ -0,0 +1,17 @@
|
|||
diff -ur qtwebkit-5.212.0-alpha2/Source/WebKit/qt/WebCoreSupport/QWebPageAdapter.cpp
|
||||
qtwebkit-5.212.0-alpha2-fix-null-pointer-dereference/Source/WebKit/qt/WebCoreSupport/QWebPageAdapter.cpp
|
||||
--- qtwebkit-5.212.0-alpha2/Source/WebKit/qt/WebCoreSupport/QWebPageAdapter.cpp 2017-06-09 16:11:36.000000000 +0200
|
||||
+++ qtwebkit-5.212.0-alpha2-fix-null-pointer-dereference/Source/WebKit/qt/WebCoreSupport/QWebPageAdapter.cpp 2017-10-24 21:44:40.504943501
|
||||
+0200
|
||||
@@ -390,7 +390,10 @@
|
||||
|
||||
QString QWebPageAdapter::selectedHtml() const
|
||||
{
|
||||
- return page->focusController().focusedOrMainFrame().editor().selectedRange()->toHTML();
|
||||
+ RefPtr<Range> range = page->focusController().focusedOrMainFrame().editor().selectedRange();
|
||||
+ if (!range)
|
||||
+ return QString();
|
||||
+ return range->toHTML();
|
||||
}
|
||||
|
||||
bool QWebPageAdapter::isContentEditable() const
|
Loading…
Reference in a new issue