mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-aarch64-rc to 4.10.rc2-1
This commit is contained in:
parent
be7bad6c06
commit
e39202359d
4 changed files with 28 additions and 297 deletions
|
@ -1,7 +1,7 @@
|
|||
From 8b8f42a28d472578364e003ad6bb25aa6d027c35 Mon Sep 17 00:00:00 2001
|
||||
From db337e0e4c54d91a3cbfaea8857951b8f6b7711c Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
|
|
@ -1,267 +0,0 @@
|
|||
From 3af195918143906fd262059302139d59cf4a0a70 Mon Sep 17 00:00:00 2001
|
||||
From: Al Viro <viro@zeniv.linux.org.uk>
|
||||
Date: Mon, 26 Dec 2016 04:10:19 -0500
|
||||
Subject: [PATCH 2/2] arm64: don't pull uaccess.h into *.S
|
||||
|
||||
Split asm-only parts of arm64 uaccess.h into a new header and use that
|
||||
from *.S.
|
||||
|
||||
Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
|
||||
---
|
||||
arch/arm64/include/asm/asm-uaccess.h | 65 ++++++++++++++++++++++++++++++++++++
|
||||
arch/arm64/include/asm/uaccess.h | 64 -----------------------------------
|
||||
arch/arm64/kernel/entry.S | 2 +-
|
||||
arch/arm64/lib/clear_user.S | 2 +-
|
||||
arch/arm64/lib/copy_from_user.S | 2 +-
|
||||
arch/arm64/lib/copy_in_user.S | 2 +-
|
||||
arch/arm64/lib/copy_to_user.S | 2 +-
|
||||
arch/arm64/mm/cache.S | 2 +-
|
||||
arch/arm64/xen/hypercall.S | 2 +-
|
||||
9 files changed, 72 insertions(+), 71 deletions(-)
|
||||
create mode 100644 arch/arm64/include/asm/asm-uaccess.h
|
||||
|
||||
diff --git a/arch/arm64/include/asm/asm-uaccess.h b/arch/arm64/include/asm/asm-uaccess.h
|
||||
new file mode 100644
|
||||
index 000000000000..df411f3e083c
|
||||
--- /dev/null
|
||||
+++ b/arch/arm64/include/asm/asm-uaccess.h
|
||||
@@ -0,0 +1,65 @@
|
||||
+#ifndef __ASM_ASM_UACCESS_H
|
||||
+#define __ASM_ASM_UACCESS_H
|
||||
+
|
||||
+#include <asm/alternative.h>
|
||||
+#include <asm/kernel-pgtable.h>
|
||||
+#include <asm/sysreg.h>
|
||||
+#include <asm/assembler.h>
|
||||
+
|
||||
+/*
|
||||
+ * User access enabling/disabling macros.
|
||||
+ */
|
||||
+#ifdef CONFIG_ARM64_SW_TTBR0_PAN
|
||||
+ .macro __uaccess_ttbr0_disable, tmp1
|
||||
+ mrs \tmp1, ttbr1_el1 // swapper_pg_dir
|
||||
+ add \tmp1, \tmp1, #SWAPPER_DIR_SIZE // reserved_ttbr0 at the end of swapper_pg_dir
|
||||
+ msr ttbr0_el1, \tmp1 // set reserved TTBR0_EL1
|
||||
+ isb
|
||||
+ .endm
|
||||
+
|
||||
+ .macro __uaccess_ttbr0_enable, tmp1
|
||||
+ get_thread_info \tmp1
|
||||
+ ldr \tmp1, [\tmp1, #TSK_TI_TTBR0] // load saved TTBR0_EL1
|
||||
+ msr ttbr0_el1, \tmp1 // set the non-PAN TTBR0_EL1
|
||||
+ isb
|
||||
+ .endm
|
||||
+
|
||||
+ .macro uaccess_ttbr0_disable, tmp1
|
||||
+alternative_if_not ARM64_HAS_PAN
|
||||
+ __uaccess_ttbr0_disable \tmp1
|
||||
+alternative_else_nop_endif
|
||||
+ .endm
|
||||
+
|
||||
+ .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||
+alternative_if_not ARM64_HAS_PAN
|
||||
+ save_and_disable_irq \tmp2 // avoid preemption
|
||||
+ __uaccess_ttbr0_enable \tmp1
|
||||
+ restore_irq \tmp2
|
||||
+alternative_else_nop_endif
|
||||
+ .endm
|
||||
+#else
|
||||
+ .macro uaccess_ttbr0_disable, tmp1
|
||||
+ .endm
|
||||
+
|
||||
+ .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||
+ .endm
|
||||
+#endif
|
||||
+
|
||||
+/*
|
||||
+ * These macros are no-ops when UAO is present.
|
||||
+ */
|
||||
+ .macro uaccess_disable_not_uao, tmp1
|
||||
+ uaccess_ttbr0_disable \tmp1
|
||||
+alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||
+ SET_PSTATE_PAN(1)
|
||||
+alternative_else_nop_endif
|
||||
+ .endm
|
||||
+
|
||||
+ .macro uaccess_enable_not_uao, tmp1, tmp2
|
||||
+ uaccess_ttbr0_enable \tmp1, \tmp2
|
||||
+alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||
+ SET_PSTATE_PAN(0)
|
||||
+alternative_else_nop_endif
|
||||
+ .endm
|
||||
+
|
||||
+#endif
|
||||
diff --git a/arch/arm64/include/asm/uaccess.h b/arch/arm64/include/asm/uaccess.h
|
||||
index d26750ca6e06..46da3ea638bb 100644
|
||||
--- a/arch/arm64/include/asm/uaccess.h
|
||||
+++ b/arch/arm64/include/asm/uaccess.h
|
||||
@@ -22,8 +22,6 @@
|
||||
#include <asm/kernel-pgtable.h>
|
||||
#include <asm/sysreg.h>
|
||||
|
||||
-#ifndef __ASSEMBLY__
|
||||
-
|
||||
/*
|
||||
* User space memory access functions
|
||||
*/
|
||||
@@ -424,66 +422,4 @@ extern long strncpy_from_user(char *dest, const char __user *src, long count);
|
||||
extern __must_check long strlen_user(const char __user *str);
|
||||
extern __must_check long strnlen_user(const char __user *str, long n);
|
||||
|
||||
-#else /* __ASSEMBLY__ */
|
||||
-
|
||||
-#include <asm/assembler.h>
|
||||
-
|
||||
-/*
|
||||
- * User access enabling/disabling macros.
|
||||
- */
|
||||
-#ifdef CONFIG_ARM64_SW_TTBR0_PAN
|
||||
- .macro __uaccess_ttbr0_disable, tmp1
|
||||
- mrs \tmp1, ttbr1_el1 // swapper_pg_dir
|
||||
- add \tmp1, \tmp1, #SWAPPER_DIR_SIZE // reserved_ttbr0 at the end of swapper_pg_dir
|
||||
- msr ttbr0_el1, \tmp1 // set reserved TTBR0_EL1
|
||||
- isb
|
||||
- .endm
|
||||
-
|
||||
- .macro __uaccess_ttbr0_enable, tmp1
|
||||
- get_thread_info \tmp1
|
||||
- ldr \tmp1, [\tmp1, #TSK_TI_TTBR0] // load saved TTBR0_EL1
|
||||
- msr ttbr0_el1, \tmp1 // set the non-PAN TTBR0_EL1
|
||||
- isb
|
||||
- .endm
|
||||
-
|
||||
- .macro uaccess_ttbr0_disable, tmp1
|
||||
-alternative_if_not ARM64_HAS_PAN
|
||||
- __uaccess_ttbr0_disable \tmp1
|
||||
-alternative_else_nop_endif
|
||||
- .endm
|
||||
-
|
||||
- .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||
-alternative_if_not ARM64_HAS_PAN
|
||||
- save_and_disable_irq \tmp2 // avoid preemption
|
||||
- __uaccess_ttbr0_enable \tmp1
|
||||
- restore_irq \tmp2
|
||||
-alternative_else_nop_endif
|
||||
- .endm
|
||||
-#else
|
||||
- .macro uaccess_ttbr0_disable, tmp1
|
||||
- .endm
|
||||
-
|
||||
- .macro uaccess_ttbr0_enable, tmp1, tmp2
|
||||
- .endm
|
||||
-#endif
|
||||
-
|
||||
-/*
|
||||
- * These macros are no-ops when UAO is present.
|
||||
- */
|
||||
- .macro uaccess_disable_not_uao, tmp1
|
||||
- uaccess_ttbr0_disable \tmp1
|
||||
-alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||
- SET_PSTATE_PAN(1)
|
||||
-alternative_else_nop_endif
|
||||
- .endm
|
||||
-
|
||||
- .macro uaccess_enable_not_uao, tmp1, tmp2
|
||||
- uaccess_ttbr0_enable \tmp1, \tmp2
|
||||
-alternative_if ARM64_ALT_PAN_NOT_UAO
|
||||
- SET_PSTATE_PAN(0)
|
||||
-alternative_else_nop_endif
|
||||
- .endm
|
||||
-
|
||||
-#endif /* __ASSEMBLY__ */
|
||||
-
|
||||
#endif /* __ASM_UACCESS_H */
|
||||
diff --git a/arch/arm64/kernel/entry.S b/arch/arm64/kernel/entry.S
|
||||
index a7504f40d7ee..923841ffe4a9 100644
|
||||
--- a/arch/arm64/kernel/entry.S
|
||||
+++ b/arch/arm64/kernel/entry.S
|
||||
@@ -31,7 +31,7 @@
|
||||
#include <asm/memory.h>
|
||||
#include <asm/ptrace.h>
|
||||
#include <asm/thread_info.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
#include <asm/unistd.h>
|
||||
|
||||
/*
|
||||
diff --git a/arch/arm64/lib/clear_user.S b/arch/arm64/lib/clear_user.S
|
||||
index add4a1334085..e88fb99c1561 100644
|
||||
--- a/arch/arm64/lib/clear_user.S
|
||||
+++ b/arch/arm64/lib/clear_user.S
|
||||
@@ -17,7 +17,7 @@
|
||||
*/
|
||||
#include <linux/linkage.h>
|
||||
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
|
||||
.text
|
||||
|
||||
diff --git a/arch/arm64/lib/copy_from_user.S b/arch/arm64/lib/copy_from_user.S
|
||||
index fd6cd05593f9..4b5d826895ff 100644
|
||||
--- a/arch/arm64/lib/copy_from_user.S
|
||||
+++ b/arch/arm64/lib/copy_from_user.S
|
||||
@@ -17,7 +17,7 @@
|
||||
#include <linux/linkage.h>
|
||||
|
||||
#include <asm/cache.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
|
||||
/*
|
||||
* Copy from user space to a kernel buffer (alignment handled by the hardware)
|
||||
diff --git a/arch/arm64/lib/copy_in_user.S b/arch/arm64/lib/copy_in_user.S
|
||||
index d828540ded6f..47184c3a97da 100644
|
||||
--- a/arch/arm64/lib/copy_in_user.S
|
||||
+++ b/arch/arm64/lib/copy_in_user.S
|
||||
@@ -19,7 +19,7 @@
|
||||
#include <linux/linkage.h>
|
||||
|
||||
#include <asm/cache.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
|
||||
/*
|
||||
* Copy from user space to user space (alignment handled by the hardware)
|
||||
diff --git a/arch/arm64/lib/copy_to_user.S b/arch/arm64/lib/copy_to_user.S
|
||||
index 3e6ae2663b82..351f0766f7a6 100644
|
||||
--- a/arch/arm64/lib/copy_to_user.S
|
||||
+++ b/arch/arm64/lib/copy_to_user.S
|
||||
@@ -17,7 +17,7 @@
|
||||
#include <linux/linkage.h>
|
||||
|
||||
#include <asm/cache.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
|
||||
/*
|
||||
* Copy to user space from a kernel buffer (alignment handled by the hardware)
|
||||
diff --git a/arch/arm64/mm/cache.S b/arch/arm64/mm/cache.S
|
||||
index 17f422a4dc55..83c27b6e6dca 100644
|
||||
--- a/arch/arm64/mm/cache.S
|
||||
+++ b/arch/arm64/mm/cache.S
|
||||
@@ -23,7 +23,7 @@
|
||||
#include <asm/assembler.h>
|
||||
#include <asm/cpufeature.h>
|
||||
#include <asm/alternative.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
|
||||
/*
|
||||
* flush_icache_range(start,end)
|
||||
diff --git a/arch/arm64/xen/hypercall.S b/arch/arm64/xen/hypercall.S
|
||||
index 47cf3f9d89ff..947830a459d2 100644
|
||||
--- a/arch/arm64/xen/hypercall.S
|
||||
+++ b/arch/arm64/xen/hypercall.S
|
||||
@@ -49,7 +49,7 @@
|
||||
|
||||
#include <linux/linkage.h>
|
||||
#include <asm/assembler.h>
|
||||
-#include <linux/uaccess.h>
|
||||
+#include <asm/asm-uaccess.h>
|
||||
#include <xen/interface/xen.h>
|
||||
|
||||
|
||||
--
|
||||
2.11.0
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=8
|
||||
|
||||
_rcver=4.10
|
||||
_rcrel=1
|
||||
_rcrel=2
|
||||
|
||||
pkgbase=linux-aarch64-rc
|
||||
_srcname=linux-${_rcver}-rc${_rcrel}
|
||||
|
@ -19,13 +19,11 @@ makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
|||
options=('!strip')
|
||||
source=("https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0002-arm64-don-t-pull-uaccess.h-into-.S.patch'
|
||||
'config'
|
||||
'linux.preset')
|
||||
md5sums=('f1969e506627fcd7d2e009576b1f30f0'
|
||||
'8d1078180e5fbe4716c9dac2633ec6ca'
|
||||
'27c05cc3320044ef8d7bed45adae6fd3'
|
||||
'd04a87d353c5c276c639fd81ef3138a4'
|
||||
md5sums=('b60c74837266da4f21747defb3f8ca24'
|
||||
'1eb6bdcfd408c4e35de1ed673403307f'
|
||||
'98055a63c1772f6ecdfeb9de6aaf4b2b'
|
||||
'25d8f6983c9a616946848c0e075a949c')
|
||||
|
||||
prepare() {
|
||||
|
@ -33,7 +31,6 @@ prepare() {
|
|||
|
||||
# ALARM patches
|
||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0002-arm64-don-t-pull-uaccess.h-into-.S.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm64 4.10.0-rc1-1 Kernel Configuration
|
||||
# Linux/arm64 4.10.0-rc2-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM64=y
|
||||
CONFIG_64BIT=y
|
||||
|
@ -3678,7 +3678,7 @@ CONFIG_CPU_THERMAL=y
|
|||
CONFIG_CLOCK_THERMAL=y
|
||||
CONFIG_DEVFREQ_THERMAL=y
|
||||
CONFIG_THERMAL_EMULATION=y
|
||||
CONFIG_HISI_THERMAL=y
|
||||
CONFIG_HISI_THERMAL=m
|
||||
# CONFIG_QORIQ_THERMAL is not set
|
||||
# CONFIG_ARMADA_THERMAL is not set
|
||||
|
||||
|
@ -3691,13 +3691,13 @@ CONFIG_MTK_THERMAL=m
|
|||
# NVIDIA Tegra thermal drivers
|
||||
#
|
||||
# CONFIG_TEGRA_SOCTHERM is not set
|
||||
CONFIG_QCOM_SPMI_TEMP_ALARM=y
|
||||
# CONFIG_GENERIC_ADC_THERMAL is not set
|
||||
CONFIG_QCOM_SPMI_TEMP_ALARM=m
|
||||
CONFIG_GENERIC_ADC_THERMAL=m
|
||||
|
||||
#
|
||||
# Qualcomm thermal drivers
|
||||
#
|
||||
# CONFIG_QCOM_TSENS is not set
|
||||
CONFIG_QCOM_TSENS=m
|
||||
CONFIG_WATCHDOG=y
|
||||
CONFIG_WATCHDOG_CORE=y
|
||||
# CONFIG_WATCHDOG_NOWAYOUT is not set
|
||||
|
@ -5300,9 +5300,9 @@ CONFIG_USBIP_VUDC=m
|
|||
# CONFIG_USBIP_DEBUG is not set
|
||||
# CONFIG_USB_MTU3 is not set
|
||||
CONFIG_USB_MUSB_HDRC=y
|
||||
CONFIG_USB_MUSB_HOST=y
|
||||
# CONFIG_USB_MUSB_HOST is not set
|
||||
# CONFIG_USB_MUSB_GADGET is not set
|
||||
# CONFIG_USB_MUSB_DUAL_ROLE is not set
|
||||
CONFIG_USB_MUSB_DUAL_ROLE=y
|
||||
|
||||
#
|
||||
# Platform Glue Layer
|
||||
|
@ -5314,9 +5314,9 @@ CONFIG_USB_MUSB_HOST=y
|
|||
# CONFIG_MUSB_PIO_ONLY is not set
|
||||
CONFIG_USB_DWC3=y
|
||||
CONFIG_USB_DWC3_ULPI=y
|
||||
CONFIG_USB_DWC3_HOST=y
|
||||
# CONFIG_USB_DWC3_HOST is not set
|
||||
# CONFIG_USB_DWC3_GADGET is not set
|
||||
# CONFIG_USB_DWC3_DUAL_ROLE is not set
|
||||
CONFIG_USB_DWC3_DUAL_ROLE=y
|
||||
|
||||
#
|
||||
# Platform Glue Driver Support
|
||||
|
@ -5324,13 +5324,13 @@ CONFIG_USB_DWC3_HOST=y
|
|||
CONFIG_USB_DWC3_PCI=y
|
||||
CONFIG_USB_DWC3_OF_SIMPLE=y
|
||||
CONFIG_USB_DWC2=y
|
||||
CONFIG_USB_DWC2_HOST=y
|
||||
# CONFIG_USB_DWC2_HOST is not set
|
||||
|
||||
#
|
||||
# Gadget/Dual-role mode requires USB Gadget support to be enabled
|
||||
#
|
||||
# CONFIG_USB_DWC2_PERIPHERAL is not set
|
||||
# CONFIG_USB_DWC2_DUAL_ROLE is not set
|
||||
CONFIG_USB_DWC2_DUAL_ROLE=y
|
||||
CONFIG_USB_DWC2_PCI=y
|
||||
# CONFIG_USB_DWC2_DEBUG is not set
|
||||
# CONFIG_USB_DWC2_TRACK_MISSED_SOFS is not set
|
||||
|
@ -5341,9 +5341,10 @@ CONFIG_USB_CHIPIDEA_UDC=y
|
|||
CONFIG_USB_CHIPIDEA_HOST=y
|
||||
CONFIG_USB_ISP1760=y
|
||||
CONFIG_USB_ISP1760_HCD=y
|
||||
CONFIG_USB_ISP1760_HOST_ROLE=y
|
||||
CONFIG_USB_ISP1761_UDC=y
|
||||
# CONFIG_USB_ISP1760_HOST_ROLE is not set
|
||||
# CONFIG_USB_ISP1760_GADGET_ROLE is not set
|
||||
# CONFIG_USB_ISP1760_DUAL_ROLE is not set
|
||||
CONFIG_USB_ISP1760_DUAL_ROLE=y
|
||||
|
||||
#
|
||||
# USB port drivers
|
||||
|
@ -5368,7 +5369,7 @@ CONFIG_USB_SERIAL_IR=m
|
|||
CONFIG_USB_SERIAL_EDGEPORT=m
|
||||
CONFIG_USB_SERIAL_EDGEPORT_TI=m
|
||||
CONFIG_USB_SERIAL_F81232=m
|
||||
# CONFIG_USB_SERIAL_F8153X is not set
|
||||
CONFIG_USB_SERIAL_F8153X=m
|
||||
CONFIG_USB_SERIAL_GARMIN=m
|
||||
CONFIG_USB_SERIAL_IPW=m
|
||||
CONFIG_USB_SERIAL_IUU=m
|
||||
|
@ -6183,10 +6184,10 @@ CONFIG_MTK_IOMMU=y
|
|||
# Remoteproc drivers
|
||||
#
|
||||
CONFIG_REMOTEPROC=y
|
||||
CONFIG_QCOM_ADSP_PIL=y
|
||||
CONFIG_QCOM_MDT_LOADER=y
|
||||
CONFIG_QCOM_Q6V5_PIL=y
|
||||
CONFIG_QCOM_WCNSS_PIL=y
|
||||
CONFIG_QCOM_ADSP_PIL=m
|
||||
CONFIG_QCOM_MDT_LOADER=m
|
||||
CONFIG_QCOM_Q6V5_PIL=m
|
||||
CONFIG_QCOM_WCNSS_PIL=m
|
||||
|
||||
#
|
||||
# Rpmsg drivers
|
||||
|
@ -6210,7 +6211,7 @@ CONFIG_QCOM_SMD_RPM=y
|
|||
CONFIG_QCOM_SMEM_STATE=y
|
||||
CONFIG_QCOM_SMP2P=y
|
||||
CONFIG_QCOM_SMSM=y
|
||||
CONFIG_QCOM_WCNSS_CTRL=y
|
||||
CONFIG_QCOM_WCNSS_CTRL=m
|
||||
CONFIG_SUNXI_SRAM=y
|
||||
CONFIG_ARCH_TEGRA_132_SOC=y
|
||||
CONFIG_ARCH_TEGRA_210_SOC=y
|
||||
|
@ -6320,8 +6321,8 @@ CONFIG_MCP320X=m
|
|||
CONFIG_MCP3422=m
|
||||
CONFIG_MEDIATEK_MT6577_AUXADC=m
|
||||
CONFIG_NAU7802=m
|
||||
CONFIG_QCOM_SPMI_IADC=y
|
||||
CONFIG_QCOM_SPMI_VADC=y
|
||||
CONFIG_QCOM_SPMI_IADC=m
|
||||
CONFIG_QCOM_SPMI_VADC=m
|
||||
CONFIG_TI_ADC081C=m
|
||||
CONFIG_TI_ADC0832=m
|
||||
CONFIG_TI_ADC12138=m
|
||||
|
|
Loading…
Reference in a new issue