removed extra/mysql

This commit is contained in:
Kevin Mihelich 2013-04-25 23:30:01 +00:00
parent 7031cf12b3
commit e42a383b38
6 changed files with 0 additions and 235 deletions

View file

@ -1,145 +0,0 @@
# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - added alarm.patch
pkgbase=mysql
pkgname=('libmysqlclient' 'mysql-clients' 'mysql')
pkgver=5.5.30
pkgrel=7
arch=('i686' 'x86_64')
license=('GPL')
url="https://www.mysql.com/products/community/"
makedepends=('cmake' 'openssl' 'zlib')
options=('!libtool')
source=(http://ftp.gwdg.de/pub/misc/mysql/Downloads/MySQL-5.5/${pkgbase}-${pkgver}.tar.gz{,.asc}
mysqld-post.sh
mysqld-tmpfile.conf
mysqld.service
alarm.patch)
sha256sums=('909fe596e0044082a02d2757b742a33b8a3ff399b589603940494d3d3d975053'
'27d3bba7b7f54f9f77cddba81a3fe124aeef918cc09eb28860338e9a4359e6f7'
'368f9fd2454d80eb32abb8f29f703d1cf9553353fb9e1ae4529c4b851cb8c5dd'
'2af318c52ae0fe5428e8a9245d1b0fc3bc5ce153842d1563329ceb1edfa83ddd'
'50212165bdb09855b97b15a917464ba34f82edf30a0c43f9a0c93a27071df556'
'e33db2d543bd8cba732c1387adc3d67017aaec27a9c5618695063acd374777a0')
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
patch -p1 -i "${srcdir}/alarm.patch"
cd "${srcdir}"
mkdir build
cd build
cmake ../${pkgbase}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSYSCONFDIR=/etc/mysql \
-DMYSQL_DATADIR=/var/lib/mysql \
-DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock \
-DDEFAULT_CHARSET=utf8 \
-DDEFAULT_COLLATION=utf8_general_ci \
-DENABLED_LOCAL_INFILE=ON \
-DINSTALL_INFODIR=share/mysql/docs \
-DINSTALL_MANDIR=share/man \
-DINSTALL_PLUGINDIR=lib/mysql/plugin \
-DINSTALL_SCRIPTDIR=bin \
-DINSTALL_INCLUDEDIR=include/mysql \
-DINSTALL_DOCREADMEDIR=share/mysql \
-DINSTALL_SUPPORTFILESDIR=share/mysql \
-DINSTALL_MYSQLSHAREDIR=share/mysql \
-DINSTALL_DOCDIR=share/mysql/docs \
-DINSTALL_SHAREDIR=share/mysql \
-DWITH_READLINE=ON \
-DWITH_ZLIB=system \
-DWITH_SSL=system \
-DWITH_LIBWRAP=OFF \
-DWITH_MYSQLD_LDFLAGS="${LDFLAGS}" \
-DWITH_EXTRA_CHARSETS=complex \
-DWITH_EMBEDDED_SERVER=ON \
-DWITH_INNOBASE_STORAGE_ENGINE=1 \
-DWITH_PARTITION_STORAGE_ENGINE=1 \
-DWITH_ARCHIVE_STORAGE_ENGINE=1 \
-DWITH_BLACKHOLE_STORAGE_ENGINE=1 \
-DWITHOUT_EXAMPLE_STORAGE_ENGINE=1 \
-DWITHOUT_FEDERATED_STORAGE_ENGINE=1 \
-DCMAKE_C_FLAGS="-fPIC ${CFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -fomit-frame-pointer" \
-DCMAKE_CXX_FLAGS="-fPIC ${CXXFLAGS} -fno-strict-aliasing -DBIG_JOINS=1 -felide-constructors -fno-rtti"
make
}
package_libmysqlclient(){
pkgdesc="MySQL client libraries"
depends=('openssl')
conflicts=('libmariadbclient')
provides=("libmariadbclient=$pkgver")
cd build
for dir in include libmysql libmysqld libservices; do
make -C ${dir} DESTDIR="${pkgdir}" install
done
install -d "${pkgdir}"/usr/bin
install -m755 scripts/mysql_config "${pkgdir}"/usr/bin/
install -d "${pkgdir}"/usr/share/man/man1
for man in mysql_config mysql_client_test_embedded mysqltest_embedded; do
install -m644 "${srcdir}"/${pkgbase}-${pkgver}/man/$man.1 "${pkgdir}"/usr/share/man/man1/$man.1
done
}
package_mysql-clients(){
pkgdesc="MySQL client tools"
depends=('libmysqlclient')
conflicts=('mariadb-clients')
provides=("mariadb-clients=$pkgver")
cd build
make -C client DESTDIR="${pkgdir}" install
# install man pages
install -d "${pkgdir}"/usr/share/man/man1
for man in mysql mysqladmin mysqlcheck mysqldump mysqlimport mysqlshow mysqlslap; do
install -m644 "${srcdir}"/${pkgbase}-${pkgver}/man/$man.1 "${pkgdir}"/usr/share/man/man1/$man.1
done
# provided by mysql
rm "${pkgdir}"/usr/bin/{mysql_{plugin,upgrade},mysqlbinlog,mysqltest}
}
package_mysql(){
pkgdesc="A fast SQL database server"
backup=('etc/mysql/my.cnf')
install=mysql.install
depends=('mysql-clients' 'systemd-tools')
conflicts=('mariadb')
provides=("mariadb=$pkgver")
options=('emptydirs')
cd build
make DESTDIR="${pkgdir}" install
install -Dm644 "${pkgdir}"/usr/share/mysql/my-medium.cnf "${pkgdir}"/etc/mysql/my.cnf
install -Dm755 "${srcdir}"/mysqld-post.sh "${pkgdir}"/usr/bin/mysqld-post
install -Dm644 "${srcdir}"/mysqld-tmpfile.conf "${pkgdir}"/usr/lib/tmpfiles.d/mysqld.conf
install -d "${pkgdir}"/usr/lib/systemd/system
install -Dm644 "${srcdir}"/mysqld.service "${pkgdir}"/usr/lib/systemd/system/
# provided by libmysqlclient
rm "${pkgdir}"/usr/bin/{mysql_config,mysql_client_test_embedded,mysqltest_embedded}
rm "${pkgdir}"/usr/lib/libmysql*
rm -r "${pkgdir}"/usr/include/
rm "${pkgdir}"/usr/share/man/man1/{mysql_config,mysql_client_test_embedded,mysqltest_embedded}.1
# provided by mysql-clients
rm "${pkgdir}"/usr/bin/{mysql,mysqladmin,mysqlcheck,mysqldump,mysqlimport,mysqlshow,mysqlslap}
rm "${pkgdir}"/usr/share/man/man1/{mysql,mysqladmin,mysqlcheck,mysqldump,mysqlimport,mysqlshow,mysqlslap}.1
# not needed
rm -r "${pkgdir}"/usr/{data,mysql-test,sql-bench}
rm "${pkgdir}"/usr/share/man/man1/mysql-test-run.pl.1
#install -dm700 "${pkgdir}"/var/lib/mysql
}

View file

@ -1,28 +0,0 @@
diff -urN a/sql-common/client_plugin.c b/sql-common/client_plugin.c
--- a/sql-common/client_plugin.c 2011-03-31 07:36:18.000000000 -0600
+++ b/sql-common/client_plugin.c 2011-04-07 11:59:48.000000000 -0600
@@ -242,9 +242,9 @@
initialized= 1;
pthread_mutex_lock(&LOCK_load_client_plugin);
-
+ va_list a = {0};
for (builtin= mysql_client_builtins; *builtin; builtin++)
- add_plugin(&mysql, *builtin, 0, 0, 0);
+ add_plugin(&mysql, *builtin, 0, 0, a);
pthread_mutex_unlock(&LOCK_load_client_plugin);
@@ -301,8 +301,10 @@
plugin->name, "it is already loaded");
plugin= NULL;
}
- else
- plugin= add_plugin(mysql, plugin, 0, 0, 0);
+ else {
+ va_list a = {0};
+ plugin= add_plugin(mysql, plugin, 0, 0, a);
+ }
pthread_mutex_unlock(&LOCK_load_client_plugin);
return plugin;

View file

@ -1,37 +0,0 @@
if [[ $(command -v my_print_defaults >/dev/null 2>&1) ]]; then
datadir=$(my_print_defaults mysqld | sed -n "s/^--datadir=//p")
fi
[[ -z $datadir ]] && datadir=/var/lib/mysql
post_install(){
groupadd -g 89 mysql &>/dev/null
useradd -u 89 -g mysql -d $datadir -s /bin/false mysql &>/dev/null
if [[ ! -e $datadir ]]; then
install -dm700 $datadir
usr/bin/mysql_install_db --user=mysql --basedir=/usr --datadir=$datadir
chown -R mysql:mysql var/lib/mysql &>/dev/null
fi
usr/bin/systemd-tmpfiles --create mysqld.conf
}
post_upgrade(){
getent group mysql >/dev/null 2>&1 || groupadd -g 89 mysql &>/dev/null
getent passwd mysql >/dev/null 2>&1 || useradd -u 89 -g mysql -d $datadir -s /bin/false mysql &>/dev/null
if [ "$(vercmp $2 5.5)" -lt 0 ]; then
echo " >> "
echo " >> Major version update. Consider restart the service, and then running mysql_upgrade after it."
echo " >> "
fi
}
post_remove(){
if getent passwd mysql >/dev/null 2>&1; then
userdel mysql
fi
if getent group mysql >/dev/null 2>&1; then
groupdel mysql
fi
}

View file

@ -1,8 +0,0 @@
#!/bin/sh
while true; do
response=$(/usr/bin/mysqladmin -uUNKNOWN_USER ping 2>&1) && break
echo "$response" | grep -q "mysqld is alive" && break
echo "$response" | grep -q "Access denied for user" && break
sleep 1
done

View file

@ -1 +0,0 @@
d /run/mysqld 0755 mysql mysql -

View file

@ -1,16 +0,0 @@
[Unit]
Description=MySQL database server
After=syslog.target
[Service]
User=mysql
Group=mysql
ExecStart=/usr/bin/mysqld --pid-file=/run/mysqld/mysqld.pid
ExecStartPost=/usr/bin/mysqld-post
Restart=always
PrivateTmp=true
[Install]
WantedBy=multi-user.target