mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
community/higan: fix
This commit is contained in:
parent
18924e3fcc
commit
e432c38c8d
2 changed files with 8 additions and 11 deletions
|
@ -1,27 +1,25 @@
|
|||
From 79fe90b4616ad226f1329c7754fc2745dc5139af Mon Sep 17 00:00:00 2001
|
||||
From 26ded571425d3f5b651bdd956013b049bacd718d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 29 Jan 2017 11:07:56 -0700
|
||||
Subject: [PATCH] AArch64 fixes
|
||||
|
||||
---
|
||||
libco/sjlj.c | 2 ++
|
||||
libco/sjlj.c | 1 +
|
||||
nall/intrinsics.hpp | 2 +-
|
||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libco/sjlj.c b/libco/sjlj.c
|
||||
index dfa0aa45..34e4b3c1 100644
|
||||
index 1d0cb59a..885b1d36 100644
|
||||
--- a/libco/sjlj.c
|
||||
+++ b/libco/sjlj.c
|
||||
@@ -10,7 +10,9 @@
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
|
||||
#define LIBCO_C
|
||||
+#define _XOPEN_SOURCE 700
|
||||
#include "libco.h"
|
||||
+#include "settings.h"
|
||||
#include "settings.h"
|
||||
|
||||
#include <stdlib.h>
|
||||
#include <signal.h>
|
||||
diff --git a/nall/intrinsics.hpp b/nall/intrinsics.hpp
|
||||
index e5dcaf64..20ed3460 100644
|
||||
--- a/nall/intrinsics.hpp
|
||||
|
@ -36,5 +34,5 @@ index e5dcaf64..20ed3460 100644
|
|||
auto Intrinsics::processor() -> Processor { return Processor::ARM; }
|
||||
#elif defined(__ppc64__) || defined(_ARCH_PPC64)
|
||||
--
|
||||
2.11.0
|
||||
2.13.3
|
||||
|
||||
|
|
|
@ -24,8 +24,7 @@ source=("https://download.byuu.org/higan_v${pkgver}-source.7z"
|
|||
'0001-AArch64-fixes.patch')
|
||||
sha256sums=('342400ba494b37a95210f11e6d941566e50a772095586406c14d75293f525544'
|
||||
'6ee3489a3cf3e8d09beaa5c1f809824593aa08b61dc9a8c9ddc12a09c89ae6cb'
|
||||
'2c5af5006f0438a7d7bfe62aa0c540b9e6ee526d45dfcafd65bb8598d50d83d7'
|
||||
'91739473c602d421533fb79c51311ad8d3a0acbbfb95b1b62d85feb2dd6fcb94')
|
||||
'0855c62824138ca02a9e775b7a6cca08b2cb20f99ce2713112be1a9d62e23509')
|
||||
|
||||
prepare() {
|
||||
cd higan_v${pkgver}-source
|
||||
|
|
Loading…
Reference in a new issue