mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/psensor to 1.2.1-1
This commit is contained in:
parent
4579d6e82b
commit
e47aadfc31
2 changed files with 5 additions and 35 deletions
|
@ -7,8 +7,8 @@
|
|||
# - remove depend on libxnvctrl
|
||||
|
||||
pkgname=psensor
|
||||
pkgver=1.2.0
|
||||
pkgrel=7
|
||||
pkgver=1.2.1
|
||||
pkgrel=1
|
||||
pkgdesc='A graphical hardware temperature monitor for Linux'
|
||||
arch=('x86_64')
|
||||
url='https://wpitchoune.net/psensor'
|
||||
|
@ -16,15 +16,11 @@ license=('GPL2')
|
|||
depends=('lm_sensors' 'dconf' 'gtk3' 'udisks2' 'curl' 'libgtop' 'libnotify'
|
||||
'json-c' 'libmicrohttpd')
|
||||
makedepends=('help2man')
|
||||
source=("https://wpitchoune.net/${pkgname}/files/${pkgname}-${pkgver}.tar.gz"
|
||||
'is_error.patch')
|
||||
sha512sums=('274928190a53f3603f7db4ea81057497bfa01b9d0f8b4eb2f5f5094fd944ee384aff8f9c21b9c85ea001cbe877e7dc020963c0570f000ef42b302cb54b038e4d'
|
||||
'fa1f0a8cdbd75fba2ad980a5beb1807e533ef12154db1f0cc97c9130080584cb0251e29a56068b0400f152e540f326a7b16749bf11b1e844d1d519d7bb0e71ed')
|
||||
source=("https://wpitchoune.net/${pkgname}/files/${pkgname}-${pkgver}.tar.gz")
|
||||
sha512sums=('931b8ab654cd708d128e0a659e94049fa69dd33dc354b17ef08e05b8da65588f5c5c1c2a4a42f7341a7990f999152c9aebf3c58484eea38e476034d60ac2ff41')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
|
||||
patch -Np1 -i "${srcdir}/is_error.patch"
|
||||
find $pkgname-$pkgver -name Makefile* | xargs sed -e 's|-Werror||g' -i # Kill -Werror
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- a/src/rsensor.c 2016-12-20 00:39:54.000000000 +0100
|
||||
+++ b/src/rsensor.c 2018-01-05 19:30:09.089759050 +0100
|
||||
@@ -133,7 +133,7 @@
|
||||
|
||||
obj = get_json_object(url);
|
||||
|
||||
- if (obj && !is_error(obj)) {
|
||||
+ if (obj && (obj != NULL)) {
|
||||
n = json_object_array_length(obj);
|
||||
sensors = malloc((n + 1) * sizeof(struct psensor *));
|
||||
|
||||
@@ -168,12 +168,12 @@
|
||||
|
||||
obj = get_json_object(get_url(s));
|
||||
|
||||
- if (obj && !is_error(obj)) {
|
||||
+ if (obj && (obj != NULL)) {
|
||||
json_object *om;
|
||||
|
||||
json_object_object_get_ex(obj, "last_measure", &om);
|
||||
|
||||
- if (!is_error(obj)) {
|
||||
+ if (obj != NULL) {
|
||||
json_object *ov, *ot;
|
||||
struct timeval tv;
|
||||
|
Loading…
Reference in a new issue