extra/ncmpcpp to 0.10-1

This commit is contained in:
David Beauchamp 2024-09-03 11:55:51 -04:00
parent f0c92bdb3b
commit e47c1eab93
3 changed files with 14 additions and 69 deletions

View file

@ -1,8 +1,8 @@
pkgbase = ncmpcpp
pkgdesc = Almost exact clone of ncmpc with some new features
pkgver = 0.9.2
pkgrel = 20
url = https://ncmpcpp.rybczak.net/
pkgdesc = Featureful ncurses based MPD client inspired by ncmpc
pkgver = 0.10
pkgrel = 1
url = https://github.com/ncmpcpp/ncmpcpp
arch = x86_64
license = GPL-2.0-only
makedepends = boost
@ -28,11 +28,8 @@ pkgbase = ncmpcpp
depends = readline
depends = libreadline.so
depends = taglib
source = git+https://github.com/ncmpcpp/ncmpcpp.git#tag=0.9.2
source = taglib-2.patch
sha512sums = e40b19318af5c191a9397fbd337a2e807d945ae06d6bc349c9555c58820f59afba70448b030541754870d30f0fe78630e028611e184c8b25368c734bc51a7c87
sha512sums = fff2987f193bb0d0423b32d81d79dda4c8dd451f701b587a3456867387697736381e4e09489ea852f648449c8a0ec9fbb386f74b7207249abf12dfd4a8f54f36
b2sums = babc1506eca6dc5bd48e58fabfd42502d33b506b2e600b7aa98126a6deb0d68e14dc692abb0ef5079e3ccf710648f0b82fe1b404303d932f2156104c479442ec
b2sums = 7e45e21e493d3da4039ac27f1f3158cdc244b6df369d7a452f770ac068ae2635d60a9ea19f166f3f6eaa5a766f25a6ed76edd83c8700c0f53b492b170b806320
source = git+https://github.com/ncmpcpp/ncmpcpp.git#tag=0.10
sha512sums = 11ecfca5ab9e9c55666990dce720b628e13abc84476770be5956b9736e9ee96de028ac96a60430218f6ce05859617b6875c540c2f4d9fe8dcc252017e72f5f48
b2sums = 6009107e2c58c2a1281313ab8071723b34a6b26f353f8fb13d99d39cc1315357a2b7f05f89910edd2829023fa54f1a7d6ae29f9a78830116849a847f46ac2f56
pkgname = ncmpcpp

View file

@ -9,10 +9,10 @@
# - configure with --without-lto
pkgname=ncmpcpp
pkgver=0.9.2
pkgrel=20
pkgdesc='Almost exact clone of ncmpc with some new features'
url='https://ncmpcpp.rybczak.net/'
pkgver=0.10
pkgrel=1
pkgdesc='Featureful ncurses based MPD client inspired by ncmpc'
url='https://github.com/ncmpcpp/ncmpcpp'
arch=('x86_64')
license=('GPL-2.0-only')
depends=('curl' 'libcurl.so' 'libmpdclient' 'libmpdclient.so' 'fftw' 'libfftw3.so' 'boost-libs'
@ -20,16 +20,12 @@ depends=('curl' 'libcurl.so' 'libmpdclient' 'libmpdclient.so' 'fftw' 'libfftw3.s
'libboost_thread.so' 'icu' 'libicui18n.so' 'libicuuc.so'
'glibc' 'gcc-libs' 'ncurses' 'libncursesw.so' 'readline' 'libreadline.so' 'taglib')
makedepends=('boost' 'git')
source=(git+https://github.com/ncmpcpp/ncmpcpp.git#tag=${pkgver}
taglib-2.patch)
sha512sums=('e40b19318af5c191a9397fbd337a2e807d945ae06d6bc349c9555c58820f59afba70448b030541754870d30f0fe78630e028611e184c8b25368c734bc51a7c87'
'fff2987f193bb0d0423b32d81d79dda4c8dd451f701b587a3456867387697736381e4e09489ea852f648449c8a0ec9fbb386f74b7207249abf12dfd4a8f54f36')
b2sums=('babc1506eca6dc5bd48e58fabfd42502d33b506b2e600b7aa98126a6deb0d68e14dc692abb0ef5079e3ccf710648f0b82fe1b404303d932f2156104c479442ec'
'7e45e21e493d3da4039ac27f1f3158cdc244b6df369d7a452f770ac068ae2635d60a9ea19f166f3f6eaa5a766f25a6ed76edd83c8700c0f53b492b170b806320')
source=(git+https://github.com/ncmpcpp/ncmpcpp.git#tag=${pkgver})
sha512sums=('11ecfca5ab9e9c55666990dce720b628e13abc84476770be5956b9736e9ee96de028ac96a60430218f6ce05859617b6875c540c2f4d9fe8dcc252017e72f5f48')
b2sums=('6009107e2c58c2a1281313ab8071723b34a6b26f353f8fb13d99d39cc1315357a2b7f05f89910edd2829023fa54f1a7d6ae29f9a78830116849a847f46ac2f56')
prepare() {
cd ${pkgname}
patch -p1 -i ../taglib-2.patch
autoreconf -fiv
sed -e 's/CXXFLAGS=/CXXFLAGS+=/' \
-e 's/CPPFLAGS=/CPPFLAGS+=/' \
@ -40,13 +36,6 @@ prepare() {
build() {
cd ${pkgname}
# http://site.icu-project.org/download/61#TOC-Migration-Issues
export CPPFLAGS+=' -DU_USING_ICU_NAMESPACE=1'
# Work around deprecated TagLib::String::null from TagLib 1.12
CXXFLAGS+=' -Wno-error=deprecated-declarations'
BOOST_LIB_SUFFIX='' ./configure \
--prefix=/usr \
--enable-clock \

View file

@ -1,41 +0,0 @@
diff --git a/extras/artist_to_albumartist.cpp b/extras/artist_to_albumartist.cpp
index c3ddfee3..bf5aac29 100644
--- a/extras/artist_to_albumartist.cpp
+++ b/extras/artist_to_albumartist.cpp
@@ -34,7 +34,7 @@ enum class CopyResult { Success, NoArtist, AlbumArtistAlreadyInPlace };
bool is_framelist_empty(const TagLib::ID3v2::FrameList &list)
{
for (auto it = list.begin(); it != list.end(); ++it)
- if ((*it)->toString() != TagLib::String::null)
+ if ((*it)->toString() != TagLib::String())
return false;
return true;
}
diff --git a/src/tags.cpp b/src/tags.cpp
index 6cd6a8c2..09731801 100644
--- a/src/tags.cpp
+++ b/src/tags.cpp
@@ -123,12 +123,12 @@ void writeCommonTags(const MPD::MutableSong &s, TagLib::Tag *tag)
tag->setArtist(ToWString(s.getArtist()));
tag->setAlbum(ToWString(s.getAlbum()));
try {
- tag->setYear(boost::lexical_cast<TagLib::uint>(s.getDate()));
+ tag->setYear(boost::lexical_cast<uint>(s.getDate()));
} catch (boost::bad_lexical_cast &) {
std::cerr << "writeCommonTags: couldn't write 'year' tag to '" << s.getURI() << "' as it's not a positive integer\n";
}
try {
- tag->setTrack(boost::lexical_cast<TagLib::uint>(s.getTrack()));
+ tag->setTrack(boost::lexical_cast<uint>(s.getTrack()));
} catch (boost::bad_lexical_cast &) {
std::cerr << "writeCommonTags: couldn't write 'track' tag to '" << s.getURI() << "' as it's not a positive integer\n";
}
@@ -306,7 +306,7 @@ bool write(MPD::MutableSong &s)
{
writeID3v2Tags(s, mpeg_file->ID3v2Tag(true));
// write id3v2.4 tags only
- if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, true, 4, false))
+ if (!mpeg_file->save(TagLib::MPEG::File::ID3v2, TagLib::File::StripTags::StripNone, TagLib::ID3v2::Version::v4, TagLib::File::DuplicateTags::DoNotDuplicate))
return false;
// do not call generic save() as it will duplicate tags
saved = true;