mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Updated to X ABI 14
This commit is contained in:
parent
d376fc516a
commit
e4bb9f1609
2 changed files with 59 additions and 45 deletions
|
@ -7,7 +7,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname="xf86-video-armsoc"
|
||||
pkgver=20130220
|
||||
pkgver=20130319
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="http://git.chromium.org/gitweb/?p=chromiumos/third_party/xf86-video-armsoc.git;a=summary"
|
||||
|
@ -15,7 +15,7 @@ license=('GPL2')
|
|||
makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverproto')
|
||||
options=('!libtool')
|
||||
source=('compat_post_X_1.13.patch')
|
||||
md5sums=('dba71c3a428a792f9b8bb015417b1b5f')
|
||||
md5sums=('12ccb37f9bdfe2e920d95a2cca832295')
|
||||
_gitroot="http://git.chromium.org/git/chromiumos/third_party/xf86-video-armsoc.git"
|
||||
_gitname="xf86-video-armsoc"
|
||||
|
||||
|
@ -34,7 +34,7 @@ build() {
|
|||
|
||||
msg "Patching source..."
|
||||
# X 1.13 compatibility from the Linaro upstream
|
||||
patch -p1 -i ${srcdir}/compat_post_X_1.13.patch
|
||||
git apply ${srcdir}/compat_post_X_1.13.patch
|
||||
|
||||
msg "Starting build..."
|
||||
./autogen.sh --prefix=/usr
|
||||
|
|
|
@ -1,11 +1,16 @@
|
|||
From 66ab235b8070a894ec1252a6979d60f9a4f69749 Mon Sep 17 00:00:00 2001
|
||||
From f52876d7712b379f7f9e4527725d4f5dbcc58fc3 Mon Sep 17 00:00:00 2001
|
||||
From: Erik Andersson <erik.h.andersson@gmail.com>
|
||||
Date: Wed, 20 Feb 2013 14:39:44 -0600
|
||||
Subject: [PATCH 1/2] Patch for compat
|
||||
Date: Tue, 19 Mar 2013 15:50:23 -0500
|
||||
Subject: [PATCH] Fixes for X 1.14 ABI
|
||||
|
||||
---
|
||||
src/compat-api.h | 101 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 101 insertions(+)
|
||||
src/compat-api.h | 101 ++++++++++++++++++++++++++++++++++++++++++++++++++
|
||||
src/drmmode_display.c | 6 +--
|
||||
src/omap_driver.c | 67 ++++++++++++++++-----------------
|
||||
src/omap_driver.h | 3 +-
|
||||
src/omap_exa.h | 5 ++-
|
||||
src/omap_exa_null.c | 4 +-
|
||||
6 files changed, 140 insertions(+), 46 deletions(-)
|
||||
create mode 100644 src/compat-api.h
|
||||
|
||||
diff --git a/src/compat-api.h b/src/compat-api.h
|
||||
|
@ -115,28 +120,21 @@ index 0000000..b74a582
|
|||
+#endif
|
||||
+
|
||||
+#endif
|
||||
--
|
||||
1.8.1.3
|
||||
|
||||
|
||||
From 689d8c9bb456c4716350af64b138b2e18365d3ab Mon Sep 17 00:00:00 2001
|
||||
From: Erik Andersson <erik.h.andersson@gmail.com>
|
||||
Date: Wed, 20 Feb 2013 14:51:04 -0600
|
||||
Subject: [PATCH 2/2] Forgot to add some files to the commit
|
||||
|
||||
---
|
||||
src/drmmode_display.c | 3 +--
|
||||
src/omap_driver.c | 66 +++++++++++++++++++++++++--------------------------
|
||||
src/omap_driver.h | 2 +-
|
||||
src/omap_exa.h | 5 ++--
|
||||
src/omap_exa_null.c | 4 ++--
|
||||
5 files changed, 39 insertions(+), 41 deletions(-)
|
||||
|
||||
diff --git a/src/drmmode_display.c b/src/drmmode_display.c
|
||||
index 14cd33f..6b7c409 100644
|
||||
index 0d5faef..424e0da 100644
|
||||
--- a/src/drmmode_display.c
|
||||
+++ b/src/drmmode_display.c
|
||||
@@ -1524,7 +1524,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
||||
@@ -58,9 +58,6 @@
|
||||
#include "compiler.h"
|
||||
#include "mipointer.h"
|
||||
|
||||
-/* All drivers implementing backing store need this */
|
||||
-#include "mibstore.h"
|
||||
-
|
||||
#include "micmap.h"
|
||||
|
||||
#include "xf86DDC.h"
|
||||
@@ -1524,7 +1521,6 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
||||
|
||||
TRACE_ENTER();
|
||||
|
||||
|
@ -144,7 +142,7 @@ index 14cd33f..6b7c409 100644
|
|||
|
||||
drmmode = calloc(1, sizeof *drmmode);
|
||||
drmmode->fd = fd;
|
||||
@@ -1564,7 +1563,7 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
||||
@@ -1564,7 +1560,7 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp)
|
||||
}
|
||||
|
||||
void
|
||||
|
@ -154,7 +152,7 @@ index 14cd33f..6b7c409 100644
|
|||
xf86CrtcConfigPtr config = XF86_CRTC_CONFIG_PTR(pScrn);
|
||||
xf86OutputPtr output = config->output[config->compat_output];
|
||||
diff --git a/src/omap_driver.c b/src/omap_driver.c
|
||||
index f343ffb..cb8397a 100644
|
||||
index f343ffb..a3a55ef 100644
|
||||
--- a/src/omap_driver.c
|
||||
+++ b/src/omap_driver.c
|
||||
@@ -36,7 +36,7 @@
|
||||
|
@ -203,7 +201,15 @@ index f343ffb..cb8397a 100644
|
|||
{
|
||||
ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
|
||||
OMAPPtr pOMAP = OMAPPTR(pScrn);
|
||||
@@ -786,7 +784,7 @@ OMAPScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
|
||||
@@ -762,7 +760,6 @@ OMAPScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
|
||||
OMAPAccelInit(pScreen);
|
||||
|
||||
/* Initialize backing store: */
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
|
||||
/* Cause the cursor position to be updated by the mouse signal handler: */
|
||||
@@ -786,7 +783,7 @@ OMAPScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
|
||||
/* Take over the virtual terminal from the console, set the desired mode,
|
||||
* etc.:
|
||||
*/
|
||||
|
@ -212,7 +218,7 @@ index f343ffb..cb8397a 100644
|
|||
ERROR_MSG("OMAPEnterVT() failed!");
|
||||
goto fail;
|
||||
}
|
||||
@@ -856,9 +854,9 @@ OMAPLoadPalette(ScrnInfoPtr pScrn, int numColors, int *indices,
|
||||
@@ -856,9 +853,9 @@ OMAPLoadPalette(ScrnInfoPtr pScrn, int numColors, int *indices,
|
||||
* held by pScrn).
|
||||
*/
|
||||
static Bool
|
||||
|
@ -224,7 +230,7 @@ index f343ffb..cb8397a 100644
|
|||
OMAPPtr pOMAP = OMAPPTR(pScrn);
|
||||
|
||||
TRACE_ENTER();
|
||||
@@ -866,12 +864,12 @@ OMAPCloseScreen(int scrnIndex, ScreenPtr pScreen)
|
||||
@@ -866,12 +863,12 @@ OMAPCloseScreen(int scrnIndex, ScreenPtr pScreen)
|
||||
drmmode_screen_fini(pScrn);
|
||||
|
||||
if (pScrn->vtSema == TRUE) {
|
||||
|
@ -239,7 +245,7 @@ index f343ffb..cb8397a 100644
|
|||
}
|
||||
}
|
||||
|
||||
@@ -893,7 +891,7 @@ OMAPCloseScreen(int scrnIndex, ScreenPtr pScreen)
|
||||
@@ -893,7 +890,7 @@ OMAPCloseScreen(int scrnIndex, ScreenPtr pScreen)
|
||||
|
||||
TRACE_EXIT();
|
||||
|
||||
|
@ -248,7 +254,7 @@ index f343ffb..cb8397a 100644
|
|||
}
|
||||
|
||||
|
||||
@@ -920,14 +918,14 @@ OMAPCreateScreenResources(ScreenPtr pScreen)
|
||||
@@ -920,14 +917,14 @@ OMAPCreateScreenResources(ScreenPtr pScreen)
|
||||
|
||||
|
||||
static void
|
||||
|
@ -267,7 +273,7 @@ index f343ffb..cb8397a 100644
|
|||
swap(pOMAP, pScreen, BlockHandler);
|
||||
|
||||
/* TODO OMAPVideoBlockHandler(), etc.. */
|
||||
@@ -940,9 +938,9 @@ OMAPBlockHandler(int i, pointer blockData, pointer pTimeout, pointer pReadmask)
|
||||
@@ -940,9 +937,9 @@ OMAPBlockHandler(int i, pointer blockData, pointer pTimeout, pointer pReadmask)
|
||||
* Screen.
|
||||
*/
|
||||
static Bool
|
||||
|
@ -279,7 +285,7 @@ index f343ffb..cb8397a 100644
|
|||
return xf86SetSingleMode(pScrn, mode, RR_Rotate_0);
|
||||
}
|
||||
|
||||
@@ -954,10 +952,10 @@ OMAPSwitchMode(int scrnIndex, DisplayModePtr mode, int flags)
|
||||
@@ -954,10 +951,10 @@ OMAPSwitchMode(int scrnIndex, DisplayModePtr mode, int flags)
|
||||
* buffer within the "viewport" of the monitor.
|
||||
*/
|
||||
static void
|
||||
|
@ -293,7 +299,7 @@ index f343ffb..cb8397a 100644
|
|||
}
|
||||
|
||||
|
||||
@@ -969,9 +967,9 @@ OMAPAdjustFrame(int scrnIndex, int x, int y, int flags)
|
||||
@@ -969,9 +966,9 @@ OMAPAdjustFrame(int scrnIndex, int x, int y, int flags)
|
||||
* HW state as needed by the X server.
|
||||
*/
|
||||
static Bool
|
||||
|
@ -305,7 +311,7 @@ index f343ffb..cb8397a 100644
|
|||
OMAPPtr pOMAP = OMAPPTR(pScrn);
|
||||
int i, ret;
|
||||
|
||||
@@ -1005,9 +1003,9 @@ OMAPEnterVT(int scrnIndex, int flags)
|
||||
@@ -1005,9 +1002,9 @@ OMAPEnterVT(int scrnIndex, int flags)
|
||||
* need to restore the console's HW state.
|
||||
*/
|
||||
static void
|
||||
|
@ -317,7 +323,7 @@ index f343ffb..cb8397a 100644
|
|||
OMAPPtr pOMAP = OMAPPTR(pScrn);
|
||||
int i, ret;
|
||||
|
||||
@@ -1034,9 +1032,9 @@ OMAPLeaveVT(int scrnIndex, int flags)
|
||||
@@ -1034,9 +1031,9 @@ OMAPLeaveVT(int scrnIndex, int flags)
|
||||
* up-to-and-including an unsuccessful ScreenInit() call.
|
||||
*/
|
||||
static void
|
||||
|
@ -329,7 +335,7 @@ index f343ffb..cb8397a 100644
|
|||
OMAPPtr pOMAP = OMAPPTR(pScrn);
|
||||
|
||||
TRACE_ENTER();
|
||||
@@ -1048,7 +1046,7 @@ OMAPFreeScreen(int scrnIndex, int flags)
|
||||
@@ -1048,7 +1045,7 @@ OMAPFreeScreen(int scrnIndex, int flags)
|
||||
|
||||
if (pOMAP->pOMAPEXA) {
|
||||
if (pOMAP->pOMAPEXA->FreeScreen) {
|
||||
|
@ -339,18 +345,26 @@ index f343ffb..cb8397a 100644
|
|||
free(pOMAP->pOMAPEXA);
|
||||
}
|
||||
diff --git a/src/omap_driver.h b/src/omap_driver.h
|
||||
index 3de1802..f0a690e 100644
|
||||
index e07fcc2..711830a 100644
|
||||
--- a/src/omap_driver.h
|
||||
+++ b/src/omap_driver.h
|
||||
@@ -240,7 +240,7 @@ static inline Bool has_dmm(OMAPPtr pOMAP)
|
||||
@@ -40,7 +40,6 @@
|
||||
* XXX - figure out what can be removed..
|
||||
*/
|
||||
#include "mipointer.h"
|
||||
-#include "mibstore.h"
|
||||
#include "micmap.h"
|
||||
#include "colormapst.h"
|
||||
#include "xf86cmap.h"
|
||||
@@ -240,7 +239,7 @@ static inline Bool has_dmm(OMAPPtr pOMAP)
|
||||
Bool drmmode_pre_init(ScrnInfoPtr pScrn, int fd, int cpp);
|
||||
void drmmode_screen_init(ScrnInfoPtr pScrn);
|
||||
void drmmode_screen_fini(ScrnInfoPtr pScrn);
|
||||
-void drmmode_adjust_frame(ScrnInfoPtr pScrn, int x, int y, int flags);
|
||||
+void drmmode_adjust_frame(ScrnInfoPtr pScrn, int x, int y);
|
||||
int drmmode_page_flip(DrawablePtr draw, uint32_t fb_id, void *priv);
|
||||
int drmmode_page_flip(DrawablePtr draw, uint32_t fb_id, void *priv,
|
||||
int* num_flipped);
|
||||
void drmmode_wait_for_event(ScrnInfoPtr pScrn);
|
||||
Bool drmmode_cursor_init(ScreenPtr pScreen);
|
||||
diff --git a/src/omap_exa.h b/src/omap_exa.h
|
||||
index 9980858..b1d4c64 100644
|
||||
--- a/src/omap_exa.h
|
||||
|
@ -403,5 +417,5 @@ index 7d1f295..3c1e683 100644
|
|||
}
|
||||
|
||||
--
|
||||
1.8.1.3
|
||||
1.8.2
|
||||
|
||||
|
|
Loading…
Reference in a new issue