mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/polymake to 4.0.r1-1
This commit is contained in:
parent
b662411064
commit
e4fb76cb93
2 changed files with 6 additions and 17 deletions
|
@ -7,8 +7,8 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=polymake
|
||||
pkgver=4.0
|
||||
pkgrel=2
|
||||
pkgver=4.0.r1
|
||||
pkgrel=1
|
||||
pkgdesc="Open source software for research in polyhedral geometry"
|
||||
arch=(x86_64)
|
||||
url="https://polymake.org/"
|
||||
|
@ -17,11 +17,11 @@ depends=(normaliz singular ppl lrs perl-xml-writer perl-xml-libxml perl-xml-libx
|
|||
perl-term-readline-gnu perl-term-readkey perl-json sympol)
|
||||
makedepends=(ninja cddlib ant boost bliss libnsl jdk8-openjdk permlib)
|
||||
optdepends=('java-runtime: java module')
|
||||
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2")
|
||||
sha256sums=('f6d350758377b240e78d16781555c5679bc36f98e181cff17490c963eac49c5b')
|
||||
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-${pkgver/.r/r}-minimal.tar.bz2")
|
||||
sha256sums=('b29de50dda6f657f2e82ef6acff62df1b51128a20c5d53bd97226ea22fdc3b52')
|
||||
|
||||
build() {
|
||||
cd polymake-$pkgver
|
||||
cd polymake-${pkgver%.*}
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--with-cdd=/usr \
|
||||
|
@ -33,6 +33,6 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd polymake-$pkgver
|
||||
cd polymake-${pkgver%.*}
|
||||
make DESTDIR="$pkgdir" install
|
||||
}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- polymake-3.6/bundled/libnormaliz/support/configure.pl.orig 2019-12-11 12:29:31.089671103 +0000
|
||||
+++ polymake-3.6/bundled/libnormaliz/support/configure.pl 2019-12-11 12:29:52.549969615 +0000
|
||||
@@ -69,7 +69,7 @@
|
||||
}
|
||||
|
||||
if ($nmz_path ne "bundled") {
|
||||
- my $error=Polymake::Configure::build_test_program(<<'---', LIBS => "-lnormaliz -lgmpxx -lgmp", CXXFLAGS => "$CXXFLAGS", LDFLAGS => "$LDFLAGS");
|
||||
+ my $error=Polymake::Configure::build_test_program(<<'---', LIBS => "-lnormaliz -lgmpxx -lgmp -leantic", CXXFLAGS => "$CXXFLAGS", LDFLAGS => "$LDFLAGS");
|
||||
|
||||
#include <cstddef>
|
||||
#include <vector>
|
Loading…
Reference in a new issue