core/linux-armv5 to 4.8.14-1

This commit is contained in:
Kevin Mihelich 2016-12-10 19:27:41 +00:00
parent d80ea96236
commit e4fc74a52e
5 changed files with 12 additions and 107 deletions

View file

@ -1,7 +1,7 @@
From 657105044a20ff77d65c6b5b61896cb44ae417bc Mon Sep 17 00:00:00 2001
From a4030e559273b194d3d9e37a79a1e68c846a237b Mon Sep 17 00:00:00 2001
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
Date: Mon, 12 Aug 2013 10:36:25 -0500
Subject: [PATCH 1/4] at91: ariag25 updates
Subject: [PATCH 1/3] at91: ariag25 updates
v2: dropped at91sam9x5 usart fix, as merged mainline

View file

@ -1,7 +1,7 @@
From 3854c9a5d5083f5f9237032278dee51c47bdea9d Mon Sep 17 00:00:00 2001
From 13e3a8ae551398e6d300600b83cddc8a87dfbbb5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 13 Jun 2015 13:46:30 -0600
Subject: [PATCH 2/4] at91: arietta-g25 support
Subject: [PATCH 2/3] at91: arietta-g25 support
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---

View file

@ -1,7 +1,7 @@
From 2b64bb5d8e67f0e84d8481ff932b845e28eb6111 Mon Sep 17 00:00:00 2001
From 93f953bb8e351b2fad9c03514acf511dbb8390d8 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 3/4] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++

View file

@ -1,92 +0,0 @@
From fe0d7be03ac2dccc7c101a84652e9891e849d1e3 Mon Sep 17 00:00:00 2001
From: Philip Pettersson <philip.pettersson@gmail.com>
Date: Wed, 30 Nov 2016 14:55:36 -0800
Subject: [PATCH 4/4] packet: fix race condition in packet_set_ring
When packet_set_ring creates a ring buffer it will initialize a
struct timer_list if the packet version is TPACKET_V3. This value
can then be raced by a different thread calling setsockopt to
set the version to TPACKET_V1 before packet_set_ring has finished.
This leads to a use-after-free on a function pointer in the
struct timer_list when the socket is closed as the previously
initialized timer will not be deleted.
The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
changing the packet version while also taking the lock at the start
of packet_set_ring.
Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
Signed-off-by: Eric Dumazet <edumazet@google.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/packet/af_packet.c | 18 ++++++++++++------
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
index d2238b2..dd23323 100644
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
@@ -3648,19 +3648,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
if (optlen != sizeof(val))
return -EINVAL;
- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
- return -EBUSY;
if (copy_from_user(&val, optval, sizeof(val)))
return -EFAULT;
switch (val) {
case TPACKET_V1:
case TPACKET_V2:
case TPACKET_V3:
- po->tp_version = val;
- return 0;
+ break;
default:
return -EINVAL;
}
+ lock_sock(sk);
+ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
+ ret = -EBUSY;
+ } else {
+ po->tp_version = val;
+ ret = 0;
+ }
+ release_sock(sk);
+ return ret;
}
case PACKET_RESERVE:
{
@@ -4164,6 +4170,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
/* Added to avoid minimal code churn */
struct tpacket_req *req = &req_u->req;
+ lock_sock(sk);
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
net_warn_ratelimited("Tx-ring is not supported.\n");
@@ -4245,7 +4252,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
goto out;
}
- lock_sock(sk);
/* Detach socket from network */
spin_lock(&po->bind_lock);
@@ -4294,11 +4300,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
if (!tx_ring)
prb_shutdown_retire_blk_timer(po, rb_queue);
}
- release_sock(sk);
if (pg_vec)
free_pg_vec(pg_vec, order, req->tp_block_nr);
out:
+ release_sock(sk);
return err;
}
--
2.10.2

View file

@ -7,8 +7,8 @@ pkgbase=linux-armv5
_srcname=linux-4.8
_kernelname=${pkgbase#linux}
_desc="ARMv5 multi-platform"
pkgver=4.8.13
pkgrel=2
pkgver=4.8.14
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
@ -19,14 +19,12 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0001-at91-ariag25-updates.patch'
'0002-at91-arietta-g25-support.patch'
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0004-packet-fix-race-condition-in-packet_set_ring.patch'
'config')
md5sums=('c1af0afbd3df35c1ccdc7a5118cd2d07'
'bc208ac66340464839ee61a4621d9384'
'5d8ebae24bc9f81630e5362f2f71586b'
'6ee0081556ccd6c4cc6296406a50e801'
'f9af3cfaf2fb091357f3963b604a539d'
'3768a608243a59fed2834e26ef3d42b4'
'b8001f580c4da45ee7ae8d928275cf97'
'080675211923f58fa49a21985641b3f0'
'43d2441c34362094c50247640e83bacd'
'647524ddf6881cf75c87f5e8a1ea57a4'
'04e8b83be4eafd9c9646d5bec6d5a772')
prepare() {
@ -39,7 +37,6 @@ prepare() {
git apply ../0001-at91-ariag25-updates.patch
git apply ../0002-at91-arietta-g25-support.patch
git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0004-packet-fix-race-condition-in-packet_set_ring.patch
cat "${srcdir}/config" > ./.config