From e50607c7736e6836f8dd5a1626b081e8b63cab6f Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 3 Jun 2013 15:51:35 +0000
Subject: [PATCH] core/glibc to 2.17-6

---
 core/glibc/PKGBUILD | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)

diff --git a/core/glibc/PKGBUILD b/core/glibc/PKGBUILD
index ec58ec6cb..18088c084 100644
--- a/core/glibc/PKGBUILD
+++ b/core/glibc/PKGBUILD
@@ -14,7 +14,7 @@ noautobuild=1
 
 pkgname=glibc
 pkgver=2.17
-pkgrel=5
+pkgrel=6
 pkgdesc="GNU C Library"
 arch=('i686' 'x86_64')
 url="http://www.gnu.org/software/libc"
@@ -82,6 +82,8 @@ build() {
   [[ $CARCH == "armv7h" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabihf --build=armv7l-unknown-linux-gnueabihf"
 
   echo "slibdir=/usr/lib" >> configparms
+  echo "sbindir=/usr/bin" >> configparms
+  echo "rootsbindir=/usr/bin" >> configparms
 
   # remove hardening options for building libraries
   CFLAGS=${CFLAGS/-fstack-protector/}
@@ -109,7 +111,7 @@ build() {
   make
 
   # remove harding in preparation to run test-suite
-  sed -i '2,4d' configparms
+  sed -i '4,6d' configparms
 }
 
 check() {
@@ -140,9 +142,6 @@ package() {
 
   install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/bin
 
-  # temporary symlink
-  ln -s ../../sbin/ldconfig ${pkgdir}/usr/bin/ldconfig
-
   # create /etc/locale.gen
   install -m644 ${srcdir}/locale.gen.txt ${pkgdir}/etc/locale.gen
   sed -e '1,3d' -e 's|/| |g' -e 's|\\| |g' -e 's|^|#|g' \
@@ -159,11 +158,10 @@ package() {
   #   libthread_db-1.0.so
 
   cd $pkgdir
-  strip $STRIP_BINARIES sbin/{ldconfig,sln} \
-                        usr/bin/{gencat,getconf,getent,iconv,locale,localedef} \
-                        usr/bin/{makedb,pcprofiledump,pldd,rpcgen,sprof} \
-                        usr/lib/getconf/* \
-                        usr/sbin/{iconvconfig,nscd}
+  strip $STRIP_BINARIES usr/bin/{gencat,getconf,getent,iconv,iconvconfig} \
+                        usr/bin/{ldconfig,locale,localedef,nscd,makedb} \
+                        usr/bin/{pcprofiledump,pldd,rpcgen,sln,sprof} \
+                        usr/lib/getconf/*
   [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
 
   strip $STRIP_STATIC usr/lib/*.a