extra/gegl02 to 0.2.0-9

This commit is contained in:
Kevin Mihelich 2018-05-12 16:38:33 +00:00
parent 9ac223acf2
commit e5539bcc34
2 changed files with 69 additions and 51 deletions

View file

@ -7,7 +7,7 @@
pkgname=gegl02
pkgver=0.2.0
pkgrel=8
pkgrel=9
pkgdesc="Graph based image processing framework (v0.2)"
arch=('i686' 'x86_64')
url="http://www.gegl.org/"
@ -21,19 +21,19 @@ optdepends=('libopenraw: openraw plugin'
'jasper: jasper plugin')
options=(!makeflags)
source=(http://ftp.gimp.org/pub/gegl/${pkgver%.*}/gegl-${pkgver}.tar.bz2
gegl-0.2.0-ffmpeg-0.11.patch
gegl-0.2.0-ffmpeg-4.patch
gegl-0.2.0-CVE-2012-4433.patch
gegl-0.2.0-lua-5.2.patch
gegl-0.2.0-remove-src-over-op.patch)
sha1sums=('764cc66cb3c7b261b8fc18a6268a0e264a91d573'
'f5e4c0edd32e088f768e303081f1ed2d80588d4c'
'6016257a286fe4f8eff91b82f958e83f116715ac'
'44d48bd9ad008703de9f8eb683d557bac39a02c8'
'c78a092b880874ba7784b652bcd9c532e2b9975d'
'dc9ae21cc5ba0fb47ef05793f0cb169572dfab74')
prepare() {
cd gegl-${pkgver}
patch -Np1 -i ../gegl-0.2.0-ffmpeg-0.11.patch
patch -Np0 -i ../gegl-0.2.0-ffmpeg-4.patch
patch -Np1 -i ../gegl-0.2.0-CVE-2012-4433.patch
patch -Np1 -i ../gegl-0.2.0-lua-5.2.patch
patch -Np1 -i ../gegl-0.2.0-remove-src-over-op.patch

View file

@ -1,47 +1,65 @@
--- ./operations/external/ff-load.c 2012-04-01 14:17:57.000000000 +0300
+++ ./operations/external/ff-load.c.new 2014-10-23 01:49:25.090139749 +0300
@@ -137,7 +137,7 @@
if (p->enc)
avcodec_close (p->enc);
if (p->ic)
- av_close_input_file (p->ic);
+ avformat_close_input(&p->ic);
if (p->lavc_frame)
av_free (p->lavc_frame);
@@ -216,9 +216,9 @@
{
do
{
- if (av_read_packet (p->ic, &p->pkt) < 0)
+ if (av_read_frame (p->ic, &p->pkt) < 0)
{
- fprintf (stderr, "av_read_packet failed for %s\n",
+ fprintf (stderr, "av_read_frame failed for %s\n",
o->path);
return -1;
}
@@ -271,12 +271,12 @@
gint err;
ff_cleanup (o);
- err = av_open_input_file (&p->ic, o->path, NULL, 0, NULL);
+ err = avformat_open_input(&p->ic, o->path, NULL, 0);
if (err < 0)
{
print_error (o->path, err);
}
- err = av_find_stream_info (p->ic);
+ err = avformat_find_stream_info (p->ic, NULL);
if (err < 0)
{
g_warning ("ff-load: error finding stream info for %s", o->path);
@@ -312,7 +312,7 @@
if (p->codec->capabilities & CODEC_CAP_TRUNCATED)
p->enc->flags |= CODEC_FLAG_TRUNCATED;
- if (avcodec_open (p->enc, p->codec) < 0)
+ if (avcodec_open2 (p->enc, p->codec, NULL) < 0)
{
g_warning ("error opening codec %s", p->enc->codec->name);
return;
https://git.gnome.org/browse/gegl/commit/?id=97067622352e
https://git.gnome.org/browse/gegl/commit/?id=6d50c42e2c9a
https://git.gnome.org/browse/gegl/commit/?id=67f14cbbc5d1
--- operations/external/ff-load.c.orig 2012-04-01 11:17:57 UTC
+++ operations/external/ff-load.c
@@ -137,7 +137,7 @@ ff_cleanup (GeglChantO *o)
if (p->enc)
avcodec_close (p->enc);
if (p->ic)
- av_close_input_file (p->ic);
+ avformat_close_input(&p->ic);
if (p->lavc_frame)
av_free (p->lavc_frame);
@@ -216,9 +216,9 @@ decode_frame (GeglOperation *operation,
{
do
{
- if (av_read_packet (p->ic, &p->pkt) < 0)
+ if (av_read_frame (p->ic, &p->pkt) < 0)
{
- fprintf (stderr, "av_read_packet failed for %s\n",
+ fprintf (stderr, "av_read_frame failed for %s\n",
o->path);
return -1;
}
@@ -271,12 +271,12 @@ prepare (GeglOperation *operation)
gint err;
ff_cleanup (o);
- err = av_open_input_file (&p->ic, o->path, NULL, 0, NULL);
+ err = avformat_open_input(&p->ic, o->path, NULL, 0);
if (err < 0)
{
print_error (o->path, err);
}
- err = av_find_stream_info (p->ic);
+ err = avformat_find_stream_info (p->ic, NULL);
if (err < 0)
{
g_warning ("ff-load: error finding stream info for %s", o->path);
@@ -309,10 +309,10 @@ prepare (GeglOperation *operation)
g_warning ("codec not found");
}
- if (p->codec->capabilities & CODEC_CAP_TRUNCATED)
- p->enc->flags |= CODEC_FLAG_TRUNCATED;
+ if (p->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
+ p->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
- if (avcodec_open (p->enc, p->codec) < 0)
+ if (avcodec_open2 (p->enc, p->codec, NULL) < 0)
{
g_warning ("error opening codec %s", p->enc->codec->name);
return;
@@ -321,7 +321,7 @@ prepare (GeglOperation *operation)
p->width = p->enc->width;
p->height = p->enc->height;
p->frames = 10000000;
- p->lavc_frame = avcodec_alloc_frame ();
+ p->lavc_frame = av_frame_alloc ();
if (p->fourcc)
g_free (p->fourcc);