mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
alarm/xf86-video-armsoc-odroid to 234.85bb904-1
This commit is contained in:
parent
173c25d1d8
commit
e55c225676
2 changed files with 5 additions and 38 deletions
|
@ -4,9 +4,9 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=xf86-video-armsoc-odroid
|
||||
_commit=29356f5b63662f3347d31fd27132802750005907
|
||||
pkgver=214.29356f5
|
||||
pkgrel=2
|
||||
_commit=85bb9041dabdd56b8dbbb69d3f8d6f023c3c9ba4
|
||||
pkgver=234.85bb904
|
||||
pkgrel=1
|
||||
arch=('armv7h')
|
||||
url="https://github.com/mdrjr/xf86-video-armsoc/tree/r4p0"
|
||||
license=('GPL2')
|
||||
|
@ -14,21 +14,14 @@ makedepends=('git' 'pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverpro
|
|||
options=('!libtool')
|
||||
conflicts=(xf86-video-armsoc)
|
||||
provides=(xf86-video-armsoc)
|
||||
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}"
|
||||
'xorg.patch')
|
||||
md5sums=('SKIP'
|
||||
'3e27624156b65b23431c77f38f155620')
|
||||
source=("$pkgname::git+https://github.com/mdrjr/xf86-video-armsoc.git#commit=${_commit}")
|
||||
md5sums=('SKIP')
|
||||
|
||||
pkgver() {
|
||||
cd $pkgname
|
||||
echo $(git rev-list --count makepkg).$(git rev-parse --short makepkg)
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd $pkgname
|
||||
patch -p1 -i ../xorg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd $pkgname
|
||||
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
diff -urN a/src/armsoc_driver.c b/src/armsoc_driver.c
|
||||
--- a/src/armsoc_driver.c 2014-07-29 20:17:16.708546536 -0600
|
||||
+++ b/src/armsoc_driver.c 2014-07-29 20:17:48.503440926 -0600
|
||||
@@ -1060,7 +1060,7 @@
|
||||
/* Initialize backing store: */
|
||||
xf86SetBackingStore(pScreen);
|
||||
|
||||
- fbdev = xf86GetOptValString(pARMSOC->pOptionInfo,
|
||||
+ fbdev = (char *)xf86GetOptValString(pARMSOC->pOptionInfo,
|
||||
OPTION_INIT_FROM_FBDEV);
|
||||
if (fbdev && *fbdev != '\0') {
|
||||
if (ARMSOCCopyFB(pScrn, fbdev)) {
|
||||
diff -urN a/src/drmmode_display.c b/src/drmmode_display.c
|
||||
--- a/src/drmmode_display.c 2014-07-29 20:17:16.708546536 -0600
|
||||
+++ b/src/drmmode_display.c 2014-07-29 20:17:52.533427544 -0600
|
||||
@@ -353,8 +353,8 @@
|
||||
drmmode_crtc->last_good_y = crtc->y;
|
||||
drmmode_crtc->last_good_rotation = crtc->rotation;
|
||||
if (drmmode_crtc->last_good_mode) {
|
||||
- if (drmmode_crtc->last_good_mode->name)
|
||||
- free(drmmode_crtc->last_good_mode->name);
|
||||
+ //if (drmmode_crtc->last_good_mode->name)
|
||||
+ // free(drmmode_crtc->last_good_mode->name);
|
||||
free(drmmode_crtc->last_good_mode);
|
||||
}
|
||||
drmmode_crtc->last_good_mode = xf86DuplicateMode(&crtc->mode);
|
Loading…
Reference in a new issue