Added working icu!!!

This commit is contained in:
Mike Staszel 2010-08-01 23:30:39 -05:00
parent 169496e636
commit e56dcc7c8b
2 changed files with 37 additions and 17 deletions

View file

@ -0,0 +1,20 @@
Index: tools/toolutil/pkg_genc.c
===================================================================
--- a/tools/toolutil/pkg_genc.c
+++ b/tools/toolutil/pkg_genc.c
@@ -1,4 +1,4 @@
/******************************************************************************
- * Copyright (C) 2009, International Business Machines
+ * Copyright (C) 2009-2010, International Business Machines
* Corporation and others. All Rights Reserved.
*******************************************************************************
@@ -119,8 +119,8 @@
{"gcc",
".globl %s\n"
- "\t.section .note.GNU-stack,\"\",@progbits\n"
+ "\t.section .note.GNU-stack,\"\",%%progbits\n"
"\t.section .rodata\n"
"\t.align 8\n" /* Either align 8 bytes or 2^8 (256) bytes. 8 bytes is needed. */
- "\t.type %s,@object\n"
+ "\t.type %s,%%object\n"
"%s:\n\n",

View file

@ -1,30 +1,30 @@
# $Id: PKGBUILD 44771 2009-07-04 10:35:13Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Mike Staszel <mikestaszel@plugboxlinux.org>
# Contributor: Art Gramlich <art@gramlich-net.com>
# Contributor: Jonny Gerold <jonny@fsk141.com>
# Plugbox changes:
# - icu needs the patch to build on ARM
pkgname=icu
pkgver=4.2.1
pkgver=4.4.1
pkgrel=1
pkgdesc="International Components for Unicode library"
arch=(arm)
arch=(i686 x86_64 arm)
url="http://www.icu-project.org/"
license=('custom:"icu"')
depends=('gcc-libs' 'sh')
source=(http://download.icu-project.org/files/${pkgname}4c/${pkgver}/${pkgname}4c-${pkgver//./_}-src.tgz
pkgdata.patch)
md5sums=('e3738abd0d3ce1870dc1fd1f22bba5b1'
'2e34b5f59e616c8c6bbd4b714b623250')
28107-icu-arm.patch)
md5sums=('b6bc0a1153540b2088f8b03e0ba625d3'
'930eec07e19c542d54e28d40a3c2e709')
build() {
cd $srcdir/icu
patch -p0 < pkgdata.patch
cd ${srcdir}/icu/source
patch -Np1 -i $srcdir/28107-icu-arm.patch || return 1
./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
make || return 1
make DESTDIR=${pkgdir} install || return 1
make -j1 DESTDIR=${pkgdir} install || return 1
# Install license
install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/icu/license.html