mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/orc to 0.4.25-1
This commit is contained in:
parent
1a966763f6
commit
e57b7e57f0
2 changed files with 11 additions and 46 deletions
|
@ -1,25 +1,22 @@
|
||||||
# $Id$
|
# $Id$
|
||||||
# Maintainer: Ionut Biru <ibiru@archlinux.org>
|
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
# - drop valgrind makedepend
|
# - drop valgrind makedepend
|
||||||
|
|
||||||
pkgname=orc
|
pkgname=orc
|
||||||
pkgver=0.4.25
|
pkgver=0.4.26
|
||||||
pkgrel=2
|
pkgrel=1
|
||||||
pkgdesc="The Oil Runtime Compiler"
|
pkgdesc="Optimized Inner Loop Runtime Compiler"
|
||||||
arch=('i686' 'x86_64')
|
arch=(i686 x86_64)
|
||||||
license=('custom')
|
license=(custom)
|
||||||
url="https://gstreamer.freedesktop.org/projects/orc.html"
|
url="https://cgit.freedesktop.org/gstreamer/orc/"
|
||||||
depends=('glibc')
|
depends=(glibc)
|
||||||
source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz
|
source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz)
|
||||||
fix-tests.patch)
|
sha256sums=('7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649')
|
||||||
md5sums=('8582a28b15f53110c88d8043d9f55bcf'
|
|
||||||
'0443f38fa7518a5d7de6c055a98365b7')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
patch -Np1 -i ../fix-tests.patch
|
|
||||||
}
|
}
|
||||||
|
|
||||||
build () {
|
build () {
|
||||||
|
@ -37,5 +34,5 @@ check() {
|
||||||
package() {
|
package() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
make DESTDIR="$pkgdir" install
|
make DESTDIR="$pkgdir" install
|
||||||
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
|
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||||
}
|
}
|
||||||
|
|
|
@ -1,32 +0,0 @@
|
||||||
From c471352db4764bdcc24223338639e4c3f52b3e51 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Pascal Terjan <pterjan@google.com>
|
|
||||||
Date: Wed, 4 May 2016 09:36:21 +0000
|
|
||||||
Subject: Fix test_parse with no executable backend
|
|
||||||
|
|
||||||
https://bugzilla.gnome.org/show_bug.cgi?id=765953
|
|
||||||
|
|
||||||
diff --git a/testsuite/test_parse.c b/testsuite/test_parse.c
|
|
||||||
index 65b17e9..87fa4ea 100644
|
|
||||||
--- a/testsuite/test_parse.c
|
|
||||||
+++ b/testsuite/test_parse.c
|
|
||||||
@@ -38,7 +38,7 @@ main (int argc, char *argv[])
|
|
||||||
printf ("%s\n", programs[i]->name);
|
|
||||||
orc_test_compare_output_full (programs[i], 0);
|
|
||||||
cres = orc_program_compile (programs[i]);
|
|
||||||
- if (cres != ORC_COMPILE_RESULT_OK) {
|
|
||||||
+ if (ORC_COMPILE_RESULT_IS_FATAL (cres)) {
|
|
||||||
fprintf (stderr, "compile error: %d\n", cres);
|
|
||||||
error = TRUE;
|
|
||||||
}
|
|
||||||
@@ -55,7 +55,7 @@ main (int argc, char *argv[])
|
|
||||||
printf ("%s\n", programs[i]->name);
|
|
||||||
orc_test_compare_output_full (programs[i], 0);
|
|
||||||
cres = orc_program_compile (programs[i]);
|
|
||||||
- if (cres != ORC_COMPILE_RESULT_OK) {
|
|
||||||
+ if (ORC_COMPILE_RESULT_IS_FATAL (cres)) {
|
|
||||||
fprintf (stderr, "compile error: %d\n", cres);
|
|
||||||
error = TRUE;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
cgit v0.10.2
|
|
||||||
|
|
Loading…
Reference in a new issue