removed core/libgpg-error

This commit is contained in:
Kevin Mihelich 2018-04-12 08:37:54 +00:00
parent 4fb25b9c5e
commit e5827e9fd1
2 changed files with 0 additions and 70 deletions

View file

@ -1,25 +0,0 @@
From e742611fb1295dd394a39f9492782dfcbc107142 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 14 Mar 2018 14:18:25 -0600
Subject: [PATCH] Fix compile on ARM
---
src/logging.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/logging.c b/src/logging.c
index 1a4f620..0b81b9e 100644
--- a/src/logging.c
+++ b/src/logging.c
@@ -1150,7 +1150,7 @@ _gpgrt_log_printhex (const void *buffer, size_t length,
va_end (arg_ptr);
}
else
- _gpgrt_logv_printhex (buffer, length, NULL, NULL);
+ _gpgrt_logv_printhex (buffer, length, NULL, arg_ptr);
}
--
2.16.2

View file

@ -1,45 +0,0 @@
# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
# Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building on ARM
pkgname=libgpg-error
pkgver=1.28
pkgrel=1
pkgdesc="Support library for libgcrypt"
arch=(x86_64)
url="https://www.gnupg.org"
license=('LGPL')
depends=('glibc' 'sh')
source=(ftp://ftp.gnupg.org/gcrypt/libgpg-error/${pkgname}-${pkgver}.tar.bz2{,.sig}
#ftp://ftp.franken.de/pub/crypt/mirror/ftp.gnupg.org/gcrypt/libgpg-error/${pkgname}-${pkgver}.tar.bz2
0001-Fix-compile-on-ARM.patch)
# https://www.gnupg.org/download/integrity_check.html
sha1sums=('2b9baae264f3e82ebe00dcd10bae3f2d64232c10'
'SKIP'
'05b14d377bf73093029ebdb009f8f6842aca2743')
validpgpkeys=('D8692123C4065DEA5E0F3AB5249B39D24F25E3B6' # Werner Koch
'031EC2536E580D8EA286A9F22071B08A33BD3F06') # NIIBE Yutaka (GnuPG Release Key) <gniibe@fsij.org>
prepare() {
cd ${pkgname}-${pkgver}
patch -p1 -i ../0001-Fix-compile-on-ARM.patch
}
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
}
check() {
cd ${pkgname}-${pkgver}
make check
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}/" install
}