mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/glibc fixes
This commit is contained in:
parent
8a079e37fb
commit
e58df508bd
3 changed files with 6 additions and 77 deletions
|
@ -41,7 +41,6 @@ source=(http://ftp.gnu.org/gnu/libc/${pkgname}-${pkgver}.tar.xz{,.sig}
|
|||
glibc-2.18-getaddrinfo-assertion.patch
|
||||
glibc-2.18-xattr-compat-hack.patch
|
||||
local-soname-hack.diff
|
||||
fix-hf-ld.so.cache.patch
|
||||
nscd.service
|
||||
nscd.tmpfiles
|
||||
locale.gen.txt
|
||||
|
@ -52,14 +51,13 @@ md5sums=('88fbbceafee809e82efd52efa1e3c58f'
|
|||
'154da6bf5a5248f42a7bf5bf08e01a47'
|
||||
'b79561ab9dce900e9bbeaf0d49927c2b'
|
||||
'c7264b99d0f7e51922a4d3126182c40a'
|
||||
'01d19fe9b2aea489cf5651530e0369f2'
|
||||
'4441f6dfe7d75ced1fa75e54dd21d36e'
|
||||
'9749ba386b08a8fe53e7ecede9bf2dfb'
|
||||
'71329fccb8eb583fb0d67b55f1e8df68'
|
||||
'd4d86add33f22125777e0ecff06bc9bb'
|
||||
'01d19fe9b2aea489cf5651530e0369f2'
|
||||
'4441f6dfe7d75ced1fa75e54dd21d36e'
|
||||
'7ca96c68a37f2a4ab91792bfa0160a24'
|
||||
'589d79041aa767a5179eaa4e2737dd3f'
|
||||
'ad8a9af15ab7eeaa23dc7ee85024af9f'
|
||||
'905370139382428ef2b97b247c0970bf'
|
||||
'd5fab2cd3abea65aa5ae696ea4a47d6b'
|
||||
'da662ca76e7c8d7efbc7986ab7acea2d'
|
||||
'07ac979b6ab5eeb778d55f041529d623'
|
||||
|
@ -101,7 +99,6 @@ prepare() {
|
|||
# ALARM: patch for hard-float ld-linux soname
|
||||
if [[ $CARCH == "armv6h" || $CARCH == "armv7h" ]]; then
|
||||
patch -p1 -i ${srcdir}/local-soname-hack.diff
|
||||
patch -p1 -i ${srcdir}/fix-hf-ld.so.cache.patch
|
||||
fi
|
||||
|
||||
mkdir ${srcdir}/glibc-build
|
||||
|
|
|
@ -1,68 +0,0 @@
|
|||
diff --git a/elf/cache.c b/elf/cache.c
|
||||
index 9901952..699550b 100644
|
||||
--- a/elf/cache.c
|
||||
+++ b/elf/cache.c
|
||||
@@ -100,6 +100,10 @@ print_entry (const char *lib, int flag, unsigned int osversion,
|
||||
case FLAG_AARCH64_LIB64:
|
||||
fputs (",AArch64", stdout);
|
||||
break;
|
||||
+ /* Uses the ARM soft-float ABI. */
|
||||
+ case FLAG_ARM_LIBSF:
|
||||
+ fputs (",soft-float", stdout);
|
||||
+ break;
|
||||
case 0:
|
||||
break;
|
||||
default:
|
||||
diff --git a/sysdeps/generic/ldconfig.h b/sysdeps/generic/ldconfig.h
|
||||
index 57a9a46..91190aa 100644
|
||||
--- a/sysdeps/generic/ldconfig.h
|
||||
+++ b/sysdeps/generic/ldconfig.h
|
||||
@@ -36,6 +36,7 @@
|
||||
#define FLAG_X8664_LIBX32 0x0800
|
||||
#define FLAG_ARM_LIBHF 0x0900
|
||||
#define FLAG_AARCH64_LIB64 0x0a00
|
||||
+#define FLAG_ARM_LIBSF 0x0b00
|
||||
|
||||
/* Name of auxiliary cache. */
|
||||
#define _PATH_LDCONFIG_AUX_CACHE "/var/cache/ldconfig/aux-cache"
|
||||
diff --git a/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h b/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||
index acc4f28..1221181 100644
|
||||
--- a/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||
+++ b/ports/sysdeps/unix/sysv/linux/arm/dl-cache.h
|
||||
@@ -18,12 +18,17 @@
|
||||
|
||||
#include <ldconfig.h>
|
||||
|
||||
+/* In order to support the transition from unmarked objects
|
||||
+ to marked objects we must treat unmarked objects as
|
||||
+ compatible with either FLAG_ARM_LIBHF or FLAG_ARM_LIBSF. */
|
||||
#ifdef __ARM_PCS_VFP
|
||||
# define _dl_cache_check_flags(flags) \
|
||||
- ((flags) == (FLAG_ARM_LIBHF | FLAG_ELF_LIBC6))
|
||||
+ ((flags) == (FLAG_ARM_LIBHF | FLAG_ELF_LIBC6) \
|
||||
+ || (flags) == FLAG_ELF_LIBC6)
|
||||
#else
|
||||
# define _dl_cache_check_flags(flags) \
|
||||
- ((flags) == FLAG_ELF_LIBC6)
|
||||
+ ((flags) == (FLAG_ARM_LIBSF | FLAG_ELF_LIBC6) \
|
||||
+ || (flags) == FLAG_ELF_LIBC6)
|
||||
#endif
|
||||
|
||||
#include_next <dl-cache.h>
|
||||
diff --git a/ports/sysdeps/unix/sysv/linux/arm/readelflib.c b/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||
index 81e5ccb..0fbd0dc 100644
|
||||
--- a/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||
+++ b/ports/sysdeps/unix/sysv/linux/arm/readelflib.c
|
||||
@@ -46,6 +46,12 @@ process_elf_file (const char *file_name, const char *lib, int *flag,
|
||||
if (elf32_header->e_flags & EF_ARM_ABI_FLOAT_HARD)
|
||||
*flag = FLAG_ARM_LIBHF|FLAG_ELF_LIBC6;
|
||||
else if (elf32_header->e_flags & EF_ARM_ABI_FLOAT_SOFT)
|
||||
+ *flag = FLAG_ARM_LIBSF|FLAG_ELF_LIBC6;
|
||||
+ else
|
||||
+ /* We must assume the unmarked objects are compatible
|
||||
+ with all ABI variants. Such objects may have been
|
||||
+ generated in a transitional period when the ABI
|
||||
+ tags were not added to all objects. */
|
||||
*flag = FLAG_ELF_LIBC6;
|
||||
}
|
||||
}
|
|
@ -1,7 +1,7 @@
|
|||
diff -urN a/elf/dl-load.c b/elf/dl-load.c
|
||||
--- a/elf/dl-load.c 2012-06-30 13:12:34.000000000 -0600
|
||||
+++ b/elf/dl-load.c 2012-07-06 15:45:51.728813355 -0600
|
||||
@@ -2081,10 +2081,13 @@
|
||||
--- a/elf/dl-load.c 2013-08-10 16:52:55.000000000 -0600
|
||||
+++ b/elf/dl-load.c 2014-01-17 12:25:32.482819996 -0700
|
||||
@@ -2105,10 +2105,13 @@
|
||||
soname = ((const char *) D_PTR (l, l_info[DT_STRTAB])
|
||||
+ l->l_info[DT_SONAME]->d_un.d_val);
|
||||
if (strcmp (name, soname) != 0)
|
||||
|
|
Loading…
Reference in a new issue