mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
core/linux-aarch64 to 5.19.4-1
This commit is contained in:
parent
0ed7ee6639
commit
e59d5f463f
4 changed files with 229 additions and 105 deletions
|
@ -1,4 +1,4 @@
|
||||||
From ef472b6f39b038f1572f1c839413600adc8da339 Mon Sep 17 00:00:00 2001
|
From 89d947a0151b40ba6855d9a9e64ebd466cd64064 Mon Sep 17 00:00:00 2001
|
||||||
From: popcornmix <popcornmix@gmail.com>
|
From: popcornmix <popcornmix@gmail.com>
|
||||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
|
@ -8,18 +8,18 @@ Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||||
1 file changed, 56 insertions(+)
|
1 file changed, 56 insertions(+)
|
||||||
|
|
||||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||||
index abe0149ed917..e62e96352b6e 100644
|
index 4dc43929e370..75e8736e3a73 100644
|
||||||
--- a/drivers/net/usb/smsc95xx.c
|
--- a/drivers/net/usb/smsc95xx.c
|
||||||
+++ b/drivers/net/usb/smsc95xx.c
|
+++ b/drivers/net/usb/smsc95xx.c
|
||||||
@@ -50,6 +50,7 @@
|
@@ -54,6 +54,7 @@
|
||||||
#define SUSPEND_SUSPEND3 (0x08)
|
#define SUSPEND_SUSPEND3 (0x08)
|
||||||
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
|
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
|
||||||
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
|
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
|
||||||
+#define MAC_ADDR_LEN (6)
|
+#define MAC_ADDR_LEN (6)
|
||||||
|
|
||||||
struct smsc95xx_priv {
|
#define SMSC95XX_NR_IRQS (1) /* raise to 12 for GPIOs */
|
||||||
u32 mac_cr;
|
#define PHY_HWIRQ (SMSC95XX_NR_IRQS - 1)
|
||||||
@@ -67,6 +68,10 @@ static bool turbo_mode = true;
|
@@ -78,6 +79,10 @@ static bool turbo_mode = true;
|
||||||
module_param(turbo_mode, bool, 0644);
|
module_param(turbo_mode, bool, 0644);
|
||||||
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
||||||
|
|
||||||
|
@ -30,7 +30,7 @@ index abe0149ed917..e62e96352b6e 100644
|
||||||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||||
u32 *data, int in_pm)
|
u32 *data, int in_pm)
|
||||||
{
|
{
|
||||||
@@ -753,8 +758,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
@@ -805,8 +810,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||||
return phy_mii_ioctl(netdev->phydev, rq, cmd);
|
return phy_mii_ioctl(netdev->phydev, rq, cmd);
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -91,5 +91,5 @@ index abe0149ed917..e62e96352b6e 100644
|
||||||
|
|
||||||
/* maybe the boot loader passed the MAC address in devicetree */
|
/* maybe the boot loader passed the MAC address in devicetree */
|
||||||
--
|
--
|
||||||
2.33.1
|
2.37.0
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
From 5f26e6ad376e36f2b5d70bcad04562fec7194dee Mon Sep 17 00:00:00 2001
|
From b07c9b386a2ed138077bbde72237b97ffacedc31 Mon Sep 17 00:00:00 2001
|
||||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
||||||
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||||
|
@ -9,10 +9,10 @@ Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
index c4dd2a6b4836..2c2a78292148 100644
|
index b340c9e246c4..2fba5e42e287 100644
|
||||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||||
@@ -745,7 +745,7 @@ wifi_host_wake_l: wifi-host-wake-l {
|
@@ -751,7 +751,7 @@ wifi_host_wake_l: wifi-host-wake-l {
|
||||||
};
|
};
|
||||||
|
|
||||||
&pwm0 {
|
&pwm0 {
|
||||||
|
@ -22,5 +22,5 @@ index c4dd2a6b4836..2c2a78292148 100644
|
||||||
|
|
||||||
&pwm2 {
|
&pwm2 {
|
||||||
--
|
--
|
||||||
2.33.1
|
2.37.0
|
||||||
|
|
||||||
|
|
|
@ -4,10 +4,10 @@
|
||||||
buildarch=8
|
buildarch=8
|
||||||
|
|
||||||
pkgbase=linux-aarch64
|
pkgbase=linux-aarch64
|
||||||
_srcname=linux-5.18
|
_srcname=linux-5.19
|
||||||
_kernelname=${pkgbase#linux}
|
_kernelname=${pkgbase#linux}
|
||||||
_desc="AArch64 multi-platform"
|
_desc="AArch64 multi-platform"
|
||||||
pkgver=5.18.1
|
pkgver=5.19.4
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=('aarch64')
|
arch=('aarch64')
|
||||||
url="http://www.kernel.org/"
|
url="http://www.kernel.org/"
|
||||||
|
@ -25,11 +25,11 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
|
||||||
'linux.preset'
|
'linux.preset'
|
||||||
'60-linux.hook'
|
'60-linux.hook'
|
||||||
'90-linux.hook')
|
'90-linux.hook')
|
||||||
md5sums=('58e80452e2d8e1993cd7ec95e697ab5a'
|
md5sums=('f91bfe133d2cb1692f705947282e123a'
|
||||||
'4d3c0c51927b2bb0de4caa5d64a6dd4c'
|
'd89c87a448cca0f1192666e538984761'
|
||||||
'91d1298599aa31b10f1f3954a450b6c3'
|
'e0514a3e8f7383c1304faeff0121dfb5'
|
||||||
'3b781286c0b97cec552ad6c8a7a019dd'
|
'965c9f68072084cdbf1e083779d2ef0e'
|
||||||
'62514cac04a488f99705eecb1e38d86c'
|
'62e8eaf43030a732d1117d1a9f604c48'
|
||||||
'7c97cf141750ad810235b1ad06eb9f75'
|
'7c97cf141750ad810235b1ad06eb9f75'
|
||||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||||
'584777ae88bce2c5659960151b64c7d8'
|
'584777ae88bce2c5659960151b64c7d8'
|
||||||
|
@ -72,9 +72,8 @@ build() {
|
||||||
_package() {
|
_package() {
|
||||||
pkgdesc="The Linux Kernel and modules - ${_desc}"
|
pkgdesc="The Linux Kernel and modules - ${_desc}"
|
||||||
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
|
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
|
||||||
optdepends=('crda: to set the correct wireless channels of your country')
|
optdepends=('wireless-regdb: to set the correct wireless channels of your country')
|
||||||
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
|
provides=("linux=${pkgver}" "WIREGUARD-MODULE")
|
||||||
replaces=('linux-armv8')
|
|
||||||
conflicts=('linux')
|
conflicts=('linux')
|
||||||
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
|
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
|
||||||
install=${pkgname}.install
|
install=${pkgname}.install
|
||||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue