mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/flatpak to 1.15.6-1
This commit is contained in:
parent
7eec83e906
commit
e5c6540bee
5 changed files with 125 additions and 116 deletions
79
extra/flatpak/.SRCINFO
Normal file
79
extra/flatpak/.SRCINFO
Normal file
|
@ -0,0 +1,79 @@
|
|||
pkgbase = flatpak
|
||||
pkgdesc = Linux application sandboxing and distribution framework (formerly xdg-app)
|
||||
pkgver = 1.15.6
|
||||
pkgrel = 1
|
||||
epoch = 1
|
||||
url = https://flatpak.org
|
||||
arch = x86_64
|
||||
license = LGPL
|
||||
checkdepends = socat
|
||||
checkdepends = valgrind
|
||||
makedepends = docbook-xsl
|
||||
makedepends = git
|
||||
makedepends = gobject-introspection
|
||||
makedepends = gtk-doc
|
||||
makedepends = meson
|
||||
makedepends = python-pyparsing
|
||||
makedepends = wayland-protocols
|
||||
makedepends = xmlto
|
||||
depends = appstream
|
||||
depends = bubblewrap
|
||||
depends = curl
|
||||
depends = dbus
|
||||
depends = fuse3
|
||||
depends = glib2
|
||||
depends = json-glib
|
||||
depends = libarchive
|
||||
depends = libmalcontent
|
||||
depends = libseccomp
|
||||
depends = libxau
|
||||
depends = ostree
|
||||
depends = polkit
|
||||
depends = python
|
||||
depends = systemd
|
||||
depends = wayland
|
||||
depends = xdg-dbus-proxy
|
||||
depends = xdg-utils
|
||||
source = git+https://github.com/flatpak/flatpak#commit=27b11b93c2a80a91c9461bc6c7f5e9a201406041
|
||||
source = git+https://gitlab.gnome.org/GNOME/libglnx.git
|
||||
source = git+https://github.com/projectatomic/bubblewrap
|
||||
source = git+https://github.com/flatpak/xdg-dbus-proxy
|
||||
source = git+https://gitlab.gnome.org/alexl/variant-schema-compiler.git
|
||||
source = https://dl.flathub.org/repo/flathub.flatpakrepo
|
||||
source = flatpak-bindir.sh
|
||||
source = 0001-HACK-Use-fusermount3.patch
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = SKIP
|
||||
b2sums = c094461a28dab284c1d32cf470f38118a6cbce27acce633b81945fb859daef9bdec1261490f344221b5cacf4437f53934cb51173f7ad2f1d2e05001139e75c54
|
||||
b2sums = 1c45caa65e2a1598f219977d5a81dcb8ea5d458880c43c40ba452b0c77cbbf41b36fa6911741f22c807d318e04e39e4fcc1455ed8d68faaba10162dae2570abc
|
||||
b2sums = 76ab2ae38c6043adfa7e521e222d9d1ab0dda70c8cca162218d04b3a1eba53e0c4b8b8df9cd005aa7dc38fc82927a9bba8bb5e235512ddaf90dc98716e242469
|
||||
|
||||
pkgname = flatpak
|
||||
depends = appstream
|
||||
depends = bubblewrap
|
||||
depends = curl
|
||||
depends = dbus
|
||||
depends = fuse3
|
||||
depends = glib2
|
||||
depends = json-glib
|
||||
depends = libarchive
|
||||
depends = libmalcontent
|
||||
depends = libseccomp
|
||||
depends = libxau
|
||||
depends = ostree
|
||||
depends = polkit
|
||||
depends = python
|
||||
depends = systemd
|
||||
depends = wayland
|
||||
depends = xdg-dbus-proxy
|
||||
depends = xdg-utils
|
||||
depends = libostree-1.so
|
||||
depends = xdg-desktop-portal
|
||||
provides = libflatpak.so
|
||||
|
||||
pkgname = flatpak-docs
|
||||
pkgdesc = Linux application sandboxing and distribution framework (formerly xdg-app) (documentation)
|
||||
depends =
|
|
@ -1,8 +1,19 @@
|
|||
diff --git i/common/flatpak-dir.c w/common/flatpak-dir.c
|
||||
index 84816389..b99a7304 100644
|
||||
--- i/common/flatpak-dir.c
|
||||
+++ w/common/flatpak-dir.c
|
||||
@@ -2109,7 +2109,7 @@ flatpak_dir_revokefs_fuse_unmount (OstreeRepo **repo,
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Tue, 14 Nov 2023 21:43:21 +0100
|
||||
Subject: [PATCH] HACK: Use fusermount3
|
||||
|
||||
---
|
||||
common/flatpak-dir.c | 2 +-
|
||||
tests/can-use-fuse.c | 6 +++---
|
||||
tests/libtest.sh | 4 ++--
|
||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
|
||||
index f6a2f872a335..82c06381450b 100644
|
||||
--- a/common/flatpak-dir.c
|
||||
+++ b/common/flatpak-dir.c
|
||||
@@ -2110,7 +2110,7 @@ flatpak_dir_revokefs_fuse_unmount (OstreeRepo **repo,
|
||||
|
||||
fusermount = g_subprocess_new (G_SUBPROCESS_FLAGS_NONE,
|
||||
error,
|
||||
|
@ -11,10 +22,10 @@ index 84816389..b99a7304 100644
|
|||
NULL);
|
||||
if (g_subprocess_wait_check (fusermount, NULL, error))
|
||||
{
|
||||
diff --git i/tests/can-use-fuse.c w/tests/can-use-fuse.c
|
||||
index fb6e2000..759f0d84 100644
|
||||
--- i/tests/can-use-fuse.c
|
||||
+++ w/tests/can-use-fuse.c
|
||||
diff --git a/tests/can-use-fuse.c b/tests/can-use-fuse.c
|
||||
index fb6e20003102..759f0d842c6c 100644
|
||||
--- a/tests/can-use-fuse.c
|
||||
+++ b/tests/can-use-fuse.c
|
||||
@@ -53,23 +53,23 @@ check_fuse (void)
|
||||
return FALSE;
|
||||
}
|
||||
|
@ -42,10 +53,10 @@ index fb6e2000..759f0d84 100644
|
|||
return FALSE;
|
||||
}
|
||||
|
||||
diff --git i/tests/libtest.sh w/tests/libtest.sh
|
||||
index 36d39ac4..e78d94ca 100644
|
||||
--- i/tests/libtest.sh
|
||||
+++ w/tests/libtest.sh
|
||||
diff --git a/tests/libtest.sh b/tests/libtest.sh
|
||||
index 36d39ac4deb7..e78d94ca525a 100644
|
||||
--- a/tests/libtest.sh
|
||||
+++ b/tests/libtest.sh
|
||||
@@ -542,7 +542,7 @@ skip_one_without_bwrap () {
|
||||
}
|
||||
|
|
@ -1,23 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Fri, 17 Mar 2023 01:58:24 +0100
|
||||
Subject: [PATCH] Set size of file info for symlinks to 0
|
||||
|
||||
`ostree_raw_file_to_content_stream` will try to read it, causing a
|
||||
critical warning with GLib 2.76 causing tests to fail.
|
||||
---
|
||||
common/flatpak-utils.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/common/flatpak-utils.c b/common/flatpak-utils.c
|
||||
index f28fdc071b1c..b8ad97003877 100644
|
||||
--- a/common/flatpak-utils.c
|
||||
+++ b/common/flatpak-utils.c
|
||||
@@ -5056,6 +5056,7 @@ flatpak_mtree_create_symlink (OstreeRepo *repo,
|
||||
|
||||
g_file_info_set_name (file_info, filename);
|
||||
g_file_info_set_file_type (file_info, G_FILE_TYPE_SYMBOLIC_LINK);
|
||||
+ g_file_info_set_size (file_info, 0);
|
||||
g_file_info_set_attribute_uint32 (file_info, "unix::uid", 0);
|
||||
g_file_info_set_attribute_uint32 (file_info, "unix::gid", 0);
|
||||
g_file_info_set_attribute_uint32 (file_info, "unix::mode", S_IFLNK | 0777);
|
|
@ -1,61 +0,0 @@
|
|||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||||
Date: Fri, 17 Mar 2023 02:08:38 +0100
|
||||
Subject: [PATCH] tests: Don't use g_test_message before g_test_init
|
||||
|
||||
Meson will fail a test using TAP if the first line on stdout isn't the
|
||||
TAP version declaration.
|
||||
---
|
||||
tests/testlib.c | 14 +++++++-------
|
||||
1 file changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/tests/testlib.c b/tests/testlib.c
|
||||
index 41f27ac9f541..d51cec375bf6 100644
|
||||
--- a/tests/testlib.c
|
||||
+++ b/tests/testlib.c
|
||||
@@ -50,38 +50,38 @@ isolated_test_dir_global_setup (void)
|
||||
|
||||
isolated_test_dir = g_strdup ("/tmp/flatpak-test-XXXXXX");
|
||||
assert_mkdtemp (isolated_test_dir);
|
||||
- g_test_message ("isolated_test_dir: %s", isolated_test_dir);
|
||||
+ g_printerr ("isolated_test_dir: %s\n", isolated_test_dir);
|
||||
|
||||
homedir = g_strconcat (isolated_test_dir, "/home", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (homedir, S_IRWXU | S_IRWXG | S_IRWXO));
|
||||
|
||||
g_setenv ("HOME", homedir, TRUE);
|
||||
- g_test_message ("setting HOME=%s", homedir);
|
||||
+ g_printerr ("setting HOME=%s\n", homedir);
|
||||
|
||||
cachedir = g_strconcat (isolated_test_dir, "/home/cache", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (cachedir, S_IRWXU | S_IRWXG | S_IRWXO));
|
||||
g_setenv ("XDG_CACHE_HOME", cachedir, TRUE);
|
||||
- g_test_message ("setting XDG_CACHE_HOME=%s", cachedir);
|
||||
+ g_printerr ("setting XDG_CACHE_HOME=%s\n", cachedir);
|
||||
|
||||
configdir = g_strconcat (isolated_test_dir, "/home/config", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (configdir, S_IRWXU | S_IRWXG | S_IRWXO));
|
||||
g_setenv ("XDG_CONFIG_HOME", configdir, TRUE);
|
||||
- g_test_message ("setting XDG_CONFIG_HOME=%s", configdir);
|
||||
+ g_printerr ("setting XDG_CONFIG_HOME=%s\n", configdir);
|
||||
|
||||
datadir = g_strconcat (isolated_test_dir, "/home/share", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (datadir, S_IRWXU | S_IRWXG | S_IRWXO));
|
||||
g_setenv ("XDG_DATA_HOME", datadir, TRUE);
|
||||
- g_test_message ("setting XDG_DATA_HOME=%s", datadir);
|
||||
+ g_printerr ("setting XDG_DATA_HOME=%s\n", datadir);
|
||||
|
||||
statedir = g_strconcat (isolated_test_dir, "/home/state", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (statedir, S_IRWXU | S_IRWXG | S_IRWXO));
|
||||
g_setenv ("XDG_STATE_HOME", statedir, TRUE);
|
||||
- g_test_message ("setting XDG_STATE_HOME=%s", statedir);
|
||||
+ g_printerr ("setting XDG_STATE_HOME=%s\n", statedir);
|
||||
|
||||
runtimedir = g_strconcat (isolated_test_dir, "/runtime", NULL);
|
||||
g_assert_no_errno (g_mkdir_with_parents (runtimedir, S_IRWXU));
|
||||
g_setenv ("XDG_RUNTIME_DIR", runtimedir, TRUE);
|
||||
- g_test_message ("setting XDG_RUNTIME_DIR=%s", runtimedir);
|
||||
+ g_printerr ("setting XDG_RUNTIME_DIR=%s\n", runtimedir);
|
||||
|
||||
g_reload_user_special_dirs_cache ();
|
||||
|
|
@ -6,9 +6,15 @@
|
|||
# - move socat to makedepends
|
||||
# - set -Dtests=false
|
||||
|
||||
# TODO: Keep at stable versions starting with 1.16.0
|
||||
# https://bugs.archlinux.org/task/77744
|
||||
|
||||
pkgbase=flatpak
|
||||
pkgname=(flatpak flatpak-docs)
|
||||
pkgver=1.15.4
|
||||
pkgname=(
|
||||
flatpak
|
||||
flatpak-docs
|
||||
)
|
||||
pkgver=1.15.6
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc="Linux application sandboxing and distribution framework (formerly xdg-app)"
|
||||
|
@ -31,7 +37,9 @@ depends=(
|
|||
polkit
|
||||
python
|
||||
systemd
|
||||
wayland
|
||||
xdg-dbus-proxy
|
||||
xdg-utils
|
||||
)
|
||||
makedepends=(
|
||||
docbook-xsl
|
||||
|
@ -40,13 +48,14 @@ makedepends=(
|
|||
gtk-doc
|
||||
meson
|
||||
python-pyparsing
|
||||
wayland-protocols
|
||||
xmlto
|
||||
socat
|
||||
)
|
||||
checkdepends=(
|
||||
valgrind
|
||||
)
|
||||
_commit=e936e3100d406c50ba49f3ad6a0ecae455345ec0 # tags/1.15.4^0
|
||||
_commit=27b11b93c2a80a91c9461bc6c7f5e9a201406041 # tags/1.15.6^0
|
||||
source=(
|
||||
"git+https://github.com/flatpak/flatpak#commit=$_commit"
|
||||
git+https://gitlab.gnome.org/GNOME/libglnx.git
|
||||
|
@ -54,10 +63,8 @@ source=(
|
|||
git+https://github.com/flatpak/xdg-dbus-proxy
|
||||
git+https://gitlab.gnome.org/alexl/variant-schema-compiler.git
|
||||
https://dl.flathub.org/repo/flathub.flatpakrepo
|
||||
0001-Set-size-of-file-info-for-symlinks-to-0.patch
|
||||
0002-tests-Don-t-use-g_test_message-before-g_test_init.patch
|
||||
fusermount3.diff
|
||||
flatpak-bindir.sh
|
||||
0001-HACK-Use-fusermount3.patch
|
||||
)
|
||||
b2sums=('SKIP'
|
||||
'SKIP'
|
||||
|
@ -65,10 +72,8 @@ b2sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'c094461a28dab284c1d32cf470f38118a6cbce27acce633b81945fb859daef9bdec1261490f344221b5cacf4437f53934cb51173f7ad2f1d2e05001139e75c54'
|
||||
'e143c7bb1179b3fb337b05b14e3a2506b5603d315739e38df99264f98c362113fa4cc92bb3442c47354a3d0d91fd3dc6a9d4f92c7991db725867550c3ec07ca8'
|
||||
'16e3006819ae991f676426163e69656b4340b8ca83c615668120858ec8e0a100c73e34b84ff94e6a62c6b5e7c9b95cf27ac95b9a8b33e81d53cc031364c53db3'
|
||||
'81010a49af57e6047ab57285e3f8430da3b2be8504bc5600502da9a3729e9f92bb086a314ca8a03bca446e8f203150e378f3443f7034d8d7ade9dad6f1b9db59'
|
||||
'1c45caa65e2a1598f219977d5a81dcb8ea5d458880c43c40ba452b0c77cbbf41b36fa6911741f22c807d318e04e39e4fcc1455ed8d68faaba10162dae2570abc')
|
||||
'1c45caa65e2a1598f219977d5a81dcb8ea5d458880c43c40ba452b0c77cbbf41b36fa6911741f22c807d318e04e39e4fcc1455ed8d68faaba10162dae2570abc'
|
||||
'76ab2ae38c6043adfa7e521e222d9d1ab0dda70c8cca162218d04b3a1eba53e0c4b8b8df9cd005aa7dc38fc82927a9bba8bb5e235512ddaf90dc98716e242469')
|
||||
|
||||
pkgver() {
|
||||
cd flatpak
|
||||
|
@ -78,19 +83,17 @@ pkgver() {
|
|||
prepare() {
|
||||
cd flatpak
|
||||
|
||||
# Fix tests
|
||||
git apply -3 ../0001-Set-size-of-file-info-for-symlinks-to-0.patch
|
||||
git apply -3 ../0002-tests-Don-t-use-g_test_message-before-g_test_init.patch
|
||||
|
||||
# Support fuse3
|
||||
# https://bugs.archlinux.org/task/75623
|
||||
git apply -3 ../fusermount3.diff
|
||||
git apply -3 ../0001-HACK-Use-fusermount3.patch
|
||||
|
||||
# git submodule set-url is broken
|
||||
# https://lore.kernel.org/git/cafa28e0bfe1f603204a74f619ac713518989a40.camel@archlinux.org/T/#u
|
||||
git submodule init
|
||||
git submodule set-url libglnx "$srcdir/libglnx"
|
||||
git submodule set-url bubblewrap "$srcdir/bubblewrap"
|
||||
git submodule set-url dbus-proxy "$srcdir/xdg-dbus-proxy"
|
||||
git submodule set-url variant-schema-compiler "$srcdir/variant-schema-compiler"
|
||||
git config --local submodule.libglnx.url "$srcdir/libglnx"
|
||||
git config --local submodule.bubblewrap.url "$srcdir/bubblewrap"
|
||||
git config --local submodule.dbus-proxy.url "$srcdir/xdg-dbus-proxy"
|
||||
git config --local submodule.variant-schema-compiler.url "$srcdir/variant-schema-compiler"
|
||||
git -c protocol.file.allow=always submodule update
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue