mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/percona-server to 8.0.33_25-1
This commit is contained in:
parent
d7b1916229
commit
e5cd259e71
2 changed files with 101 additions and 3 deletions
|
@ -6,7 +6,7 @@
|
|||
|
||||
pkgbase=percona-server
|
||||
pkgname=('libperconaserverclient' 'percona-server-clients' 'percona-server')
|
||||
pkgver=8.0.32_24
|
||||
pkgver=8.0.33_25
|
||||
_boost_ver=1.77.0
|
||||
_pkgver=${pkgver/_/-}
|
||||
_myver=${pkgver/_rel*}
|
||||
|
@ -21,18 +21,22 @@ source=("https://www.percona.com/downloads/Percona-Server-${pkgver%.*_*}/Percona
|
|||
'my.cnf'
|
||||
'mysql-user.conf'
|
||||
'mysqlrouter-user.conf'
|
||||
'mysql-build-fix.patch'
|
||||
'0001-fix-LF_PINS-padding-calculation.patch')
|
||||
sha256sums=('2867706e914597cb3a5161751573c5463caf8343684ed7eeafcad1eb8f2d081e'
|
||||
sha256sums=('9871cac20c226bba7607f35c19ee23516a38c67573dd48618727c74eae22912e'
|
||||
'5347464af5b14ac54bb945dc68f1dd7c56f0dad7262816b956138fc53bcc0131'
|
||||
'b467b04d6d06152b2abc33f2a6de63fef0fc922dd5119d2ee1d07d3c1a489731'
|
||||
'5d7710fe88ec6d298175a309c0b776142397b119c468830b2865980292ed5da6'
|
||||
'4ca7ffdcb2d1716d4f31e4c7dd314e5d76e64f13fdc67c5d81c53650b793f5e0'
|
||||
'ea17c754d5595bf053d733373b7c4ae6d608a9f85a990dbe5779b499dd398bef'
|
||||
'aa5e960625843b061f47c32b4a267fab1115667b8b7d1ce7ec952efe42eb77af')
|
||||
|
||||
prepare() {
|
||||
cd $pkgbase-$_pkgver
|
||||
rm -v sql/sql_yacc.{cc,h}
|
||||
|
||||
patch -p1 -i ../mysql-build-fix.patch
|
||||
|
||||
sed -r -e s@/var/run/mysqlrouter@/run/mysqlrouter@ \
|
||||
-e s@lib64/mysql@lib/mysql@ \
|
||||
-i cmake/install_layout.cmake
|
||||
|
@ -202,5 +206,4 @@ package_percona-server() {
|
|||
|
||||
# not needed
|
||||
rm -r usr/share/mysql-test
|
||||
rm usr/share/doc/percona-server/mysql.info
|
||||
}
|
||||
|
|
95
extra/percona-server/mysql-build-fix.patch
Normal file
95
extra/percona-server/mysql-build-fix.patch
Normal file
|
@ -0,0 +1,95 @@
|
|||
diff --git a/cmake/zlib.cmake b/cmake/zlib.cmake
|
||||
index 460d87a..4b98b68 100644
|
||||
--- a/cmake/zlib.cmake
|
||||
+++ b/cmake/zlib.cmake
|
||||
@@ -32,7 +32,7 @@
|
||||
SET(MIN_ZLIB_VERSION_REQUIRED "1.2.13")
|
||||
|
||||
|
||||
-FUNCTION(FIND_ZLIB_VERSION ZLIB_INCLUDE_DIR)
|
||||
+MACRO(FIND_ZLIB_VERSION ZLIB_INCLUDE_DIR)
|
||||
FOREACH(version_part
|
||||
ZLIB_VER_MAJOR
|
||||
ZLIB_VER_MINOR
|
||||
@@ -48,9 +48,9 @@ FUNCTION(FIND_ZLIB_VERSION ZLIB_INCLUDE_DIR)
|
||||
SET(ZLIB_VERSION "${ZLIB_VERSION}" CACHE INTERNAL "ZLIB major.minor.step")
|
||||
MESSAGE(STATUS "ZLIB_VERSION (${WITH_ZLIB}) is ${ZLIB_VERSION}")
|
||||
MESSAGE(STATUS "ZLIB_INCLUDE_DIR ${ZLIB_INCLUDE_DIR}")
|
||||
-ENDFUNCTION(FIND_ZLIB_VERSION)
|
||||
+ENDMACRO(FIND_ZLIB_VERSION)
|
||||
|
||||
-FUNCTION(FIND_SYSTEM_ZLIB)
|
||||
+MACRO(FIND_SYSTEM_ZLIB)
|
||||
FIND_PACKAGE(ZLIB)
|
||||
IF(ZLIB_FOUND)
|
||||
ADD_LIBRARY(zlib_interface INTERFACE)
|
||||
@@ -61,7 +61,7 @@ FUNCTION(FIND_SYSTEM_ZLIB)
|
||||
${ZLIB_INCLUDE_DIR})
|
||||
ENDIF()
|
||||
ENDIF()
|
||||
-ENDFUNCTION(FIND_SYSTEM_ZLIB)
|
||||
+ENDMACRO(FIND_SYSTEM_ZLIB)
|
||||
|
||||
MACRO (RESET_ZLIB_VARIABLES)
|
||||
# Reset whatever FIND_PACKAGE may have left behind.
|
||||
@@ -114,9 +114,9 @@ MACRO (MYSQL_CHECK_ZLIB)
|
||||
MYSQL_USE_BUNDLED_ZLIB()
|
||||
ELSEIF(WITH_ZLIB STREQUAL "system")
|
||||
FIND_SYSTEM_ZLIB()
|
||||
- IF(NOT ZLIB_FOUND)
|
||||
- MESSAGE(FATAL_ERROR "Cannot find system zlib libraries.")
|
||||
- ENDIF()
|
||||
+ # IF(NOT ZLIB_FOUND)
|
||||
+ # MESSAGE(FATAL_ERROR "Cannot find system zlib libraries.")
|
||||
+ # ENDIF()
|
||||
ELSE()
|
||||
RESET_ZLIB_VARIABLES()
|
||||
MESSAGE(FATAL_ERROR "WITH_ZLIB must be bundled or system")
|
||||
diff --git a/components/keyrings/common/data/data.h b/components/keyrings/common/data/data.h
|
||||
index 6340a26..566e036 100644
|
||||
--- a/components/keyrings/common/data/data.h
|
||||
+++ b/components/keyrings/common/data/data.h
|
||||
@@ -23,6 +23,7 @@
|
||||
#ifndef DATA_INCLUDED
|
||||
#define DATA_INCLUDED
|
||||
|
||||
+#include <cstdint>
|
||||
#include <functional>
|
||||
#include <string>
|
||||
#include "pfs_string.h"
|
||||
diff --git a/mysys/buffered_error_log.cc b/mysys/buffered_error_log.cc
|
||||
index a8abb63..7f8e39a 100644
|
||||
--- a/mysys/buffered_error_log.cc
|
||||
+++ b/mysys/buffered_error_log.cc
|
||||
@@ -1,5 +1,6 @@
|
||||
|
||||
#include "buffered_error_log.h"
|
||||
+#include <string>
|
||||
|
||||
Buffered_error_logger buffered_error_log;
|
||||
char *buffered_error_log_filename = nullptr;
|
||||
diff --git a/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h b/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h
|
||||
index f356395..c6651ca 100644
|
||||
--- a/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h
|
||||
+++ b/storage/rocksdb/rocksdb/table/block_based/data_block_hash_index.h
|
||||
@@ -5,6 +5,8 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
#include <string>
|
||||
#include <vector>
|
||||
|
||||
diff --git a/storage/rocksdb/rocksdb/util/string_util.h b/storage/rocksdb/rocksdb/util/string_util.h
|
||||
index 55d106f..11178fd 100644
|
||||
--- a/storage/rocksdb/rocksdb/util/string_util.h
|
||||
+++ b/storage/rocksdb/rocksdb/util/string_util.h
|
||||
@@ -6,6 +6,7 @@
|
||||
|
||||
#pragma once
|
||||
|
||||
+#include <cstdint>
|
||||
#include <sstream>
|
||||
#include <string>
|
||||
#include <unordered_map>
|
Loading…
Reference in a new issue