community/jupyterlab to 3.3.3-1

This commit is contained in:
David Beauchamp 2022-04-07 14:59:26 -04:00
parent 99e1d0fcef
commit e5cdd85842
2 changed files with 10 additions and 13 deletions

View file

@ -5,8 +5,8 @@
pkgname=jupyterlab
_pipname=jupyterlab
pkgver=3.3.2
pkgrel=3
pkgver=3.3.3
pkgrel=1
pkgdesc='JupyterLab computational environment'
arch=(any)
url='https://github.com/jupyterlab/jupyterlab'
@ -16,15 +16,12 @@ depends=(python-jupyterlab_server python-jupyter_packaging jupyter-notebook-shim
optdepends=('npm: to install extensions' 'jupyterlab-widgets: ipywidgets support')
checkdepends=('python-pytest-tornasync' 'npm')
source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz
no-nbclassic.patch
jupyterlab-fix-tests.patch::https://github.com/jupyterlab/jupyterlab/commit/56b437fc.patch)
sha256sums=('3c716bf5592cb28c5c55c615c6e5bd3efc71898f6957d13719b56478bbbb587a'
'923954cca5ac139091f3a6c7c922c3bf3b4173375bb28a1cc016f74f82869d7e'
'5db8f09ecb71ca93c09d050940c9767218bf4ffc5368225eb7ebd72a7f02ed90')
no-nbclassic.patch)
sha256sums=('294d67126015ba397f6b1c80563deec862e47e042623851bbe2a7d870d69eb6a'
'c81b7b957622b7ea68589daa568bba96a8955e768aea0bce60c27fa041e07cc4')
prepare() {
patch -d $pkgname-$pkgver -p1 < no-nbclassic.patch # Drop nbclassic dependency
patch -d $pkgname-$pkgver -p1 < jupyterlab-fix-tests.patch # Fix tests
}
build() {

View file

@ -1,11 +1,11 @@
diff --git a/jupyterlab/labapp.py b/jupyterlab/labapp.py
index 75af58179c..df2bcdc4cd 100644
index 1eb56b22fe..5a401a0fdf 100644
--- a/jupyterlab/labapp.py
+++ b/jupyterlab/labapp.py
@@ -14,7 +14,7 @@ from jupyter_server.serverapp import flags
from jupyter_server.utils import url_path_join as ujoin
from jupyterlab_server import LabServerApp, LicensesApp, WorkspaceExportApp, WorkspaceImportApp, WorkspaceListApp
@@ -19,7 +19,7 @@ from jupyterlab_server import (
WorkspaceImportApp,
WorkspaceListApp,
)
-from nbclassic.shim import NBClassicConfigShimMixin
+from notebook_shim.shim import NotebookConfigShimMixin as NBClassicConfigShimMixin
from traitlets import Bool, Instance, Unicode, default