extra/gst-plugins-bad to 1.14.2-1

This commit is contained in:
Kevin Mihelich 2018-07-20 18:18:29 +00:00
parent 35e1c97297
commit e5e1631105
2 changed files with 61 additions and 5 deletions

View file

@ -6,8 +6,8 @@
# - remove --enable-gtk-doc from configure - broken with latest gtk-doc
pkgname=gst-plugins-bad
pkgver=1.14.1
pkgrel=2
pkgver=1.14.2
pkgrel=1
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@ -19,11 +19,13 @@ depends=(mjpegtools gst-plugins-base-libs curl chromaprint libmms faad2 celt lib
openexr libbs2b libnice lcms2 bluez-libs glu srt)
makedepends=(python gtk-doc autoconf-archive git gobject-introspection gtk3 vulkan-headers
vulkan-validation-layers librsvg libtiger zbar fluidsynth lilv opencv)
_commit=fd178617d0fc3bed781d566def792f90d7825d01 # tags/1.14.1^0
_commit=513ef5efdf85f9af4a016e8ae69f28cf16c9ec58 # tags/1.14.2^0
source=("git+https://anongit.freedesktop.org/git/gstreamer/gst-plugins-bad#commit=$_commit"
"gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common")
"gst-common::git+https://anongit.freedesktop.org/git/gstreamer/common"
missing-includes.diff)
sha256sums=('SKIP'
'SKIP')
'SKIP'
'acf625d58611372532bc76e7276dacd69d2a9f7dee88ed9e2e8ecae0881476a3')
pkgver() {
cd $pkgname
@ -33,6 +35,9 @@ pkgver() {
prepare() {
cd $pkgname
# error: CV_RGB was not declared in this scope
patch -Np1 -i ../missing-includes.diff
git submodule init
git config --local submodule.common.url "$srcdir/gst-common"
git submodule update

View file

@ -0,0 +1,51 @@
Submodule common f0c2dc9aa..ed78bee43:
> valgrind suppressions: ignore any error triggered by */ld*.so
> gtk-doc-plugins.mak: sort xml inspect files
diff --git i/ext/opencv/MotionCells.cpp w/ext/opencv/MotionCells.cpp
index f85989e11..e75191308 100644
--- i/ext/opencv/MotionCells.cpp
+++ w/ext/opencv/MotionCells.cpp
@@ -52,6 +52,7 @@
#include <errno.h>
#include "MotionCells.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc/imgproc.hpp>
MotionCells::MotionCells ()
{
diff --git i/ext/opencv/gsthanddetect.cpp w/ext/opencv/gsthanddetect.cpp
index 60fd5be72..aadbc03de 100644
--- i/ext/opencv/gsthanddetect.cpp
+++ w/ext/opencv/gsthanddetect.cpp
@@ -63,6 +63,7 @@
/* element header */
#include "gsthanddetect.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_handdetect_debug);
#define GST_CAT_DEFAULT gst_handdetect_debug
diff --git i/ext/opencv/gstsegmentation.cpp w/ext/opencv/gstsegmentation.cpp
index d52476e7d..fd3abb507 100644
--- i/ext/opencv/gstsegmentation.cpp
+++ w/ext/opencv/gstsegmentation.cpp
@@ -92,6 +92,7 @@
#include "gstsegmentation.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_segmentation_debug);
#define GST_CAT_DEFAULT gst_segmentation_debug
diff --git i/ext/opencv/gsttemplatematch.cpp w/ext/opencv/gsttemplatematch.cpp
index f39208dc2..50197f23d 100644
--- i/ext/opencv/gsttemplatematch.cpp
+++ w/ext/opencv/gsttemplatematch.cpp
@@ -64,6 +64,7 @@
#include "../../gst-libs/gst/gst-i18n-plugin.h"
#include "gsttemplatematch.h"
#include <opencv2/imgproc/imgproc_c.h>
+#include <opencv2/imgproc.hpp>
GST_DEBUG_CATEGORY_STATIC (gst_template_match_debug);
#define GST_CAT_DEFAULT gst_template_match_debug