mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
community/linux-tools to 4.0-1
This commit is contained in:
parent
1661aacc0e
commit
e62131890a
2 changed files with 7 additions and 21 deletions
|
@ -1,13 +0,0 @@
|
|||
# Copyright 2014 Sébastien Luttringer
|
||||
|
||||
--- a/tools/thermal/tmon/Makefile
|
||||
+++ b/tools/thermal/tmon/Makefile
|
||||
@@ -21,7 +21,7 @@ OBJS = tmon.o tui.o sysfs.o pid.o
|
||||
OBJS +=
|
||||
|
||||
tmon: $(OBJS) Makefile tmon.h
|
||||
- $(CC) ${CFLAGS} $(LDFLAGS) $(OBJS) -o $(TARGET) -lm -lpanel -lncursesw -ltinfo -lpthread
|
||||
+ $(CC) ${CFLAGS} $(LDFLAGS) $(OBJS) -o $(TARGET) -lm -lpanel -lncursesw -lpthread
|
||||
|
||||
valgrind: tmon
|
||||
sudo valgrind -v --track-origins=yes --tool=memcheck --leak-check=yes --show-reachable=yes --num-callers=20 --track-fds=yes ./$(TARGET) 1> /dev/null
|
|
@ -16,7 +16,7 @@ pkgname=(
|
|||
'tmon'
|
||||
'usbip'
|
||||
)
|
||||
pkgver=3.19
|
||||
pkgver=4.0
|
||||
pkgrel=1
|
||||
license=('GPL2')
|
||||
arch=('i686' 'x86_64')
|
||||
|
@ -34,31 +34,30 @@ makedepends+=('glib2' 'sysfsutils' 'udev')
|
|||
# tmon deps
|
||||
makedepends+=('ncurses')
|
||||
groups=("$pkgbase")
|
||||
source=("http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$pkgver.tar.xz"
|
||||
#"http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.7.xz"
|
||||
validpgpkeys=('ABAF11C65A2970B130ABE3C479BE3E4300411886') # Linus Torvalds
|
||||
source=("http://ftp.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/linux-$pkgver.tar"{.xz,.sign}
|
||||
#"http://ftp.kernel.org/pub/linux/kernel/v${pkgver:0:1}.x/patch-$pkgver.7.xz"
|
||||
'cpupower.default'
|
||||
'cpupower.systemd'
|
||||
'cpupower.service'
|
||||
'usbipd.service'
|
||||
'02-archlinux-paths.patch'
|
||||
'03-fix-tmon-ltinfo.patch'
|
||||
'04-fix-usip-h-path.patch')
|
||||
# http://www.kernel.org/pub/linux/kernel/v3.x/sha256sums.asc
|
||||
sha256sums=('be42511fe5321012bb4a2009167ce56a9e5fe362b4af43e8c371b3666859806c'
|
||||
# http://www.kernel.org/pub/linux/kernel/v4.x/sha256sums.asc
|
||||
sha256sums=('0f2f7d44979bc8f71c4fc5d3308c03499c26a824dd311fdf6eef4dee0d7d5991'
|
||||
'SKIP'
|
||||
'6d54f1dcd4d9441644a7ef4445f6633158e666fddaa6f06bb6656ab2ff4509d4'
|
||||
'4fa509949d6863d001075fa3e8671eff2599c046d20c98bb4a70778595cd1c3f'
|
||||
'fbf6e0ce6eb0ef15703fe212958de6ca46e62188900b5e9f9272ed3cc9cfd54e'
|
||||
'a89284d0ecb556ca53a66d1c2087b5fd6d0a901ab2769cd3aebb93f4478905dc'
|
||||
'2e187734d8aec58a3046d79883510d779aa93fb3ab20bd3132c1a607ebe5498f'
|
||||
'eb866a589a26b1979ffb2fe08be09417e277a4befac34bdb279a6bb3a27b0570'
|
||||
'7547815bb761d49d198b85f95011535713c2ed4a004f249a9cf6ba985af8c4ed'
|
||||
'e5543d8d6d3fbc7f8d9d25c428a882737d2e0169455f70cbc3f73076ff33dd5d')
|
||||
|
||||
prepare() {
|
||||
cd linux-$pkgver
|
||||
#patch -N -p1 -i "$srcdir/patch-$pkgver.7"
|
||||
patch -N -p1 -i "$srcdir/02-archlinux-paths.patch"
|
||||
patch -N -p1 -i "$srcdir/03-fix-tmon-ltinfo.patch"
|
||||
patch -N -p1 -i "$srcdir/04-fix-usip-h-path.patch"
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue