extra/boost to 1.66.0-3

This commit is contained in:
Kevin Mihelich 2018-05-30 23:21:15 +00:00
parent 5264cc8c91
commit e66fa35fe9
2 changed files with 34 additions and 3 deletions

23
extra/boost/776.patch Normal file
View file

@ -0,0 +1,23 @@
From fdbdb94db64e888fce90fe519be23c2a4396a82e Mon Sep 17 00:00:00 2001
From: pradeep <pradeep@arrayfire.com>
Date: Tue, 8 May 2018 14:53:38 +0530
Subject: [PATCH 1/2] Fix return var qualifier in svm_ptr::get_context
Lack of `const` qualifier is throwing errors with GCC 8.1
---
include/boost/compute/memory/svm_ptr.hpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/boost/compute/memory/svm_ptr.hpp b/include/boost/compute/memory/svm_ptr.hpp
index c8753f5b..56cf1268 100644
--- a/include/boost/compute/memory/svm_ptr.hpp
+++ b/include/boost/compute/memory/svm_ptr.hpp
@@ -126,7 +126,7 @@ class svm_ptr
return m_ptr - other.m_ptr;
}
- context& get_context() const
+ const context& get_context() const
{
return m_context;
}

View file

@ -18,13 +18,21 @@ pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.66.0
_boostver=${pkgver//./_}
pkgrel=2
pkgrel=3
url='http://www.boost.org/'
arch=('x86_64')
license=('custom')
makedepends=('icu>=55.1' 'python' 'python2' 'python-numpy' 'python2-numpy' 'bzip2' 'zlib' 'openmpi')
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2)
sha256sums=('5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9')
source=(https://downloads.sourceforge.net/project/${pkgbase}/${pkgbase}/${pkgver}/${pkgbase}_${_boostver}.tar.bz2
776.patch)
sha256sums=('5721818253e6a0989583192f96782c4a98eb6204965316df9f5ad75819225ca9'
'43cdc2081f90d2acc7e4d9de6689bce07b2a1b4754e85dc7fa50872afa330ffa')
prepare() {
cd ${pkgbase}_${_boostver}/boost
patch -Np3 -i "$srcdir"/776.patch
}
build() {
CFLAGS=`echo $CFLAGS | sed -e 's/armv6/armv6k/'` && CXXFLAGS="$CFLAGS"