mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/android-tools to 29.0.2-2
This commit is contained in:
parent
3781ceedb3
commit
e6807f5eab
3 changed files with 13 additions and 41 deletions
|
@ -9,7 +9,7 @@ buildarch=28
|
|||
|
||||
pkgname=android-tools
|
||||
pkgver=29.0.2
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
tag=platform-tools-$pkgver
|
||||
pkgdesc='Android platform tools'
|
||||
arch=(x86_64)
|
||||
|
@ -20,7 +20,7 @@ optdepends=('python: for mkbootimg script')
|
|||
makedepends=(git clang gtest ruby cmake ninja go-pie)
|
||||
provides=(fastboot adb)
|
||||
conflicts=(fastboot adb)
|
||||
_boringssl_commit=`curl https://android.googlesource.com/platform/external/boringssl/+/refs/tags/$tag/BORINGSSL_REVISION?format=TEXT | base64 -d`
|
||||
_boringssl_commit=$(curl https://android.googlesource.com/platform/external/boringssl/+/refs/tags/$tag/BORINGSSL_REVISION?format=TEXT | base64 -d)
|
||||
source=(git+https://android.googlesource.com/platform/system/core#tag=$tag
|
||||
git+https://android.googlesource.com/platform/system/extras#tag=$tag
|
||||
git+https://android.googlesource.com/platform/system/tools/mkbootimg#tag=$tag
|
||||
|
@ -31,7 +31,6 @@ source=(git+https://android.googlesource.com/platform/system/core#tag=$tag
|
|||
git+https://boringssl.googlesource.com/boringssl#commit=$_boringssl_commit
|
||||
generate_build.rb
|
||||
fix_build_core.patch
|
||||
fix_build_selinux.patch
|
||||
fix_build_e2fsprogs.patch
|
||||
bash_completion.fastboot)
|
||||
# Bash completion file was taken from https://github.com/mbrubeck/android-completion
|
||||
|
@ -43,36 +42,35 @@ sha1sums=('SKIP'
|
|||
'SKIP'
|
||||
'SKIP'
|
||||
'SKIP'
|
||||
'ff8613a331b9026f2f413768f88ccd10e26149bf'
|
||||
'afca7974ad8658e52fd028ead12ad0a959d63273'
|
||||
'99a1618bd93af8ef3ff2cca893e950a0346021fe'
|
||||
'b2ccf6dac3577d230f910e668ae70af6051fee46'
|
||||
'bcebdf1e706a3c3da175234840c6ee4e13652012'
|
||||
'7004dbd0c193668827174880de6f8434de8ceaee')
|
||||
|
||||
prepare() {
|
||||
PLATFORM_TOOLS_VERSION="$pkgver" LDFLAGS='-Wl,-z,relro,-z,now' ./generate_build.rb > build.ninja
|
||||
|
||||
cd $srcdir/core
|
||||
cd "$srcdir"/core
|
||||
patch -p1 < ../fix_build_core.patch
|
||||
|
||||
cd $srcdir/selinux
|
||||
patch -p1 < ../fix_build_selinux.patch
|
||||
|
||||
cd $srcdir/e2fsprogs
|
||||
cd "$srcdir"/e2fsprogs
|
||||
patch -p1 < ../fix_build_e2fsprogs.patch
|
||||
|
||||
cd $srcdir/avb
|
||||
cd "$srcdir"/avb
|
||||
sed -i 's|/usr/bin/env python$|/usr/bin/env python2|g' avbtool
|
||||
|
||||
cd "$srcdir"/mkbootimg
|
||||
sed -i 's|/usr/bin/env python$|/usr/bin/env python2|g' unpack_bootimg.py
|
||||
|
||||
sed -i 's/-fno-common/-fno-common -Wno-error=attributes/' $srcdir/boringssl/CMakeLists.txt
|
||||
mkdir -p $srcdir/boringssl/build && cd $srcdir/boringssl/build && cmake -GNinja ..; ninja
|
||||
mkdir -p "$srcdir"/boringssl/build && cd "$srcdir"/boringssl/build && cmake -GNinja ..; ninja crypto/libcrypto.a
|
||||
}
|
||||
|
||||
build() {
|
||||
ninja
|
||||
}
|
||||
|
||||
package(){
|
||||
package() {
|
||||
install -m755 -d "$pkgdir"/usr/bin
|
||||
install -m755 -t "$pkgdir"/usr/bin fastboot adb mke2fs.android e2fsdroid ext2simg avb/avbtool
|
||||
install -Dm 755 mkbootimg/mkbootimg.py "$pkgdir"/usr/bin/mkbootimg
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
diff --git a/libsepol/src/private.h b/libsepol/src/private.h
|
||||
index b884c23b..447fa64b 100644
|
||||
--- a/libsepol/src/private.h
|
||||
+++ b/libsepol/src/private.h
|
||||
@@ -14,7 +14,7 @@
|
||||
#endif
|
||||
|
||||
#include <errno.h>
|
||||
-#include <dso.h>
|
||||
+#include "dso.h"
|
||||
|
||||
#ifdef __APPLE__
|
||||
#define __BYTE_ORDER BYTE_ORDER
|
||||
diff --git a/libsepol/src/util.c b/libsepol/src/util.c
|
||||
index a4008882..d79a8335 100644
|
||||
--- a/libsepol/src/util.c
|
||||
+++ b/libsepol/src/util.c
|
||||
@@ -27,7 +27,7 @@
|
||||
#include <sepol/policydb/flask_types.h>
|
||||
#include <sepol/policydb/policydb.h>
|
||||
#include <sepol/policydb/util.h>
|
||||
-#include <dso.h>
|
||||
+#include "dso.h"
|
||||
|
||||
struct val_to_name {
|
||||
unsigned int val;
|
|
@ -176,7 +176,7 @@ fastbootfiles = %w(
|
|||
main.cpp
|
||||
fastboot_driver.cpp
|
||||
)
|
||||
libfastboot = compile(expand("core/fastboot", fastbootfiles), '-DPLATFORM_TOOLS_VERSION="\"$PLATFORM_TOOLS_VERSION\"" -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -DUSE_F2FS -Icore/base/include -Icore/include -Icore/adb -Icore/libsparse/include -Imkbootimg/include/bootimg -Iextras/ext4_utils/include -Iextras/f2fs_utils -Icore/libziparchive/include -Imkbootimg/include/bootimg/include/bootimg -Icore/fs_mgr/liblp/include -Icore/diagnose_usb/include')
|
||||
libfastboot = compile(expand("core/fastboot", fastbootfiles), '-DPLATFORM_TOOLS_VERSION="\"$PLATFORM_TOOLS_VERSION\"" -D_GNU_SOURCE -D_XOPEN_SOURCE=700 -DUSE_F2FS -Icore/base/include -Icore/include -Icore/adb -Icore/libsparse/include -Imkbootimg/include/bootimg -Iextras/ext4_utils/include -Iextras/f2fs_utils -Icore/libziparchive/include -Icore/fs_mgr/liblp/include -Icore/diagnose_usb/include')
|
||||
|
||||
fsmgrfiles = %w(
|
||||
liblp/reader.cpp
|
||||
|
@ -272,7 +272,7 @@ libsepolfiles = %w(
|
|||
hierarchy.c
|
||||
kernel_to_common.c
|
||||
)
|
||||
libsepol = compile(expand("selinux/libsepol/src", libsepolfiles), "-Iselinux/libsepol/include")
|
||||
libsepol = compile(expand("selinux/libsepol/src", libsepolfiles), "-Iselinux/libsepol/include -Iselinux/libsepol/src")
|
||||
|
||||
link("fastboot", libfsmgr + libsparse + libzip + libcutils + liblog + libutil + libbase + libext4 + f2fs + libselinux + libsepol + libfastboot + libdiagnoseusb + boringssl, "-lz -lpcre2-8 -lpthread -ldl")
|
||||
|
||||
|
|
Loading…
Reference in a new issue