core/linux-armv7 to 6.9.12-2

This commit is contained in:
Kevin Mihelich 2024-08-06 13:06:17 +00:00
parent 6b02ffc860
commit e6dc55592f
8 changed files with 354 additions and 296 deletions

View file

@ -1,4 +1,4 @@
From 4533007cef1bd1da546752b372234b9bb9548214 Mon Sep 17 00:00:00 2001
From c8c8ba803738ca4c4260ab6b186f8100baf735ba Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
@ -12,7 +12,7 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
1 file changed, 17 insertions(+)
diff --git a/arch/arm/include/uapi/asm/setup.h b/arch/arm/include/uapi/asm/setup.h
index 25ceda63b284..83578c54975b 100644
index 8e50e034fec7..827143cd47aa 100644
--- a/arch/arm/include/uapi/asm/setup.h
+++ b/arch/arm/include/uapi/asm/setup.h
@@ -144,6 +144,18 @@ struct tag_memclk {
@ -47,5 +47,5 @@ index 25ceda63b284..83578c54975b 100644
};
--
2.37.0
2.45.2

View file

@ -1,4 +1,4 @@
From b2f96ec9b408c8bbec437c3d3b54c0b748fca85a Mon Sep 17 00:00:00 2001
From 8167bb1e9ba5788b359b8ef598337a6138a731ff Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
@ -17,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
index 1feb6b0f7a1f..5e5cb3094b6a 100644
index 627752f18661..62128c5d8669 100644
--- a/arch/arm/boot/compressed/atags_to_fdt.c
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
@@ -205,6 +205,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
@@ -206,6 +206,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
hex_str(serno, atag->u.serialnr.high);
hex_str(serno+8, atag->u.serialnr.low);
setprop_string(fdt, "/", "serial-number", serno);
@ -34,5 +34,5 @@ index 1feb6b0f7a1f..5e5cb3094b6a 100644
}
--
2.37.0
2.45.2

View file

@ -1,4 +1,4 @@
From 5b76d7e549a6f65f881ef832cb39ae6a4ad34119 Mon Sep 17 00:00:00 2001
From c9c7d39cf65e5fdaaaf9ca90dca6e047e3edb044 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 3/7] fix mvsdio eMMC timing
@ -12,10 +12,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
index 629efbe639c4..c507c064736c 100644
index af7f21888e27..250489b22eaa 100644
--- a/drivers/mmc/host/mvsdio.c
+++ b/drivers/mmc/host/mvsdio.c
@@ -90,7 +90,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
@@ -91,7 +91,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
tmout_index = fls(tmout - 1) - 12;
if (tmout_index < 0)
tmout_index = 0;
@ -24,7 +24,7 @@ index 629efbe639c4..c507c064736c 100644
tmout_index = MVSD_HOST_CTRL_TMOUT_MAX;
dev_dbg(host->dev, "data %s at 0x%08x: blocks=%d blksz=%d tmout=%u (%d)\n",
@@ -613,6 +613,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
@@ -648,6 +648,8 @@ static void mvsd_set_ios(struct mmc_host *mmc, struct mmc_ios *ios)
u32 m = DIV_ROUND_UP(host->base_clock, ios->clock) - 1;
if (m > MVSD_BASE_DIV_MAX)
m = MVSD_BASE_DIV_MAX;
@ -34,5 +34,5 @@ index 629efbe639c4..c507c064736c 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.37.0
2.45.2

View file

@ -1,4 +1,4 @@
From 824cc151d839ce92269200119f9148013755adb8 Mon Sep 17 00:00:00 2001
From 39c2456e280c7020e29646689c2a0d67d2dc6a5c Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 4/7] net/smsc95xx: Allow mac address to be set as a parameter
@ -8,7 +8,7 @@ Subject: [PATCH 4/7] net/smsc95xx: Allow mac address to be set as a parameter
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index bfb58c91db04..29b7c4cb90f1 100644
index 8e82184be5e7..19a820031c04 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -54,6 +54,7 @@
@ -19,7 +19,7 @@ index bfb58c91db04..29b7c4cb90f1 100644
#define SMSC95XX_NR_IRQS (1) /* raise to 12 for GPIOs */
#define PHY_HWIRQ (SMSC95XX_NR_IRQS - 1)
@@ -78,6 +79,10 @@ static bool turbo_mode = true;
@@ -79,6 +80,10 @@ static bool turbo_mode = true;
module_param(turbo_mode, bool, 0644);
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
@ -30,7 +30,7 @@ index bfb58c91db04..29b7c4cb90f1 100644
static int __must_check smsc95xx_read_reg(struct usbnet *dev, u32 index,
u32 *data)
{
@@ -761,8 +766,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
@@ -801,8 +806,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
return phy_mii_ioctl(netdev->phydev, rq, cmd);
}
@ -91,5 +91,5 @@ index bfb58c91db04..29b7c4cb90f1 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.37.0
2.45.2

View file

@ -1,33 +1,33 @@
From 3a5136fec1bdb0f7a5ca614dab47c55c3177d26a Mon Sep 17 00:00:00 2001
From e2d137f94813e3d7d5f388991945834d09cbb271 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 5/7] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts | 2 ++
arch/arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts
index 52160e3..21c8ef9 100644
index 52160e368304..21c8ef94c756 100644
--- a/arch/arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts
+++ b/arch/arm/boot/dts/allwinner/sun7i-a20-cubietruck.dts
@@ -78,6 +78,7 @@
@@ -78,6 +78,7 @@ leds {
led-0 {
label = "cubietruck:blue:usr";
gpios = <&pio 7 21 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "heartbeat";
};
led-1 {
@@ -93,6 +94,7 @@
@@ -93,6 +94,7 @@ led-2 {
led-3 {
label = "cubietruck:green:usr";
gpios = <&pio 7 7 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "mmc0";
};
};
--
2.43.2
--
2.45.2

View file

@ -1,4 +1,4 @@
From c87c82c5a03baf1202d22567e4f6d113cfe17bad Mon Sep 17 00:00:00 2001
From ae4b381ebc808a42e1bc420fa45834f3c96ae9e7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 6/7] exynos4412-odroid: set higher minimum buck2 regulator
@ -13,11 +13,11 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/samsung/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/samsung/exynos4412-odroid-common.dtsi
index 93ddbd4..e636f13 100644
index 93ddbd4b0a18..e636f135bda9 100644
--- a/arch/arm/boot/dts/samsung/exynos4412-odroid-common.dtsi
+++ b/arch/arm/boot/dts/samsung/exynos4412-odroid-common.dtsi
@@ -439,7 +439,7 @@ buck1_reg: BUCK1 {
buck2_reg: BUCK2 {
regulator-name = "VDD_ARM";
- regulator-min-microvolt = <900000>;
@ -25,6 +25,6 @@ index 93ddbd4..e636f13 100644
regulator-max-microvolt = <1350000>;
regulator-always-on;
regulator-boot-on;
--
2.43.2
--
2.45.2

View file

@ -1,275 +1,42 @@
From 23e406e404f935be33c917ca7772466dd52582c3 Mon Sep 17 00:00:00 2001
From b1a17581a6efba8f4a94625955364185c3e867de Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 7/7] USB Armory MkII support
---
arch/arm/boot/dts/nxp/imx/Makefile | 4 +
.../boot/dts/nxp/imx/imx6ul-1G-usbarmory.dts | 225 ++++++++++++++++++
.../dts/nxp/imx/imx6ul-512M-usbarmory.dts | 225 ++++++++++++++++++
3 files changed, 454 insertions(+)
create mode 100644 arch/arm/boot/dts/nxp/imx/imx6ul-1G-usbarmory.dts
create mode 100644 arch/arm/boot/dts/nxp/imx/imx6ul-512M-usbarmory.dts
arch/arm/boot/dts/nxp/imx/Makefile | 2 +
.../arm/boot/dts/nxp/imx/imx6ul-usbarmory.dts | 256 +++++++++++++++++
.../boot/dts/nxp/imx/imx6ull-usbarmory.dts | 257 ++++++++++++++++++
3 files changed, 515 insertions(+)
create mode 100644 arch/arm/boot/dts/nxp/imx/imx6ul-usbarmory.dts
create mode 100644 arch/arm/boot/dts/nxp/imx/imx6ull-usbarmory.dts
diff --git a/arch/arm/boot/dts/nxp/imx/Makefile b/arch/arm/boot/dts/nxp/imx/Makefile
index a724d1a..641b67a 100644
index 4052cad859fa..2c6d17819c76 100644
--- a/arch/arm/boot/dts/nxp/imx/Makefile
+++ b/arch/arm/boot/dts/nxp/imx/Makefile
@@ -317,6 +317,8 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
@@ -323,6 +323,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ul-tx6ul-0010.dtb \
imx6ul-tx6ul-0011.dtb \
imx6ul-tx6ul-mainboard.dtb \
+ imx6ul-512M-usbarmory.dts \
+ imx6ul-1G-usbarmory.dts \
+ imx6ul-usbarmory.dtb \
imx6ull-14x14-evk.dtb \
imx6ull-colibri-aster.dtb \
imx6ull-colibri-emmc-aster.dtb \
@@ -349,6 +351,8 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
@@ -355,6 +356,7 @@ dtb-$(CONFIG_SOC_IMX6UL) += \
imx6ull-tarragon-slavext.dtb \
imx6ull-tqma6ull2-mba6ulx.dtb \
imx6ull-tqma6ull2l-mba6ulx.dtb \
+ imx6ul-512M-usbarmory.dts \
+ imx6ul-1G-usbarmory.dts \
+ imx6ull-usbarmory.dtb \
imx6ulz-14x14-evk.dtb \
imx6ulz-bsh-smm-m2.dtb
dtb-$(CONFIG_SOC_IMX7D) += \
diff --git a/arch/arm/boot/dts/nxp/imx/imx6ul-1G-usbarmory.dts b/arch/arm/boot/dts/nxp/imx/imx6ul-1G-usbarmory.dts
diff --git a/arch/arm/boot/dts/nxp/imx/imx6ul-usbarmory.dts b/arch/arm/boot/dts/nxp/imx/imx6ul-usbarmory.dts
new file mode 100644
index 0000000..e388725
index 000000000000..1fdcd6f611d5
--- /dev/null
+++ b/arch/arm/boot/dts/nxp/imx/imx6ul-1G-usbarmory.dts
@@ -0,0 +1,225 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
+ *
+ * Copyright (C) 2019, F-Secure Corporation
+ * Andrej Rosano <andrej.rosano@f-secure.com>
+ *
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
+
+#include "imx6ul.dtsi"
+
+/ {
+ model = "F-Secure USB armory Mk II";
+ compatible = "inversepath,imx6ul-usbarmory-mkII", "fsl,imx6ul";
+
+ chosen {
+ stdout-path = &uart2;
+ };
+
+ memory {
+ device_type = "memory";
+ reg = <0x80000000 0x40000000>;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_led>;
+
+ led-white {
+ label = "LED_WHITE";
+ gpios = <&gpio4 21 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "heartbeat";
+ };
+
+ led-blue {
+ label = "LED_BLUE";
+ gpios = <&gpio4 22 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ regulators {
+ compatible = "simple-bus";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ reg_sd1_vmmc: sd1_regulator {
+ compatible = "regulator-fixed";
+ regulator-name = "VSD_3V3";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ };
+ };
+};
+
+&uart1 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_bluetooth>;
+ uart-has-rtscts;
+ status = "okay";
+};
+
+&uart2 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_uart2>;
+ status = "okay";
+};
+
+&usdhc1 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_usdhc1>;
+ no-1-8-v;
+ keep-power-in-suspend;
+ wakeup-source;
+ status = "okay";
+};
+
+&usdhc2 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_usdhc2>;
+ non-removable;
+ status = "okay";
+};
+
+&i2c1 {
+ pinctrl-0 = <&pinctrl_i2c1>;
+ status = "okay";
+};
+
+&iomuxc {
+ pinctrl_uart2: uart2grp {
+ fsl,pins = <
+ MX6UL_PAD_UART2_TX_DATA__UART2_DCE_TX 0x1b0b1
+ MX6UL_PAD_UART2_RX_DATA__UART2_DCE_RX 0x1b0b1
+ >;
+ };
+
+ pinctrl_bluetooth: uart1grp {
+ fsl,pins = <
+ MX6UL_PAD_UART1_TX_DATA__UART1_DCE_TX 0x1b0b0 /* BT_UART_TX */
+ MX6UL_PAD_UART1_RX_DATA__UART1_DCE_RX 0x1b0b0 /* BT_UART_RX */
+ MX6UL_PAD_UART1_CTS_B__UART1_DCE_CTS 0x1b0b0 /* BT_UART_CTS */
+ MX6UL_PAD_GPIO1_IO07__UART1_DCE_RTS 0x130b0 /* BT_UART_RTS */
+ MX6UL_PAD_UART3_TX_DATA__GPIO1_IO24 0x1f020 /* BT_UART_DSR */
+ MX6UL_PAD_UART3_RX_DATA__GPIO1_IO25 0x10020 /* BT_UART_DTR */
+ MX6UL_PAD_GPIO1_IO04__GPIO1_IO04 0x1f020 /* BT_SWDCLK */
+ MX6UL_PAD_GPIO1_IO06__GPIO1_IO06 0x1f020 /* BT_SWDIO */
+ MX6UL_PAD_GPIO1_IO09__GPIO1_IO09 0x1f020 /* BT_RESET */
+ MX6UL_PAD_UART3_RTS_B__GPIO1_IO27 0x1f020 /* BT_SWITCH_1 */
+ MX6UL_PAD_UART3_CTS_B__GPIO1_IO26 0x1f020 /* BT_SWITCH_2 */
+ >;
+ };
+
+ pinctrl_i2c1: i2c1grp {
+ fsl,pins = <
+ MX6UL_PAD_GPIO1_IO02__I2C1_SCL 0x4001b8b0
+ MX6UL_PAD_GPIO1_IO03__I2C1_SDA 0x4001b8b0
+ >;
+ };
+
+ pinctrl_led: ledgrp {
+ fsl,pins = <
+ MX6UL_PAD_CSI_DATA00__GPIO4_IO21 0x1f020
+ MX6UL_PAD_CSI_DATA01__GPIO4_IO22 0x1f020
+ >;
+ };
+
+ pinctrl_usdhc1: usdhc1grp {
+ fsl,pins = <
+ MX6UL_PAD_SD1_CMD__USDHC1_CMD 0x1f019
+ MX6UL_PAD_SD1_CLK__USDHC1_CLK 0x1f019
+ MX6UL_PAD_SD1_DATA0__USDHC1_DATA0 0x1f019
+ MX6UL_PAD_SD1_DATA1__USDHC1_DATA1 0x1f019
+ MX6UL_PAD_SD1_DATA2__USDHC1_DATA2 0x1f019
+ MX6UL_PAD_SD1_DATA3__USDHC1_DATA3 0x1f019
+ >;
+ };
+
+ pinctrl_usdhc2: usdhc2grp {
+ fsl,pins = <
+ MX6UL_PAD_NAND_RE_B__USDHC2_CLK 0x10071
+ MX6UL_PAD_NAND_WE_B__USDHC2_CMD 0x17059
+ MX6UL_PAD_NAND_DATA00__USDHC2_DATA0 0x17059
+ MX6UL_PAD_NAND_DATA01__USDHC2_DATA1 0x17059
+ MX6UL_PAD_NAND_DATA02__USDHC2_DATA2 0x17059
+ MX6UL_PAD_NAND_DATA03__USDHC2_DATA3 0x17059
+ MX6UL_PAD_NAND_DATA04__USDHC2_DATA4 0x17059
+ MX6UL_PAD_NAND_DATA05__USDHC2_DATA5 0x17059
+ MX6UL_PAD_NAND_DATA06__USDHC2_DATA6 0x17059
+ MX6UL_PAD_NAND_DATA07__USDHC2_DATA7 0x17059
+ >;
+ };
+};
+
+/ {
+ soc {
+ caam_sm: caam-sm@00100000 {
+ compatible = "fsl,imx7d-caam-sm", "fsl,imx6q-caam-sm";
+ reg = <0x00100000 0x3fff>;
+ };
+
+ irq_sec_vio: caam_secvio {
+ compatible = "fsl,imx7d-caam-secvio", "fsl,imx6q-caam-secvio";
+ interrupts = <GIC_SPI 20 IRQ_TYPE_LEVEL_HIGH>;
+ };
+ };
+
+ caam_keyblob: caam-keyblob {
+ compatible = "fsl,sec-v4.0-keyblob";
+ status = "okay";
+ };
+};
+
+&usbotg1 {
+ dr_mode = "peripheral";
+ disable-over-current;
+ tpl-support;
+ status = "okay";
+};
+
+&usbotg2 {
+ dr_mode = "host";
+ disable-over-current;
+ tpl-support;
+ status = "okay";
+};
diff --git a/arch/arm/boot/dts/nxp/imx/imx6ul-512M-usbarmory.dts b/arch/arm/boot/dts/nxp/imx/imx6ul-512M-usbarmory.dts
new file mode 100644
index 0000000..bff5c6f
--- /dev/null
+++ b/arch/arm/boot/dts/nxp/imx/imx6ul-512M-usbarmory.dts
@@ -0,0 +1,225 @@
+++ b/arch/arm/boot/dts/nxp/imx/imx6ul-usbarmory.dts
@@ -0,0 +1,256 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
@ -415,7 +182,7 @@ index 0000000..bff5c6f
+ MX6UL_PAD_UART3_TX_DATA__GPIO1_IO24 0x1f020 /* BT_UART_DSR */
+ MX6UL_PAD_UART3_RX_DATA__GPIO1_IO25 0x10020 /* BT_UART_DTR */
+ MX6UL_PAD_GPIO1_IO04__GPIO1_IO04 0x1f020 /* BT_SWDCLK */
+ MX6UL_PAD_GPIO1_IO06__GPIO1_IO06 0x1f020 /* BT_SWDIO */
+ MX6UL_PAD_GPIO1_IO05__GPIO1_IO05 0x1f020 /* BT_SWDIO */
+ MX6UL_PAD_GPIO1_IO09__GPIO1_IO09 0x1f020 /* BT_RESET */
+ MX6UL_PAD_UART3_RTS_B__GPIO1_IO27 0x1f020 /* BT_SWITCH_1 */
+ MX6UL_PAD_UART3_CTS_B__GPIO1_IO26 0x1f020 /* BT_SWITCH_2 */
@ -431,8 +198,8 @@ index 0000000..bff5c6f
+
+ pinctrl_led: ledgrp {
+ fsl,pins = <
+ MX6UL_PAD_CSI_DATA00__GPIO4_IO21 0x1f020
+ MX6UL_PAD_CSI_DATA01__GPIO4_IO22 0x1f020
+ MX6UL_PAD_CSI_DATA06__GPIO4_IO27 0x1f020
+ MX6UL_PAD_CSI_DATA07__GPIO4_IO28 0x1f020
+ >;
+ };
+
@ -463,6 +230,37 @@ index 0000000..bff5c6f
+ };
+};
+
+&aips2 {
+ crypto: crypto@2140000 {
+ compatible = "fsl,imx6ul-caam", "fsl,sec-v4.0";
+ #address-cells = <1>;
+ #size-cells = <1>;
+ reg = <0x2140000 0x3c000>;
+ ranges = <0 0x2140000 0x3c000>;
+ interrupts = <GIC_SPI 48 IRQ_TYPE_LEVEL_HIGH>;
+ clocks = <&clks IMX6UL_CLK_CAAM_IPG>, <&clks IMX6UL_CLK_CAAM_ACLK>,
+ <&clks IMX6UL_CLK_CAAM_MEM>;
+ clock-names = "ipg", "aclk", "mem";
+
+ sec_jr0: jr@1000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x1000 0x1000>;
+ interrupts = <GIC_SPI 105 IRQ_TYPE_LEVEL_HIGH>;
+ };
+
+ sec_jr1: jr@2000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x2000 0x1000>;
+ interrupts = <GIC_SPI 106 IRQ_TYPE_LEVEL_HIGH>;
+ };
+ sec_jr2: jr@3000 {
+ compatible = "fsl,sec-v4.0-job-ring";
+ reg = <0x3000 0x1000>;
+ interrupts = <GIC_SPI 46 IRQ_TYPE_LEVEL_HIGH>;
+ };
+ };
+};
+
+/ {
+ soc {
+ caam_sm: caam-sm@00100000 {
@ -495,6 +293,269 @@ index 0000000..bff5c6f
+ tpl-support;
+ status = "okay";
+};
diff --git a/arch/arm/boot/dts/nxp/imx/imx6ull-usbarmory.dts b/arch/arm/boot/dts/nxp/imx/imx6ull-usbarmory.dts
new file mode 100644
index 000000000000..f74d0296d5f6
--- /dev/null
+++ b/arch/arm/boot/dts/nxp/imx/imx6ull-usbarmory.dts
@@ -0,0 +1,257 @@
+/*
+ * USB armory Mk II device tree file
+ * https://github.com/inversepath/usbarmory
+ *
+ * Copyright (C) 2019, F-Secure Corporation
+ * Andrej Rosano <andrej.rosano@f-secure.com>
+ *
+ * This file is dual-licensed: you can use it either under the terms
+ * of the GPL or the X11 license, at your option. Note that this dual
+ * licensing only applies to this file, and not this project as a
+ * whole.
+ *
+ * a) This file is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License as
+ * published by the Free Software Foundation; either version 2 of the
+ * License, or (at your option) any later version.
+ *
+ * This file is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * Or, alternatively,
+ *
+ * b) Permission is hereby granted, free of charge, to any person
+ * obtaining a copy of this software and associated documentation
+ * files (the "Software"), to deal in the Software without
+ * restriction, including without limitation the rights to use,
+ * copy, modify, merge, publish, distribute, sublicense, and/or
+ * sell copies of the Software, and to permit persons to whom the
+ * Software is furnished to do so, subject to the following
+ * conditions:
+ *
+ * The above copyright notice and this permission notice shall be
+ * included in all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+ * OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+ * NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+ * HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+ * WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+ * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+ * OTHER DEALINGS IN THE SOFTWARE.
+ */
+
+/dts-v1/;
+
+#include "imx6ul.dtsi"
+
+/ {
+ model = "F-Secure USB armory Mk II";
+ compatible = "inversepath,imx6ull-usbarmory-mkII", "fsl,imx6ull";
+
+ chosen {
+ stdout-path = &uart2;
+ };
+
+ memory {
+ device_type = "memory";
+ reg = <0x80000000 0x20000000>;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_led>;
+
+ led-white {
+ label = "LED_WHITE";
+ gpios = <&gpio4 21 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "heartbeat";
+ };
+
+ led-blue {
+ label = "LED_BLUE";
+ gpios = <&gpio4 22 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ regulators {
+ compatible = "simple-bus";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ reg_sd1_vmmc: sd1_regulator {
+ compatible = "regulator-fixed";
+ regulator-name = "VSD_3V3";
+ regulator-min-microvolt = <3300000>;
+ regulator-max-microvolt = <3300000>;
+ };
+ };
+};
+
+/* Delete CAAM node in AIPS-2 (i.MX6UL specific) */
+/delete-node/ &crypto;
+
+&cpu0 {
+ operating-points = <
+ /* kHz uV */
+ 900000 1275000
+ 792000 1225000
+ 528000 1175000
+ 396000 1025000
+ 198000 950000
+ >;
+ fsl,soc-operating-points = <
+ /* KHz uV */
+ 900000 1250000
+ 792000 1175000
+ 528000 1175000
+ 396000 1175000
+ 198000 1175000
+ >;
+};
+
+&uart1 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_bluetooth>;
+ uart-has-rtscts;
+ status = "okay";
+};
+
+&uart2 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_uart2>;
+ status = "okay";
+};
+
+&usdhc1 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_usdhc1>;
+ no-1-8-v;
+ keep-power-in-suspend;
+ wakeup-source;
+ status = "okay";
+};
+
+&usdhc2 {
+ pinctrl-names = "default";
+ pinctrl-0 = <&pinctrl_usdhc2>;
+ non-removable;
+ status = "okay";
+};
+
+&i2c1 {
+ pinctrl-0 = <&pinctrl_i2c1>;
+ status = "okay";
+};
+
+&iomuxc {
+ pinctrl_uart2: uart2grp {
+ fsl,pins = <
+ MX6UL_PAD_UART2_TX_DATA__UART2_DCE_TX 0x1b0b1
+ MX6UL_PAD_UART2_RX_DATA__UART2_DCE_RX 0x1b0b1
+ >;
+ };
+
+ pinctrl_bluetooth: uart1grp {
+ fsl,pins = <
+ MX6UL_PAD_UART1_TX_DATA__UART1_DCE_TX 0x1b0b0 /* BT_UART_TX */
+ MX6UL_PAD_UART1_RX_DATA__UART1_DCE_RX 0x1b0b0 /* BT_UART_RX */
+ MX6UL_PAD_UART1_CTS_B__UART1_DCE_CTS 0x1b0b0 /* BT_UART_CTS */
+ MX6UL_PAD_GPIO1_IO07__UART1_DCE_RTS 0x130b0 /* BT_UART_RTS */
+ MX6UL_PAD_UART3_TX_DATA__GPIO1_IO24 0x1f020 /* BT_UART_DSR */
+ MX6UL_PAD_UART3_RX_DATA__GPIO1_IO25 0x10020 /* BT_UART_DTR */
+ MX6UL_PAD_GPIO1_IO04__GPIO1_IO04 0x1f020 /* BT_SWDCLK */
+ MX6UL_PAD_GPIO1_IO05__GPIO1_IO05 0x1f020 /* BT_SWDIO */
+ MX6UL_PAD_GPIO1_IO09__GPIO1_IO09 0x1f020 /* BT_RESET */
+ MX6UL_PAD_UART3_RTS_B__GPIO1_IO27 0x1f020 /* BT_SWITCH_1 */
+ MX6UL_PAD_UART3_CTS_B__GPIO1_IO26 0x1f020 /* BT_SWITCH_2 */
+ >;
+ };
+
+ pinctrl_i2c1: i2c1grp {
+ fsl,pins = <
+ MX6UL_PAD_GPIO1_IO02__I2C1_SCL 0x4001b8b0
+ MX6UL_PAD_GPIO1_IO03__I2C1_SDA 0x4001b8b0
+ >;
+ };
+
+ pinctrl_led: ledgrp {
+ fsl,pins = <
+ MX6UL_PAD_CSI_DATA06__GPIO4_IO27 0x1f020
+ MX6UL_PAD_CSI_DATA07__GPIO4_IO28 0x1f020
+ >;
+ };
+
+ pinctrl_usdhc1: usdhc1grp {
+ fsl,pins = <
+ MX6UL_PAD_SD1_CMD__USDHC1_CMD 0x1f019
+ MX6UL_PAD_SD1_CLK__USDHC1_CLK 0x1f019
+ MX6UL_PAD_SD1_DATA0__USDHC1_DATA0 0x1f019
+ MX6UL_PAD_SD1_DATA1__USDHC1_DATA1 0x1f019
+ MX6UL_PAD_SD1_DATA2__USDHC1_DATA2 0x1f019
+ MX6UL_PAD_SD1_DATA3__USDHC1_DATA3 0x1f019
+ >;
+ };
+
+ pinctrl_usdhc2: usdhc2grp {
+ fsl,pins = <
+ MX6UL_PAD_NAND_RE_B__USDHC2_CLK 0x10071
+ MX6UL_PAD_NAND_WE_B__USDHC2_CMD 0x17059
+ MX6UL_PAD_NAND_DATA00__USDHC2_DATA0 0x17059
+ MX6UL_PAD_NAND_DATA01__USDHC2_DATA1 0x17059
+ MX6UL_PAD_NAND_DATA02__USDHC2_DATA2 0x17059
+ MX6UL_PAD_NAND_DATA03__USDHC2_DATA3 0x17059
+ MX6UL_PAD_NAND_DATA04__USDHC2_DATA4 0x17059
+ MX6UL_PAD_NAND_DATA05__USDHC2_DATA5 0x17059
+ MX6UL_PAD_NAND_DATA06__USDHC2_DATA6 0x17059
+ MX6UL_PAD_NAND_DATA07__USDHC2_DATA7 0x17059
+ >;
+ };
+};
+
+/ {
+ soc {
+ aips3: aips-bus@02200000 {
+ compatible = "fsl,aips-bus", "simple-bus";
+ #address-cells = <1>;
+ #size-cells = <1>;
+ reg = <0x02200000 0x100000>;
+ ranges;
+
+ dcp: dcp@02280000 {
+ compatible = "fsl,imx6ull-dcp", "fsl,imx6sl-dcp", "fsl,imx28-dcp";
+ reg = <0x02280000 0x4000>;
+ interrupts = <GIC_SPI 46 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_SPI 47 IRQ_TYPE_LEVEL_HIGH>,
+ <GIC_SPI 48 IRQ_TYPE_LEVEL_HIGH>;
+ clocks = <&clks IMX6ULL_CLK_DCP_CLK>;
+ clock-names = "dcp";
+ };
+
+ rngb: rngb@02284000 {
+ compatible = "fsl,imx6sl-rng", "fsl,imx25-rngb", "fsl,imx-rng", "imx-rng";
+ reg = <0x02284000 0x4000>;
+ interrupts = <GIC_SPI 6 IRQ_TYPE_LEVEL_HIGH>;
+ clocks = <&clks IMX6UL_CLK_DUMMY>;
+ };
+ };
+ };
+};
+
+&usbotg1 {
+ dr_mode = "peripheral";
+ disable-over-current;
+ tpl-support;
+ status = "okay";
+};
+
+&usbotg2 {
+ dr_mode = "host";
+ disable-over-current;
+ tpl-support;
+ status = "okay";
+};
--
2.43.2
2.45.2

View file

@ -8,7 +8,7 @@ _srcname=linux-6.9
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=6.9.12
pkgrel=1
pkgrel=2
rcnver=6.9.0
rcnrel=multiv7-r1
arch=('armv7h')
@ -34,13 +34,13 @@ source=("https://www.kernel.org/pub/linux/kernel/v6.x/${_srcname}.tar.xz"
md5sums=('b9828ed78dae306e3d90643cd5cdb8f1'
'f2d395bdb12bb02ffd3289b65db0e01a'
'39c5b016f75c2e8ca64222eb16ad6c6e'
'9e9d3b4cde2e27afd79f8818eb86a493'
'46fd4237094df0d32e19ef797511195f'
'bb32c18626916fba143461da3b6d3f7a'
'8f18d1db15ced906458992ea5aafa79e'
'68e6db7ebf429d65e1696ad83bdcb329'
'e03a69d7b41ce58991c7cbaf5cfdaee3'
'30c879166a58eb98e7ce6a652427a4b1'
'30fc57b96c9ac83f0a0abef8b4552ffa'
'5bf1ae1dec17213bb477c0578925391d'
'a8ad6d64dd9a8fd59529f6a751987d30'
'2d48051202f6123a1b0c442230d60120'
'8cd31506d15134f0165927f03bfc23f0'
'8cc8dce375aff1e9d9a9907fc40a4196'
'901842d79326725dee2381a8f0b375d9'
'c274675245cce72d30b5c935b5798534'
'2d6094def20fc719ea4c36624eb91c39'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -63,10 +63,7 @@ prepare() {
git apply ../0004-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0005-set-default-cubietruck-led-triggers.patch
git apply ../0006-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
# TODO: fix MkII stuff currently ends in errors:
# make[4]: *** No rule to make target '/scratch/d/pkg/linux-armv7/boot/dtbs/imx6ul-512M-usbarmory.dts', needed by '__dtbs_install'. Stop.
#git apply ../0007-USB-Armory-MkII-support.patch
git apply ../0007-USB-Armory-MkII-support.patch
cat "${srcdir}/config" > ./.config