aur/owfs to 3.1p0-1

This commit is contained in:
Kevin Mihelich 2015-05-03 14:46:48 +00:00
parent c9d011f22f
commit e74f31d535
2 changed files with 42 additions and 8 deletions

View file

@ -1,8 +1,8 @@
# Contributor: plut0nium <charles(DOT)fourneau(AT)gmail(DOT)com > # Contributor: plut0nium <charles(DOT)fourneau(AT)gmail(DOT)com >
# tzervo <tzervo@gmail.com> # tzervo <tzervo@gmail.com>
pkgname="owfs" pkgname="owfs"
pkgver=2.9p7 pkgver=3.1p0
pkgrel=0 pkgrel=1
pkgdesc="An easy way to use the powerful 1-wire system of Dallas/Maxim." pkgdesc="An easy way to use the powerful 1-wire system of Dallas/Maxim."
arch=('any') arch=('any')
url="http://www.owfs.org" url="http://www.owfs.org"
@ -19,14 +19,26 @@ replaces=()
backup=() backup=()
options=() options=()
install= install=
source=(http://downloads.sourceforge.net/sourceforge/owfs/$pkgname-$pkgver.tar.gz) source=("http://downloads.sourceforge.net/sourceforge/owfs/$pkgname-$pkgver.tar.gz" "fix-libusb-includes.patch")
noextract=() noextract=()
md5sums=('47808d820e6340af58ec05cfe8e220c6') md5sums=('3d8919af078ae8c9171e5713a1789195'
'f23d0571e00fb869c2e5e0602ed6f628')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 -i ../../fix-libusb-includes.patch
}
build() { build() {
cd "$srcdir/$pkgname-$pkgver" cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --with-python="/usr/bin/python2" --with-pythonconfig="/usr/bin/python2-config" autoreconf && \
./configure --disable-swig --disable-owperl --prefix=/usr --with-python="/usr/bin/python2" --with-pythonconfig="/usr/bin/python2-config"
make make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install make DESTDIR="$pkgdir" install
} }

View file

@ -0,0 +1,22 @@
diff -ruN owfs-orig/module/owshell/src/c/Makefile.am owfs/module/owshell/src/c/Makefile.am
--- owfs-orig/module/owshell/src/c/Makefile.am 2015-01-11 03:31:32.000000000 +0200
+++ owfs/module/owshell/src/c/Makefile.am 2015-03-23 18:47:03.211445494 +0200
@@ -41,6 +41,7 @@
-Wcast-align \
-Wstrict-prototypes \
-Wredundant-decls \
+ ${LIBUSB_CFLAGS} \
${EXTRACFLAGS}
LDADD = ${LD_EXTRALIBS} ${OSLIBS}
diff -ruN owfs-orig/module/owtcl/Makefile.am owfs/module/owtcl/Makefile.am
--- owfs-orig/module/owtcl/Makefile.am 2015-01-11 03:31:32.000000000 +0200
+++ owfs/module/owtcl/Makefile.am 2015-03-23 18:46:52.681151547 +0200
@@ -39,6 +39,7 @@
-Wcast-align \
-Wstrict-prototypes \
-Wredundant-decls \
+ ${LIBUSB_CFLAGS} \
${EXTRACFLAGS} \
${PTHREAD_CFLAGS} \
$(TCL_DEFS) \