mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
core/file to 5.40-6
This commit is contained in:
parent
9873c4735b
commit
e7602801b1
2 changed files with 62 additions and 1 deletions
|
@ -8,7 +8,7 @@
|
|||
|
||||
pkgname=file
|
||||
pkgver=5.40
|
||||
pkgrel=5
|
||||
pkgrel=6
|
||||
pkgdesc='File type identification utility'
|
||||
arch=('x86_64')
|
||||
license=('custom')
|
||||
|
@ -18,12 +18,14 @@ depends=('glibc' 'zlib' 'xz' 'bzip2')
|
|||
provides=('libmagic.so')
|
||||
source=("https://astron.com/pub/$pkgname/$pkgname-$pkgver.tar.gz"{,.asc}
|
||||
"pr256.patch" # fix binary detection that breaks subversion tests
|
||||
"pr259.patch" # mime printing through indirect magic is not taken into account, use match directly so that it does
|
||||
"pr261.patch" # follow-up patch which restores file 5.39 behavior
|
||||
"https://github.com/file/file/commit/9b0459afab309a82aa4e46f73a4e50dd641f3d39.patch")
|
||||
validpgpkeys=('BE04995BA8F90ED0C0C176C471112AB16CB33B3A') # Christos Zoulas
|
||||
sha256sums=('167321f43c148a553f68a0ea7f579821ef3b11c27b8cbe158e4df897e4a5dd57'
|
||||
'SKIP'
|
||||
'5fd8dc41a10ee8097ddbffad37e07ea417b6ea5ff9d416d4aadfe15bc33a46df'
|
||||
'e811744d8e02883e7ddea67497a113db6a9a176dd6c3696d43498ad15440aa6c'
|
||||
'c149311a54ee2539344d6ace2cb733e45bc1c134cd91d50d462dd9edbff916f5'
|
||||
'f5d9c964233b75d6b5ac1b95fe4cc23143fbc6070d3b136e91b542021959e7dd')
|
||||
|
||||
|
|
59
core/file/pr259.patch
Normal file
59
core/file/pr259.patch
Normal file
|
@ -0,0 +1,59 @@
|
|||
From 07595622bd09e5b09720ccd717d2d862703a95fe Mon Sep 17 00:00:00 2001
|
||||
From: Christos Zoulas <christos@zoulas.com>
|
||||
Date: Mon, 19 Apr 2021 16:47:13 +0000
|
||||
Subject: PR/259: aleksandr.v.novichkov: mime printing through indirect magic
|
||||
is not taken into account, use match directly so that it does.
|
||||
|
||||
---
|
||||
src/softmagic.c | 15 +++++++++++----
|
||||
1 file changed, 11 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/src/softmagic.c b/src/softmagic.c
|
||||
index 1ec3e604..2eb5b630 100644
|
||||
--- a/src/softmagic.c
|
||||
+++ b/src/softmagic.c
|
||||
@@ -1559,7 +1559,7 @@ mget(struct magic_set *ms, struct magic *m, const struct buffer *b,
|
||||
int rv, oneed_separator, in_type, nfound_match;
|
||||
char *rbuf;
|
||||
union VALUETYPE *p = &ms->ms_value;
|
||||
- struct mlist ml;
|
||||
+ struct mlist ml, *mlp;
|
||||
struct cont c;
|
||||
|
||||
if (*indir_count >= ms->indir_max) {
|
||||
@@ -1829,8 +1829,15 @@ mget(struct magic_set *ms, struct magic *m, const struct buffer *b,
|
||||
bb = *b;
|
||||
bb.fbuf = s + offset;
|
||||
bb.flen = nbytes - offset;
|
||||
- rv = file_softmagic(ms, &bb,
|
||||
- indir_count, name_count, BINTEST, text);
|
||||
+ for (mlp = ms->mlist[0]->next; mlp != ms->mlist[0];
|
||||
+ mlp = mlp->next)
|
||||
+ {
|
||||
+ if ((rv = match(ms, mlp->magic, mlp->nmagic, &bb, 0,
|
||||
+ BINTEST, text, 0, indir_count, name_count,
|
||||
+ printed_something, need_separator, NULL,
|
||||
+ NULL)) != 0)
|
||||
+ break;
|
||||
+ }
|
||||
|
||||
if ((ms->flags & MAGIC_DEBUG) != 0)
|
||||
fprintf(stderr, "indirect @offs=%u[%d]\n", offset, rv);
|
||||
From aba3766ef6fddc67e12514293be3f1f4180ee5ab Mon Sep 17 00:00:00 2001
|
||||
From: Christos Zoulas <christos@zoulas.com>
|
||||
Date: Mon, 19 Apr 2021 20:35:30 +0000
|
||||
Subject: fix tests
|
||||
|
||||
---
|
||||
tests/JW07022A.mp3.result | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/tests/JW07022A.mp3.result b/tests/JW07022A.mp3.result
|
||||
index 8a3e1195..f5911910 100644
|
||||
--- a/tests/JW07022A.mp3.result
|
||||
+++ b/tests/JW07022A.mp3.result
|
||||
@@ -1 +1 @@
|
||||
-Audio file with ID3 version 2.2.0, contains:MPEG ADTS, layer III, v1, 96 kbps, 44.1 kHz, Monaural
|
||||
\ No newline at end of file
|
||||
+Audio file with ID3 version 2.2.0, contains: MPEG ADTS, layer III, v1, 96 kbps, 44.1 kHz, Monaural
|
||||
\ No newline at end of file
|
Loading…
Reference in a new issue