updated extra/boost

This commit is contained in:
Kevin Mihelich 2011-03-09 01:42:42 -05:00
parent 637a8a9e9b
commit e76e588182
3 changed files with 106 additions and 18 deletions

View file

@ -0,0 +1,16 @@
Index: libs/python/src/converter/builtin_converters.cpp
===================================================================
--- libs/python/src/converter/builtin_converters.cpp (revision 67279)
+++ libs/python/src/converter/builtin_converters.cpp (working copy)
@@ -431,7 +431,11 @@
if (!result.empty())
{
int err = PyUnicode_AsWideChar(
+#if PY_VERSION_HEX >= 0x03020000
+ intermediate
+#else
(PyUnicodeObject *)intermediate
+#endif
, &result[0]
, result.size());

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 100298 2010-11-22 15:31:39Z ibiru $
# $Id: PKGBUILD 112033 2011-03-03 10:41:09Z ibiru $
# Maintainer: kevin <kevin@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# TU: Kritoke <kritoke@gamebox.net>
@ -11,16 +11,19 @@ plugrel=1
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.45.0
pkgver=1.46.0
_boostver=${pkgver//./_}
pkgrel=1
pkgrel=3
arch=('i686' 'x86_64')
url="http://www.boost.org/"
makedepends=('python2' 'bzip2' 'zlib')
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib' 'openmpi')
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
4994-compile-fix-for-Python32-v2.patch
boost-1.46.0-spirit.patch)
license=('custom')
options=('!ccache')
md5sums=('739792c98fafb95e7a6b5da23a30062c')
md5sums=('820393d5746553c192db7b81ba0e53fe'
'cb59e8adbf2a45ef9264a2f4ab92b849'
'9d6e2f13fef23bf27d7bdddc104e182a')
_stagedir="${srcdir}/stagedir"
@ -28,6 +31,8 @@ build() {
# set python path for bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools"
echo "using python : 2.7 : /usr/bin/python2 ;" >> build/v2/user-config.jam
echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
echo "using mpi ;" >> build/v2/user-config.jam
# build bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine/src"
@ -36,8 +41,8 @@ build() {
_bindir="bin.linuxarm"
[ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
install -m755 -d "${_stagedir}"/usr/bin
install -m755 ${_bindir}/bjam "${_stagedir}"/usr/bin/bjam
install -d "${_stagedir}"/usr/bin
install ${_bindir}/bjam "${_stagedir}"/usr/bin/bjam
# build bcp
cd "${srcdir}/${pkgbase}_${_boostver}/tools/bcp"
@ -47,35 +52,42 @@ build() {
# build libs
cd "${srcdir}/${pkgbase}_${_boostver}"
#python 3.2 support
#https://svn.boost.org/trac/boost/ticket/4994
patch -Np0 -i "${srcdir}/4994-compile-fix-for-Python32-v2.patch"
patch -Np0 -i "${srcdir}/boost-1.46.0-spirit.patch"
# default "minimal" install: "release link=shared,static
# runtime-link=shared threading=multi"
# runtime-link=shared threading=single,multi"
# --layout=tagged will add the "-mt" suffix for multithreaded libraries
# and installs includes in /usr/include/boost.
# --layout=system no longer adds the -mt suffix for multi-threaded libs.
# install to ${_stagedir} in preparation for split packaging
./tools/build/v2/engine/src/${_bindir}/bjam \
release debug-symbols=off threading=single,multi \
release debug-symbols=off threading=multi \
runtime-link=shared link=shared,static \
cflags=-fno-strict-aliasing \
toolset=gcc \
--prefix="${_stagedir}" \
-sTOOLS=gcc \
--layout=tagged \
--layout=system \
${MAKEFLAGS} \
install
# pyste is unmaintained: http://www.boost.org/doc/libs/1_46_0/libs/python/doc/index.html
# build pyste
cd "${srcdir}/${pkgbase}_${_boostver}/libs/python/pyste/install"
python2 setup.py install --root=${_stagedir}
#cd "${srcdir}/${pkgbase}_${_boostver}/libs/python/pyste/install"
#python2 setup.py install --root=${_stagedir} --optimize=1
}
package_boost() {
pkgdesc="Free peer-reviewed portable C++ source libraries - Development"
depends=("boost-libs=${pkgver}")
optdepends=('python2: for python bindings')
optdepends=('python: for python bindings'
'python2: for python2 bindings')
install -dm 755 "${pkgdir}"/usr/{include,lib}
install -d "${pkgdir}"/usr/{include,lib}
# headers/source files
cp -r "${_stagedir}"/include/ "${pkgdir}"/usr/
@ -92,9 +104,10 @@ package_boost() {
package_boost-libs() {
pkgdesc="Free peer-reviewed portable C++ source libraries - Runtime"
depends=('gcc-libs' 'bzip2' 'zlib')
depends=('gcc-libs' 'bzip2' 'zlib' 'icu')
optdepends=('openmpi: for mpi support')
install -dm 755 "${pkgdir}/usr/lib"
install -d "${pkgdir}/usr/lib"
#shared libs
cp -r "${_stagedir}"/lib/*.so{,.*} "${pkgdir}/usr/lib/"

View file

@ -0,0 +1,59 @@
Index: boost/spirit/home/qi/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/qi/parser.hpp>
namespace boost { namespace spirit { namespace qi
@@ -59,4 +60,16 @@ namespace boost { namespace spirit { nam
};
}}}
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<qi::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif
Index: boost/spirit/home/karma/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/karma/generator.hpp>
namespace boost { namespace spirit { namespace karma
@@ -60,4 +61,17 @@ namespace boost { namespace spirit { nam
};
}}}
+
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<karma::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif