extra/texlive-bin to 2011.3-7

This commit is contained in:
Kevin Mihelich 2012-05-28 16:30:12 -04:00
parent c526ccc812
commit e792a79fa3
2 changed files with 81 additions and 1 deletions

View file

@ -12,7 +12,7 @@ plugrel=1
pkgname=texlive-bin
pkgver=2011.3
_luatex_ver=0.70.1
pkgrel=6
pkgrel=7
pkgdesc="TeX Live binaries"
license=('GPL')
arch=('i686' 'x86_64')
@ -27,6 +27,7 @@ install="texlive.install"
source=('texmf.cnf'
'fix-fontforge-encoding.patch'
'09-texlive-fonts.conf'
'luatex-poppler-0.20.patch'
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-source-20111210.tar.xz'
'http://mirrors.kernel.org/archlinux/other/texlive/texlive-bin-texmf-20111210.tar.xz'
# "http://foundry.supelec.fr/gf/download/frsrelease/392/1730/luatex-beta-${_luatex_ver}.tar.bz2"
@ -49,6 +50,7 @@ backup=(etc/texmf/web2c/texmf.cnf \
md5sums=('220a4f4cc0d915bf8fcbcb553dcee1ae'
'bfb9716aa00c86c08cd31e5b32edeb98'
'393a4bf67adc7ca5df2b386759d1a637'
'52ce57c02e30a25036b6a3175c566b78'
'c7bb38c0ab30c2b64cf4cf83a736b35c'
'5d8f06a3683ce88a3c33e15f5ba6a858'
'e7f0197559ef865d8c01683dab3b8526')
@ -64,6 +66,7 @@ build() {
# cd luatex-beta-${_luatex_ver}
cd luatex
patch -p0 -i ../fix-fontforge-encoding.patch
patch -Np0 -i ../luatex-poppler-0.20.patch
(cd source && ./texk/web2c/luatexdir/getluatexsvnversion.sh)
mkdir build
cd build

View file

@ -0,0 +1,77 @@
--- source/texk/web2c/luatexdir/lua/lepdflib.cc.orig 2011-10-06 06:14:20.000000000 +0000
+++ source/texk/web2c/luatexdir/lua/lepdflib.cc 2012-05-17 11:30:26.327236883 +0000
@@ -157,7 +157,7 @@
pdfdoc_changed_error(L);
uout = new_Annot_userdata(L);
uout->d =
- new Annot((XRef *) uxref->d, (Dict *) udict->d, (Catalog *) ucatalog->d,
+ new Annot((PDFDoc *) uxref->pd, (Dict *) udict->d,
(Object *) uref->d);
uout->atype = ALLOC_LEPDF;
uout->pc = uxref->pc;
@@ -179,7 +179,7 @@
pdfdoc_changed_error(L);
uout = new_Annots_userdata(L);
uout->d =
- new Annots((XRef *) uxref->d, (Catalog *) ucatalog->d,
+ new Annots((PDFDoc *) uxref->pd,
(Object *) uannotsobj->d);
uout->atype = ALLOC_LEPDF;
uout->pc = uxref->pc;
@@ -369,7 +369,7 @@
// Annot
m_poppler_get_BOOL(Annot, isOk);
-m_poppler_get_OBJECT(Annot, getAppearance);
+m_poppler_get_OBJECT(Annot, getAppearanceResDict);
m_poppler_get_poppler(Annot, AnnotBorder, getBorder);
static int m_Annot_match(lua_State * L)
@@ -408,7 +408,7 @@
static const struct luaL_Reg Annot_m[] = {
{"isOk", m_Annot_isOk},
- {"getAppearance", m_Annot_getAppearance},
+ {"getAppearance", m_Annot_getAppearanceResDict},
{"getBorder", m_Annot_getBorder},
{"match", m_Annot_match},
{"__tostring", m_Annot__tostring},
@@ -1433,7 +1433,7 @@
static int m_Object_getTypeName(lua_State * L)
{
- char *s;
+ const char *s;
udstruct *uin;
uin = (udstruct *) luaL_checkudata(L, 1, M_Object);
if (uin->pd != NULL && uin->pd->pc != uin->pc)
@@ -2120,7 +2120,7 @@
if ((uin->pd != NULL && uin->pd->pc != uin->pc)
|| (ucat->pd != NULL && ucat->pd->pc != ucat->pd->pc))
pdfdoc_changed_error(L);
- links = ((Page *) uin->d)->getLinks((Catalog *) ucat->d);
+ links = ((Page *) uin->d)->getLinks();
if (links != NULL) {
uout = new_Links_userdata(L);
uout->d = links;
@@ -2738,7 +2738,10 @@
return 1;
}
-m_poppler_get_INT(XRef, getSize);
+static int m_XRef_getSize(lua_State * L)
+{
+ return m_XRef_getNumObjects(L);
+}
static int m_XRef_getEntry(lua_State * L)
{
@@ -2748,7 +2751,7 @@
if (uin->pd != NULL && uin->pd->pc != uin->pc)
pdfdoc_changed_error(L);
i = luaL_checkint(L, 2);
- size = ((XRef *) uin->d)->getSize();
+ size = ((XRef *) uin->d)->getNumObjects();
if (i > 0 && i <= size) {
uout = new_XRefEntry_userdata(L);
uout->d = ((XRef *) uin->d)->getEntry(i);