added community/kbibtex

This commit is contained in:
Kevin Mihelich 2015-08-18 23:40:04 +00:00
parent 74b94df224
commit e7b22fbc10
3 changed files with 85 additions and 0 deletions

View file

@ -0,0 +1,25 @@
From 1c95e056224ab6399b84d69fb90572b37a8a53a5 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 18 Aug 2015 17:37:44 -0600
Subject: [PATCH] remove qreal cast for arm
---
src/gui/widgets/starrating.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/gui/widgets/starrating.cpp b/src/gui/widgets/starrating.cpp
index 664f12f..d3dbb4c 100644
--- a/src/gui/widgets/starrating.cpp
+++ b/src/gui/widgets/starrating.cpp
@@ -250,7 +250,7 @@ double StarRating::percentForPosition(const QPoint &pos, int numTotalStars, cons
const int width = starSize * numTotalStars;
const int x = pos.x() - Private::paintMargin - inside.left();
const double percent = x * 100.0 / width;
- return qMax(qreal(0.0), qMin(qreal(100.0), percent));
+ return qMax(0.0, qMin(100.0, percent));
}
bool StarRatingFieldInput::reset(const Value &value)
--
2.5.0

View file

@ -0,0 +1,45 @@
# $Id$
# Maintainer: Ray Rashif <schiv@archlinux.org>
# Contributor: Antonio Rojas <nqn1976 @ gmail.com>
# Contributor: cmorlok <christianmorlok@web.de>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to remove qreal usage on v5/6/7
pkgname=kbibtex
pkgver=0.6
_branch=0.6
pkgrel=1
pkgdesc="A BibTeX editor for KDE"
arch=('i686' 'x86_64')
url='http://home.gna.org/kbibtex/'
license=('GPL')
depends=('kdebase-runtime' 'poppler-qt4')
optdepends=('kdegraphics-okular: Document preview')
makedepends=('cmake' 'automoc4')
install=$pkgname.install
source=("http://download.gna.org/$pkgname/$_branch/$pkgname-$pkgver.tar.xz"
'0001-remove-qreal-cast-for-arm.patch')
md5sums=('f1a9c1867d94c36fe88cfa0470b85dac'
'fae1a894b4dbc9339b0ad70a3a3b185c')
prepare() {
cd "$pkgname-$pkgver"
[[ $CARCH != "aarch64" ]] && patch -p1 -i ../0001-remove-qreal-cast-for-arm.patch
}
build() {
cd "$pkgname-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:

View file

@ -0,0 +1,15 @@
post_install() {
xdg-icon-resource forceupdate --theme hicolor &> /dev/null
update-mime-database usr/share/mime &> /dev/null
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}
# vim:set ts=2 sw=2 et: