mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/valgrind fixes
This commit is contained in:
parent
2ec19b5fe6
commit
e7ca0f7869
2 changed files with 1 additions and 29 deletions
|
@ -18,7 +18,7 @@ options=('!emptydirs')
|
||||||
source=(http://valgrind.org/downloads/${pkgname}-${pkgver}.tar.bz2
|
source=(http://valgrind.org/downloads/${pkgname}-${pkgver}.tar.bz2
|
||||||
alarm.patch)
|
alarm.patch)
|
||||||
md5sums=('ec04dfd1256307432b2a7b520398c526'
|
md5sums=('ec04dfd1256307432b2a7b520398c526'
|
||||||
'09895dece4b831ceb80285c2175ae937')
|
'aba5261d8ef25ab9bbad44631172da02')
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd ${srcdir}/${pkgname}-${pkgver}
|
cd ${srcdir}/${pkgname}-${pkgver}
|
||||||
|
|
|
@ -9,31 +9,3 @@
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ok (${host_cpu})" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ok (${host_cpu})" >&5
|
||||||
$as_echo "ok (${host_cpu})" >&6; }
|
$as_echo "ok (${host_cpu})" >&6; }
|
||||||
ARCH_MAX="arm"
|
ARCH_MAX="arm"
|
||||||
Description: Make valgrind believe it's cross compiled so that it builds on armel
|
|
||||||
Origin: vendor
|
|
||||||
Author: Pierre Habouzit <madcoder@debian.org>
|
|
||||||
Reviewed-by: Alessandro Ghedini <ghedo@debian.org>
|
|
||||||
Last-Update: 2012-05-10
|
|
||||||
|
|
||||||
--- valgrind.orig/configure
|
|
||||||
+++ valgrind/configure
|
|
||||||
@@ -5133,7 +5133,7 @@
|
|
||||||
| head -n 1 \
|
|
||||||
| $SED 's/i686-apple-darwin10//' \
|
|
||||||
| $SED 's/i686-apple-darwin11//' \
|
|
||||||
- | $SED 's/^[^0-9]*\([0-9.]*\).*$/\1/'`
|
|
||||||
+ | $SED 's/^[^ ]* [^0-9]*\([0-9.]*\).*$/\1/'`
|
|
||||||
|
|
||||||
is_clang="notclang"
|
|
||||||
if test "x`${CC} --version | head -n 1 | $SED 's/\(clang\) version.*/\1/'`" = "xclang" ; then
|
|
||||||
--- valgrind.orig/configure.in
|
|
||||||
+++ valgrind/configure.in
|
|
||||||
@@ -109,7 +109,7 @@
|
|
||||||
| head -n 1 \
|
|
||||||
| $SED 's/i686-apple-darwin10//' \
|
|
||||||
| $SED 's/i686-apple-darwin11//' \
|
|
||||||
- | $SED 's/^[^0-9]*\([0-9.]*\).*$/\1/'`]
|
|
||||||
+ | $SED 's/^[^ ]* [^0-9]*\([0-9.]*\).*$/\1/'`]
|
|
||||||
|
|
||||||
is_clang="notclang"
|
|
||||||
if test "x`${CC} --version | head -n 1 | $SED 's/\(clang\) version.*/\1/'`" = "xclang" ; then
|
|
||||||
|
|
Loading…
Reference in a new issue