diff --git a/community/openimageio/PKGBUILD b/community/openimageio/PKGBUILD
index e58632472..757911b1c 100644
--- a/community/openimageio/PKGBUILD
+++ b/community/openimageio/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 90071 2013-05-06 19:38:49Z foutrelis $
+# $Id$
 # Contributor: SpepS <dreamspepser at yahoo dot it>
 # Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
 
@@ -6,32 +6,18 @@
 #  - removed intel-tbb from deps, set -DUSE_TBB=0
 
 pkgname=openimageio
-pkgver=1.4.16
-pkgrel=7
+pkgver=1.6.8
+pkgrel=3
 pkgdesc="A library for reading and writing images, including classes, utilities, and applications"
 arch=(i686 x86_64)
 url="http://www.openimageio.org/"
 license=('custom')
-depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio')
+depends=('openexr' 'boost-libs' 'jasper' 'glew' 'libtiff' 'opencolorio' 'openssl')
 makedepends=('cmake' 'qt4' 'python2' 'boost' 'mesa' 'git')
 optdepends=('qt4: iv image viewer'
             'python2: bindings support')
-source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver}
-        ustring-cxx11-std-string.patch
-        fix-compiler-warning.patch
-        stdmath.patch)
-md5sums=('SKIP'
-         'ec2e922a5297331901fd9331fcfb6bdb'
-         'f41243f93ad9370060efdad931750289'
-         '7b819bf20cf2c13cbde5fc6511e39f35')
-
-prepare() {
-  cd oiio
-
-  patch -Np1 < "$srcdir/ustring-cxx11-std-string.patch"
-  patch -Np1 < "$srcdir/fix-compiler-warning.patch"
-  patch -Np1 < "$srcdir/stdmath.patch"
-}
+source=(git+git://github.com/OpenImageIO/oiio.git#tag=Release-${pkgver})
+md5sums=('SKIP')
 
 build() {
   cd oiio
@@ -39,13 +25,16 @@ build() {
   [[ -d build ]] && rm -r build
   mkdir build && cd build
 
-  cmake \
+  # Python is currently broken :(
+  cmake .. \
+      -DUSE_PYTHON=OFF \
+      -DUSE_PYTHON3=OFF \
+      -DUSE_OPENSSL=ON \
       -DCMAKE_INSTALL_PREFIX=/usr \
       -DPYLIB_INSTALL_DIR=lib/python2.7/site-packages \
-      -DUSE_EXTERNAL_TBB=ON \
-      -DOIIO_BUILD_TESTS=OFF \
-      -DUSE_TBB=0 \
-      ..
+      -DOIIO_BUILD_TESTS=ON \
+      -DOIIO_BUILD_TOOLS=ON \
+      -DUSE_TBB=0
   make
 }