extra/texlive-bin to 2023.66539-1

This commit is contained in:
Kevin Mihelich 2023-03-29 12:39:01 +00:00
parent 29442272d5
commit e7efc0133c
2 changed files with 35 additions and 13 deletions

View file

@ -8,8 +8,8 @@
# drop clisp and ffcall makedepends
pkgname=('texlive-bin' 'libsynctex')
pkgver=2022.62885
pkgrel=5
pkgver=2023.66539
pkgrel=1
license=('GPL')
arch=('x86_64')
makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd'
@ -17,9 +17,11 @@ makedepends=('git' 'cairo' 'pixman' 'graphite' 't1lib' 'gd'
'icu' 'harfbuzz' 'harfbuzz-icu' 'gmp' 'mpfr' 'potrace' 'libpaper'
'perl' 'libxcrypt')
url='https://tug.org/texlive/'
_commit=f398692b64d6462c35939ec9489694d0828edee5 # svn://tug.org/texlive/tags/texlive-2022.0/Build/source@62885
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}")
sha256sums=('SKIP')
_commit=0d0bb3a2401e8825b4987eee51e8ef469eb8c3fc # tags/texlive-2023.0
source=("git+https://github.com/Tex-Live/texlive-source.git#commit=${_commit}"
"ptex-debug-print.patch")
sha256sums=('SKIP'
'aa838f09003c62c2efb5770a8de66f99b409df049fbd65098d80fd1957d06c50')
prepare() {
cd "$srcdir/texlive-source"
@ -29,6 +31,8 @@ prepare() {
(cd texk/bibtex-x && autoreconf)
# t4ht expects to be un /usr/share/texmf/bin/t4ht (FS#27251)
sed -i s/SELFAUTOPARENT/TEXMFROOT/ texk/tex4htk/t4ht.c
# remove spurious ptex "guessed encoding" print
patch -Np1 -i "${srcdir}/ptex-debug-print.patch"
}
build() {
@ -163,12 +167,13 @@ package_texlive-bin() {
_bibtexextra_scripts="
bbl2bib
bib2gls
bibcop
bibdoiadd
bibexport
bibmradd
biburl2doi
bibzbladd
citeproc
citeproc-lua
convertgls2bib
listbib
ltx2crossrefxml
@ -196,8 +201,6 @@ cjk-gs-integrate
cluttex
cllualatex
clxelatex
context
contextjit
ctanbib
ctanify
ctanupload
@ -205,6 +208,7 @@ ctan-o-mat
de-macro
depythontex
deweb
digestif
dosepsbin
dtxgen
dvi2fax
@ -253,7 +257,6 @@ ltxfileinfo
ltximg
luafindfont
luaotfload-tool
luatools
lwarpmk
make4ht
match_parens
@ -267,8 +270,6 @@ mktexmf
mktexpk
mktextfm
mptopdf
mtxrun
mtxrunjit
optexcount
ot2kpx
pamphletangler
@ -295,6 +296,7 @@ spix
srcredact
sty2dtx
tex4ebook
texaccents
texconfig
texconfig-dialog
texconfig-sys
@ -304,7 +306,6 @@ texdiff
texdirflatten
texdoc
texdoctk
texexec
texfot
texhash
texlinks
@ -312,7 +313,6 @@ texliveonfly
texloganalyser
texlogfilter
texlogsieve
texmfstart
texosquery
texosquery-jre5
texosquery-jre8
@ -351,11 +351,13 @@ l3build
makedtx
makeglossaries
makeglossaries-lite
pagelayoutapi
pdfannotextractor
perltex
ps4pdf
splitindex
svn-multi
textestvis
vpe
webquiz
wordcount
@ -401,6 +403,12 @@ tikztosvg"
done
###################################################################
# Install old ConTeXt stubs
cd "$srcdir/texlive-source"
for stub in context contextjit luatools mtxrun mtxrunjit texexec texmfstart; do
install -m755 texk/texlive/linked_scripts/context/stubs/unix/"$stub" "$pkgdir/usr/bin/$stub"
done
# remove libsynctex
rm -f "$pkgdir"/usr/include/synctex/*
rm -f "$pkgdir"/usr/lib/libsynctex.*

View file

@ -0,0 +1,14 @@
diff --git a/texk/ptexenc/ptexenc.c b/texk/ptexenc/ptexenc.c
index 4e81dbee7c..3c98d68125 100644
--- a/texk/ptexenc/ptexenc.c
+++ b/texk/ptexenc/ptexenc.c
@@ -1044,7 +1044,9 @@ long input_line2(FILE *fp, unsigned char *buff, unsigned char *buff2,
enc = ptenc_guess_enc(fp);
if (string_to_enc(enc) > 0) {
infile_enc[fd] = string_to_enc(enc);
+#ifdef DEBUG
fprintf(stderr, "(guessed encoding #%d: %s = %s)", fd, enc, enc_to_string(infile_enc[fd]));
+#endif /* DEBUG */
} else {
infile_enc[fd] = get_file_enc();
}