mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-armv5-rc to 4.7.rc2-1
This commit is contained in:
parent
8b335012c9
commit
e872414647
5 changed files with 22 additions and 20 deletions
|
@ -1,4 +1,4 @@
|
|||
From 30d23c01c3ea43b237a07b5d404662f65598e3c8 Mon Sep 17 00:00:00 2001
|
||||
From 49e3d1debcd45f07c67e369d12e980bbec391fe2 Mon Sep 17 00:00:00 2001
|
||||
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
|
||||
Date: Mon, 12 Aug 2013 10:36:25 -0500
|
||||
Subject: [PATCH 1/3] at91: ariag25 updates
|
||||
|
@ -89,5 +89,5 @@ index e9ced30..8308515 100644
|
|||
|
||||
usb0: ohci@00600000 {
|
||||
--
|
||||
2.8.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From 515ca42e8a6eb3c12a73875ae221e56b226c0cdc Mon Sep 17 00:00:00 2001
|
||||
From 7b311f2091f758961f40af07d234609e1d23e08f Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Jun 2015 13:46:30 -0600
|
||||
Subject: [PATCH 2/3] at91: arietta-g25 support
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
create mode 100644 arch/arm/boot/dts/at91-arietta256.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index 95c1923..96010d9 100644
|
||||
index 06b6c2d..29d0fdc 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -33,6 +33,8 @@ dtb-$(CONFIG_SOC_SAM_V4_V5) += \
|
||||
|
@ -376,5 +376,5 @@ index 0000000..cbae789
|
|||
+
|
||||
+};
|
||||
--
|
||||
2.8.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
From db8ae51c160d4af4420eb29489d3ede9c9395607 Mon Sep 17 00:00:00 2001
|
||||
From 4e6140b0ca84e5c149d40ba6ed8d249d2b59d6f3 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
@ -8,7 +8,7 @@ Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
|
|||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index 2edc2bc..2445b56 100644
|
||||
index dc989a8..912be75 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -60,6 +60,7 @@
|
||||
|
@ -17,9 +17,9 @@ index 2edc2bc..2445b56 100644
|
|||
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
|
||||
+#define MAC_ADDR_LEN (6)
|
||||
|
||||
struct smsc95xx_priv {
|
||||
u32 mac_cr;
|
||||
@@ -75,6 +76,10 @@ static bool turbo_mode = true;
|
||||
#define CARRIER_CHECK_DELAY (2 * HZ)
|
||||
|
||||
@@ -80,6 +81,10 @@ static bool turbo_mode = true;
|
||||
module_param(turbo_mode, bool, 0644);
|
||||
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
||||
|
||||
|
@ -30,7 +30,7 @@ index 2edc2bc..2445b56 100644
|
|||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||
u32 *data, int in_pm)
|
||||
{
|
||||
@@ -764,8 +769,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
@@ -809,8 +814,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
|
||||
}
|
||||
|
||||
|
@ -91,5 +91,5 @@ index 2edc2bc..2445b56 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.8.2
|
||||
2.8.3
|
||||
|
||||
|
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=2
|
||||
|
||||
_rcver=4.7
|
||||
_rcrel=1
|
||||
_rcrel=2
|
||||
|
||||
pkgbase=linux-armv5-rc
|
||||
#_srcname=linux-4.$((${_rcver##*.}-1))
|
||||
|
@ -25,11 +25,11 @@ source=(#"http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0002-at91-arietta-g25-support.patch'
|
||||
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'config')
|
||||
md5sums=('b5d7583fa8e332a11cd78dc8da0802d6'
|
||||
'aba0f2b0bfe0922b0cd556c01b271fb7'
|
||||
'b0a34a7166501fdc2bf5ea2abb4aa6a0'
|
||||
'61aafdc68c57c58cc0b6cb026d134144'
|
||||
'4c7c046758d3a4c14b686c2aace3fece')
|
||||
md5sums=('687e3ff4f6be272e69cd1633d2955027'
|
||||
'77bd4cf88b10ab0a5545c99383675b5e'
|
||||
'a46e1936a8a028342a8cd2286e0a344c'
|
||||
'7feab415253a953c99ae14c4d9d816e3'
|
||||
'2007dee90ce4cac1aa8f239cb88490ea')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.7.0-rc1-1 Kernel Configuration
|
||||
# Linux/arm 4.7.0-rc2-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -681,6 +681,8 @@ CONFIG_IPV6_SIT_6RD=y
|
|||
CONFIG_IPV6_NDISC_NODETYPE=y
|
||||
CONFIG_IPV6_TUNNEL=m
|
||||
CONFIG_IPV6_GRE=m
|
||||
CONFIG_IPV6_FOU=m
|
||||
CONFIG_IPV6_FOU_TUNNEL=m
|
||||
CONFIG_IPV6_MULTIPLE_TABLES=y
|
||||
CONFIG_IPV6_SUBTREES=y
|
||||
CONFIG_IPV6_MROUTE=y
|
||||
|
@ -2148,7 +2150,6 @@ CONFIG_VT_CONSOLE_SLEEP=y
|
|||
CONFIG_HW_CONSOLE=y
|
||||
CONFIG_VT_HW_CONSOLE_BINDING=y
|
||||
CONFIG_UNIX98_PTYS=y
|
||||
CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
|
||||
# CONFIG_LEGACY_PTYS is not set
|
||||
# CONFIG_SERIAL_NONSTANDARD is not set
|
||||
# CONFIG_N_GSM is not set
|
||||
|
@ -5184,6 +5185,7 @@ CONFIG_TRACING_SUPPORT=y
|
|||
# CONFIG_TEST_KSTRTOX is not set
|
||||
# CONFIG_TEST_PRINTF is not set
|
||||
# CONFIG_TEST_BITMAP is not set
|
||||
# CONFIG_TEST_UUID is not set
|
||||
# CONFIG_TEST_RHASHTABLE is not set
|
||||
# CONFIG_TEST_HASH is not set
|
||||
# CONFIG_DMA_API_DEBUG is not set
|
||||
|
|
Loading…
Reference in a new issue