mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/firefox to 93.0-1
This commit is contained in:
parent
c1542071e5
commit
e8b5e2d0f1
3 changed files with 6 additions and 51 deletions
|
@ -9,10 +9,10 @@ Subject: [PATCH] Use remoting name for GDK application names
|
||||||
2 files changed, 6 insertions(+), 12 deletions(-)
|
2 files changed, 6 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
|
||||||
index 055be3e7a3554..f660bd26e331c 100644
|
index bb14d84338334..f5c0222987fb0 100644
|
||||||
--- a/toolkit/xre/nsAppRunner.cpp
|
--- a/toolkit/xre/nsAppRunner.cpp
|
||||||
+++ b/toolkit/xre/nsAppRunner.cpp
|
+++ b/toolkit/xre/nsAppRunner.cpp
|
||||||
@@ -4304,11 +4304,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
@@ -4299,11 +4299,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
|
||||||
// consistently.
|
// consistently.
|
||||||
|
|
||||||
// Set program name to the one defined in application.ini.
|
// Set program name to the one defined in application.ini.
|
||||||
|
|
|
@ -1,40 +0,0 @@
|
||||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
||||||
Date: Sun, 19 Sep 2021 17:26:30 +0200
|
|
||||||
Subject: [PATCH] Bug 1731495 - Don't typecheck the pipewire session_handle.
|
|
||||||
r?rmader
|
|
||||||
|
|
||||||
Since xdg-desktop-portal 1.10.0, the type is "o" (an object path string)
|
|
||||||
instead of "s" (a normal string). g_variant_lookup fails if the type
|
|
||||||
doesn't match exactly, even though both are strings.
|
|
||||||
|
|
||||||
Use g_variant_lookup_value to get the field value, telling it not to
|
|
||||||
typecheck. Use g_variant_dup_string to extract the string, which doesn't
|
|
||||||
care about the exact type, so this code should work with all versions of
|
|
||||||
xdg-desktop-portal.
|
|
||||||
|
|
||||||
Following a similar fix to OBS, see
|
|
||||||
https://github.com/obsproject/obs-studio/commit/ef0540c0d7df.
|
|
||||||
---
|
|
||||||
.../desktop_capture/linux/base_capturer_pipewire.cc | 8 ++++++--
|
|
||||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/third_party/libwebrtc/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc b/third_party/libwebrtc/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc
|
|
||||||
index 236fc09c8a96b..2c4489fb62c6c 100644
|
|
||||||
--- a/third_party/libwebrtc/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc
|
|
||||||
+++ b/third_party/libwebrtc/webrtc/modules/desktop_capture/linux/base_capturer_pipewire.cc
|
|
||||||
@@ -589,8 +589,12 @@ void BaseCapturerPipeWire::OnSessionRequestResponseSignal(
|
|
||||||
guint32 portal_response;
|
|
||||||
GVariant* response_data;
|
|
||||||
g_variant_get(parameters, "(u@a{sv})", &portal_response, &response_data);
|
|
||||||
- g_variant_lookup(response_data, "session_handle", "s",
|
|
||||||
- &that->session_handle_);
|
|
||||||
+
|
|
||||||
+ GVariant* session_handle =
|
|
||||||
+ g_variant_lookup_value(response_data, "session_handle", NULL);
|
|
||||||
+ that->session_handle_ = g_variant_dup_string(session_handle, NULL);
|
|
||||||
+
|
|
||||||
+ g_variant_unref(session_handle);
|
|
||||||
g_variant_unref(response_data);
|
|
||||||
|
|
||||||
if (!that->session_handle_ || portal_response) {
|
|
|
@ -10,8 +10,8 @@ buildarch=12
|
||||||
highmem=1
|
highmem=1
|
||||||
|
|
||||||
pkgname=firefox
|
pkgname=firefox
|
||||||
pkgver=92.0.1
|
pkgver=93.0
|
||||||
pkgrel=1.1
|
pkgrel=1
|
||||||
pkgdesc="Standalone web browser from mozilla.org"
|
pkgdesc="Standalone web browser from mozilla.org"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
license=(MPL GPL LGPL)
|
license=(MPL GPL LGPL)
|
||||||
|
@ -30,13 +30,11 @@ options=(!emptydirs !makeflags !strip)
|
||||||
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
|
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
|
||||||
build-arm-libopus.patch
|
build-arm-libopus.patch
|
||||||
0001-Use-remoting-name-for-GDK-application-names.patch
|
0001-Use-remoting-name-for-GDK-application-names.patch
|
||||||
0002-Bug-1731495-Don-t-typecheck-the-pipewire-session_han.patch
|
|
||||||
$pkgname.desktop identity-icons-brand.svg)
|
$pkgname.desktop identity-icons-brand.svg)
|
||||||
sha256sums=('9096b22e162cd299080d5eef8f3627a71a594ceba2b89e3000f2c3e8ea603eb1'
|
sha256sums=('a78f080f5849bc284b84299f3540934a12e961a7ea368b592ae6576ea1f97102'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||||
'd7c7a65c4b7ec9ea40df129724ffb369d3f775b0514e3c267c52eec6d284b5e6'
|
'bb9769a8fe720abea2bba5b895c70c4fba0d44bb553399d83350268edf85cdeb'
|
||||||
'8f313d96c845723f54996d660a201d747dfa8da791f19a827aba55cb81261e38'
|
|
||||||
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
|
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf'
|
||||||
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
|
'a9b8b4a0a1f4a7b4af77d5fc70c2686d624038909263c795ecc81e0aec7711e9')
|
||||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||||
|
@ -61,9 +59,6 @@ prepare() {
|
||||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
|
||||||
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
|
||||||
|
|
||||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1731495
|
|
||||||
patch -Np1 -i ../0002-Bug-1731495-Don-t-typecheck-the-pipewire-session_han.patch
|
|
||||||
|
|
||||||
echo -n "$_google_api_key" >google-api-key
|
echo -n "$_google_api_key" >google-api-key
|
||||||
echo -n "$_mozilla_api_key" >mozilla-api-key
|
echo -n "$_mozilla_api_key" >mozilla-api-key
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue