extra/chromium to 95.0.4638.54-1

This commit is contained in:
Kevin Mihelich 2021-10-19 23:51:14 +00:00
parent 2009048c54
commit e8ccea777a
3 changed files with 75 additions and 6 deletions

View file

@ -17,10 +17,10 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=94.0.4606.81
pkgver=95.0.4638.54
pkgrel=1
_launcher_ver=8
_gcc_patchset=3
_gcc_patchset=4
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
url="https://www.chromium.org/Home"
@ -37,6 +37,8 @@ optdepends=('pipewire: WebRTC desktop sharing under Wayland'
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
maldoca-depend-on-zlib-instead-of-headers-only.patch
chromium-95-harfbuzz-3.patch
replace-blacklist-with-ignorelist.patch
add-a-TODO-about-a-missing-pnacl-flag.patch
use-ffile-compilation-dir.patch
@ -49,9 +51,11 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
0001-widevine-support-for-arm.patch
0002-Run-blink-bindings-generation-single-threaded.patch
0003-Fix-eu-strip-build-for-newer-GCC.patch)
sha256sums=('7071aa2b2caf48094c2ae816395948b4daec940606f4982ad5bbf68e5d2de598'
sha256sums=('3eef88d745e6ddaeaf507358f1510482d6f399cf335061bb1226a5f7120061fd'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'22692bddaf2761c6ddf9ff0bc4722972bca4d4c5b2fd3e5dbdac7eb60d914320'
'bc6373f2470a9e6d947a4deaee0612f730112f69552b933c54bb6e60b82dd6f1'
'074b32078b9e53fd9b33709ce5785c120eb0346b015a93921897caed4f95f7b6'
'd9002f1e33390c3e770637773c81be6731584b18f68f086e955bcc3f66f4510d'
'd3344ba39b8c6ed202334ba7f441c70d81ddf8cdb15af1aa8c16e9a3a75fbb35'
'd53da216538f2e741a6e048ed103964a91a98e9a3c10c27fdfa34d4692fdc455'
'921010cd8fab5f30be76c68b68c9b39fac9e21f4c4133bb709879592bbdf606e'
@ -147,6 +151,10 @@ prepare() {
# https://crbug.com/1207478
patch -Np0 -i ../unexpire-accelerated-video-decode-flag.patch
# Upstream fixes
patch -Np1 -i ../maldoca-depend-on-zlib-instead-of-headers-only.patch
patch -Np1 -i ../chromium-95-harfbuzz-3.patch
# Revert transition to -fsanitize-ignorelist (needs newer clang)
patch -Rp1 -i ../replace-blacklist-with-ignorelist.patch
@ -161,8 +169,7 @@ prepare() {
patch -Np1 -i ../sql-make-VirtualCursor-standard-layout-type.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-90-ruy-include.patch
patch -Np1 -i ../patches/chromium-94-CustomSpaces-include.patch
patch -Np1 -i ../patches/chromium-95-quiche-include.patch
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin

View file

@ -0,0 +1,31 @@
From 9e00e702633c47c590a869bc66b5c2ceec09da50 Mon Sep 17 00:00:00 2001
From: Dominik Röttsches <drott@chromium.org>
Date: Tue, 28 Sep 2021 15:31:50 +0000
Subject: [PATCH] Roll src/third_party/harfbuzz-ng/src/ 6602cbb70..a52c6df38 (80 commits)
Fixed: 1252284
Change-Id: Ie2ff99da5e41ca97b8881e1bd3e158881f4d5a8e
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3190252
Commit-Queue: Dominik Röttsches <drott@chromium.org>
Commit-Queue: Calder Kitagawa <ckitagawa@chromium.org>
Auto-Submit: Dominik Röttsches <drott@chromium.org>
Reviewed-by: Calder Kitagawa <ckitagawa@chromium.org>
Reviewed-by: Anders Hartvoll Ruud <andruud@chromium.org>
Cr-Commit-Position: refs/heads/main@{#925776}
(only components/paint_preview/common/subset_font.cc)
---
diff --git a/components/paint_preview/common/subset_font.cc b/components/paint_preview/common/subset_font.cc
index 45daea7b1..43a448e 100644
--- a/components/paint_preview/common/subset_font.cc
+++ b/components/paint_preview/common/subset_font.cc
@@ -79,7 +79,7 @@
// Retain all variation information for OpenType variation fonts. See:
// https://docs.microsoft.com/en-us/typography/opentype/spec/otvaroverview
hb_set_t* skip_subset =
- hb_subset_input_no_subset_tables_set(input.get()); // Owned by |input|.
+ hb_subset_input_set(input.get(), HB_SUBSET_SETS_NO_SUBSET_TABLE_TAG);
hb_set_add(skip_subset, HB_TAG('a', 'v', 'a', 'r'));
hb_set_add(skip_subset, HB_TAG('c', 'v', 'a', 'r'));
hb_set_add(skip_subset, HB_TAG('f', 'v', 'a', 'r'));

View file

@ -0,0 +1,31 @@
From 0aa878b7839141077071db97ba1cd30edf486827 Mon Sep 17 00:00:00 2001
From: Stephan Hartmann <stha09@googlemail.com>
Date: Wed, 15 Sep 2021 17:14:14 +0000
Subject: [PATCH] maldoca: depend on zlib instead of headers only
There is no zlib_common_headers target for unbundled zlib
and in the end code links against zlib static library anyways.
Bug: None
Change-Id: I50b8bb5b480770b637904de00aecc3a629f09471
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/3162976
Reviewed-by: Daniel Rubery <drubery@chromium.org>
Commit-Queue: Stephan Hartmann <stha09@googlemail.com>
Cr-Commit-Position: refs/heads/main@{#921717}
---
third_party/maldoca/BUILD.gn | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/third_party/maldoca/BUILD.gn b/third_party/maldoca/BUILD.gn
index eeab2056b5..29a0a2ca49 100644
--- a/third_party/maldoca/BUILD.gn
+++ b/third_party/maldoca/BUILD.gn
@@ -224,7 +224,7 @@ source_set("maldoca-ole") {
"//third_party/libxml",
"//third_party/protobuf:protobuf_lite",
"//third_party/re2",
- "//third_party/zlib:zlib_common_headers",
+ "//third_party/zlib:zlib",
"//third_party/zlib/google:zip",
]