mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
removed community/mplayer-vaapi
This commit is contained in:
parent
418fc7b8a2
commit
e91ea3c208
6 changed files with 0 additions and 217 deletions
|
@ -1,97 +0,0 @@
|
|||
# $Id: PKGBUILD 73508 2012-07-08 19:34:25Z foutrelis $
|
||||
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Hugo Doria <hugo@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove --enable-runtime-cpudetection from configure
|
||||
|
||||
pkgname=mplayer-vaapi
|
||||
pkgver=36265
|
||||
pkgrel=14
|
||||
pkgdesc="A movie player, compiled with vaapi support"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://gitorious.org/vaapi/mplayer"
|
||||
license=('GPL')
|
||||
depends=('libxxf86dga' 'libxxf86vm' 'libmad' 'libcdio-paranoia' 'libxinerama' 'sdl'
|
||||
'lame' 'fontconfig' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'glu'
|
||||
'sdl' 'smbclient' 'aalib' 'jack' 'libcaca' 'libx264' 'faac' 'faad2'
|
||||
'lirc' 'ttf-dejavu' 'libxvmc' 'enca' 'opencore-amr' 'libdca'
|
||||
'a52dec' 'schroedinger' 'mpg123' 'libvpx' 'libpulse' 'fribidi' 'opus'
|
||||
'libbluray' 'libva' 'libass' 'rtmpdump' 'gsm' 'desktop-file-utils')
|
||||
depends+=('libx264.so')
|
||||
makedepends=('unzip' 'live-media' 'yasm' 'ladspa' 'git' 'mesa' 'x264')
|
||||
provides=("mplayer=$pkgver")
|
||||
conflicts=('mplayer')
|
||||
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
|
||||
source=(http://pkgbuild.com/~foutrelis/sources/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
|
||||
cdio-includes.patch
|
||||
tweak-desktop-file.patch
|
||||
subreader-fix-srt-parsing.patch
|
||||
include-samba-4.0.patch)
|
||||
options=('!buildflags' '!emptydirs')
|
||||
install=mplayer-vaapi.install
|
||||
sha256sums=('5747c28c30c15d1000fb655a8abaa4b22483746d0e82775b27466948ae0c549a'
|
||||
'SKIP'
|
||||
'72e6c654f9733953ad2466d0ea1a52f23e753791d8232d90f13293eb1b358720'
|
||||
'5a09fb462729a4e573568f9e8c1f57dbe7f69c0b68cfa4f6d70b3e52c450d93b'
|
||||
'8b6cd325d89ff8bce3662c6aaa9b61b8e6163c6574e09b575426a1eed02b8ad3'
|
||||
'169eb47b3b838ea95e50c871bdbbfb6fe0b9349b054da830f55f3b4d5055e4f3')
|
||||
validpgpkeys=('86CFFCA918CF3AF47147588051E8B148A9999C34')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
patch -Np0 -i "$srcdir/cdio-includes.patch"
|
||||
patch -d etc -Np0 -i "$srcdir/tweak-desktop-file.patch"
|
||||
|
||||
# http://bugzilla.mplayerhq.hu/show_bug.cgi?id=2139
|
||||
patch -Np0 -i "$srcdir/subreader-fix-srt-parsing.patch"
|
||||
|
||||
# https://bugs.archlinux.org/task/41588
|
||||
patch -Np1 -i "$srcdir/include-samba-4.0.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--disable-gui \
|
||||
--disable-arts \
|
||||
--disable-liblzo \
|
||||
--disable-speex \
|
||||
--disable-cdparanoia \
|
||||
--disable-openal \
|
||||
--disable-libdv \
|
||||
--disable-musepack \
|
||||
--disable-esd \
|
||||
--disable-mga \
|
||||
--disable-ass-internal \
|
||||
--enable-xvmc \
|
||||
--enable-radio \
|
||||
--enable-radio-capture \
|
||||
--enable-smb \
|
||||
--disable-vdpau \
|
||||
--enable-vaapi \
|
||||
--language=all \
|
||||
--confdir=/etc/mplayer
|
||||
|
||||
[[ $CARCH == i686 ]] && sed -i 's|-march=i486|-march=i686|g' config.mak
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
|
||||
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
|
||||
install -Dm644 etc/mplayer.desktop "$pkgdir/usr/share/applications/mplayer.desktop"
|
||||
install -d "$pkgdir/usr/share/mplayer/"
|
||||
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
|
||||
rm -rf "$pkgdir/usr/share/mplayer/font"
|
||||
install -Dm644 etc/mplayer256x256.png "$pkgdir/usr/share/pixmaps/mplayer.png"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,43 +0,0 @@
|
|||
Index: configure
|
||||
===================================================================
|
||||
--- configure (revision 35421)
|
||||
+++ configure (working copy)
|
||||
@@ -5968,8 +5968,8 @@
|
||||
cat > $TMPC << EOF
|
||||
#include <stdio.h>
|
||||
#include <cdio/version.h>
|
||||
-#include <cdio/cdda.h>
|
||||
-#include <cdio/paranoia.h>
|
||||
+#include <cdio/paranoia/cdda.h>
|
||||
+#include <cdio/paranoia/paranoia.h>
|
||||
int main(void) {
|
||||
void *test = cdda_verbose_set;
|
||||
printf("%s\n", CDIO_VERSION);
|
||||
Index: gui/win32/interface.c
|
||||
===================================================================
|
||||
--- gui/win32/interface.c (revision 35421)
|
||||
+++ gui/win32/interface.c (working copy)
|
||||
@@ -24,7 +24,7 @@
|
||||
#include "config.h"
|
||||
|
||||
#if defined(CONFIG_LIBCDIO)
|
||||
-#include <cdio/cdda.h>
|
||||
+#include <cdio/paranoia/cdda.h>
|
||||
#elif defined(CONFIG_CDDA)
|
||||
#include <cdda_interface.h>
|
||||
#endif
|
||||
Index: stream/stream_cdda.c
|
||||
===================================================================
|
||||
--- stream/stream_cdda.c (revision 35421)
|
||||
+++ stream/stream_cdda.c (working copy)
|
||||
@@ -21,8 +21,8 @@
|
||||
#include <cdda_interface.h>
|
||||
#include <cdda_paranoia.h>
|
||||
#else
|
||||
-#include <cdio/cdda.h>
|
||||
-#include <cdio/paranoia.h>
|
||||
+#include <cdio/paranoia/cdda.h>
|
||||
+#include <cdio/paranoia/paranoia.h>
|
||||
#endif
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
|
@ -1,12 +0,0 @@
|
|||
diff -rupN a/stream/stream_smb.c b/stream/stream_smb.c
|
||||
--- a/stream/stream_smb.c 2013-03-16 13:38:34.000000000 +0000
|
||||
+++ b/stream/stream_smb.c 2013-10-31 20:05:32.473947926 +0000
|
||||
@@ -18,7 +18,7 @@
|
||||
|
||||
#include "config.h"
|
||||
|
||||
-#include <libsmbclient.h>
|
||||
+#include <samba-4.0/libsmbclient.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#include "mp_msg.h"
|
|
@ -1,11 +0,0 @@
|
|||
post_install() {
|
||||
update-desktop-database -q
|
||||
}
|
||||
post_upgrade() {
|
||||
post_install
|
||||
}
|
||||
post_remove() {
|
||||
post_install
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
|
@ -1,40 +0,0 @@
|
|||
Index: sub/subreader.c
|
||||
===================================================================
|
||||
--- sub/subreader.c (revision 36284)
|
||||
+++ sub/subreader.c (revision 36285)
|
||||
@@ -378,14 +378,14 @@
|
||||
int h1, m1, s1, ms1, h2, m2, s2, ms2, j = 0;
|
||||
|
||||
while (!current->text[0]) {
|
||||
- char line[LINE_LEN + 1], full_line[LINE_LEN + 1], sep;
|
||||
+ char line[LINE_LEN + 1], full_line[LINE_LEN + 1];
|
||||
int i;
|
||||
|
||||
/* Parse SubRip header */
|
||||
if (!stream_read_line(st, line, LINE_LEN, utf16))
|
||||
return NULL;
|
||||
- if (sscanf(line, "%d:%d:%d%[,.:]%d --> %d:%d:%d%[,.:]%d",
|
||||
- &h1, &m1, &s1, &sep, &ms1, &h2, &m2, &s2, &sep, &ms2) < 10)
|
||||
+ if (sscanf(line, "%d:%d:%d%*[,.:]%d --> %d:%d:%d%*[,.:]%d",
|
||||
+ &h1, &m1, &s1, &ms1, &h2, &m2, &s2, &ms2) < 8)
|
||||
continue;
|
||||
|
||||
current->start = h1 * 360000 + m1 * 6000 + s1 * 100 + ms1 / 10;
|
||||
@@ -442,7 +442,7 @@
|
||||
#endif
|
||||
while (!current->text[0]) {
|
||||
if (!stream_read_line (st, line, LINE_LEN, utf16)) return NULL;
|
||||
- if ((len=sscanf (line, "%d:%d:%d%[,.:]%d --> %d:%d:%d%[,.:]%d",&a1,&a2,&a3,(char *)&i,&a4,&b1,&b2,&b3,(char *)&i,&b4)) < 10)
|
||||
+ if ((len=sscanf (line, "%d:%d:%d%*[,.:]%d --> %d:%d:%d%*[,.:]%d",&a1,&a2,&a3,&a4,&b1,&b2,&b3,&b4)) < 8)
|
||||
continue;
|
||||
current->start = a1*360000+a2*6000+a3*100+a4/10;
|
||||
current->end = b1*360000+b2*6000+b3*100+b4/10;
|
||||
@@ -1123,7 +1123,7 @@
|
||||
{*uses_time=1;return SUB_MPL2;}
|
||||
if (sscanf (line, "%d:%d:%d.%d,%d:%d:%d.%d", &i, &i, &i, &i, &i, &i, &i, &i)==8)
|
||||
{*uses_time=1;return SUB_SUBRIP;}
|
||||
- if (sscanf (line, "%d:%d:%d%[,.:]%d --> %d:%d:%d%[,.:]%d", &i, &i, &i, (char *)&i, &i, &i, &i, &i, (char *)&i, &i)==10)
|
||||
+ if (sscanf (line, "%d:%d:%d%*[,.:]%d --> %d:%d:%d%*[,.:]%d", &i, &i, &i, &i, &i, &i, &i, &i)==8)
|
||||
{*uses_time=1;return SUB_SUBVIEWER;}
|
||||
if (sscanf (line, "{T %d:%d:%d:%d",&i, &i, &i, &i)==4)
|
||||
{*uses_time=1;return SUB_SUBVIEWER2;}
|
|
@ -1,14 +0,0 @@
|
|||
--- mplayer.desktop.orig 2012-07-08 22:18:27.000000000 +0300
|
||||
+++ mplayer.desktop 2012-07-08 22:19:08.000000000 +0300
|
||||
@@ -23,8 +23,9 @@ Comment[fr]=Lit les films et musiques
|
||||
Comment[it]=Riproduce filmati e musica
|
||||
Comment[ja]=動画や音声のファイルを再生します
|
||||
Icon=mplayer
|
||||
-TryExec=gmplayer
|
||||
-Exec=gmplayer %F
|
||||
+TryExec=mplayer
|
||||
+Exec=mplayer -really-quiet %F
|
||||
Terminal=false
|
||||
+NoDisplay=true
|
||||
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
|
||||
MimeType=application/mxf;application/x-netshow-channel;application/ogg;application/ram;application/vnd.rn-realmedia;application/x-shockwave-flash;application/smil;audio/ac3;audio/x-adpcm;audio/x-aiff;audio/AMR;audio/AMR-WB;audio/x-ape;audio/basic;audio/flac;audio/x-flac;audio/x-flac+ogg;audio/x-m4b;audio/x-matroska;audio/mp2;audio/mp4;audio/mpeg;audio/x-mpegurl;audio/x-ms-asx;audio/x-ms-wma;audio/x-musepack;audio/ogg;audio/vnd.rn-realaudio;audio/x-scpls;audio/x-voc;audio/x-vorbis+ogg;audio/x-wav;audio/x-wavpack;video/3gpp;video/3gpp2;video/dv;video/x-flic;video/x-flv;video/x-matroska;video/mp2t;video/mp4;video/mpeg;video/x-ms-asf;video/x-ms-wmv;video/x-msvideo;video/x-nsv;video/ogg;video/x-ogm+ogg;video/quicktime;video/vnd.rn-realvideo;video/x-theora+ogg;video/webm;
|
Loading…
Reference in a new issue