mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
added extra/xulrunner
This commit is contained in:
parent
51fabc288e
commit
e9201faecb
4 changed files with 150 additions and 0 deletions
59
extra/xulrunner/PKGBUILD
Normal file
59
extra/xulrunner/PKGBUILD
Normal file
|
@ -0,0 +1,59 @@
|
|||
# $Id: PKGBUILD 169809 2012-10-29 21:12:03Z ibiru $
|
||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||
# Contributor: Alexander Baldeck <alexander@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich
|
||||
# - added --disable-elf-hack to mozconfig
|
||||
|
||||
highmem=1
|
||||
|
||||
pkgname=xulrunner
|
||||
pkgver=16.0.2
|
||||
pkgrel=1
|
||||
pkgdesc="Mozilla Runtime Environment"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
depends=('gtk2' 'mozilla-common' 'nss>=3.13.1' 'libxt' 'libxrender' 'hunspell' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'libevent' 'sqlite>=3.7.4' 'libnotify' 'libvpx' 'python2')
|
||||
makedepends=('zip' 'unzip' 'pkg-config' 'diffutils' 'wireless_tools' 'yasm' 'mesa' 'autoconf2.13')
|
||||
url="http://wiki.mozilla.org/XUL:Xul_Runner"
|
||||
source=(ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
|
||||
mozconfig
|
||||
mozilla-pkgconfig.patch
|
||||
shared-libs.patch)
|
||||
options=('!emptydirs')
|
||||
replaces=('xulrunner-oss')
|
||||
md5sums=('1b360968ab05b2a59757d33514897915'
|
||||
'37f005b4b0cf19d823193980b23d334c'
|
||||
'27271ce647a83906ef7a24605e840d61'
|
||||
'52e52f840a49eb1d14be1c0065b03a93')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/mozilla-release"
|
||||
cp "$srcdir/mozconfig" .mozconfig
|
||||
|
||||
#fix libdir/sdkdir - fedora
|
||||
patch -Np1 -i ../mozilla-pkgconfig.patch
|
||||
patch -Np1 -i ../shared-libs.patch
|
||||
|
||||
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/xulrunner-$pkgver"
|
||||
export PYTHON="/usr/bin/python2"
|
||||
|
||||
make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/mozilla-release"
|
||||
make -j1 -f client.mk DESTDIR="$pkgdir" install
|
||||
|
||||
rm -rf "$pkgdir"/usr/lib/xulrunner-$pkgver/{dictionaries,hyphenation}
|
||||
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/xulrunner-$pkgver/dictionaries"
|
||||
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/xulrunner-$pkgver/hyphenation"
|
||||
|
||||
# add xulrunner library path to ld.so.conf
|
||||
install -d $pkgdir/etc/ld.so.conf.d
|
||||
echo "/usr/lib/xulrunner-$pkgver" > $pkgdir/etc/ld.so.conf.d/xulrunner.conf
|
||||
|
||||
chmod +x "${pkgdir}/usr/lib/xulrunner-devel-$pkgver/sdk/bin/xpt.py"
|
||||
sed -i 's|!/usr/bin/env python$|!/usr/bin/env python2|' \
|
||||
"$pkgdir"/usr/lib/xulrunner-devel-$pkgver/sdk/bin/{xpt,header,typelib,xpidl}.py
|
||||
}
|
39
extra/xulrunner/mozconfig
Normal file
39
extra/xulrunner/mozconfig
Normal file
|
@ -0,0 +1,39 @@
|
|||
. $topsrcdir/xulrunner/config/mozconfig
|
||||
|
||||
ac_add_options --prefix=/usr
|
||||
ac_add_options --libdir=/usr/lib
|
||||
|
||||
# System libraries
|
||||
ac_add_options --disable-elf-hack
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
ac_add_options --with-system-jpeg
|
||||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-system-png
|
||||
ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
ac_add_options --enable-system-ffi
|
||||
#ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-pixman
|
||||
ac_add_options --with-pthreads
|
||||
|
||||
# Features
|
||||
ac_add_options --enable-safe-browsing
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-gio
|
||||
|
||||
ac_add_options --disable-gnomevfs
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --disable-tests
|
||||
ac_add_options --disable-mochitest
|
||||
ac_add_options --disable-installer
|
||||
|
||||
# Optimization
|
||||
ac_add_options --enable-optimize
|
||||
|
||||
export MOZILLA_OFFICIAL=1
|
||||
mk_add_options MOZILLA_OFFICIAL=1
|
40
extra/xulrunner/mozilla-pkgconfig.patch
Normal file
40
extra/xulrunner/mozilla-pkgconfig.patch
Normal file
|
@ -0,0 +1,40 @@
|
|||
diff -Nur mozilla-release.orig/xulrunner/installer/libxul-embedding.pc.in mozilla-release/xulrunner/installer/libxul-embedding.pc.in
|
||||
--- mozilla-release.orig/xulrunner/installer/libxul-embedding.pc.in 2011-12-19 22:11:38.100005674 +0000
|
||||
+++ mozilla-release/xulrunner/installer/libxul-embedding.pc.in 2011-12-19 22:14:35.095147521 +0000
|
||||
@@ -6,5 +6,6 @@
|
||||
Name: libxul-embedding
|
||||
Description: Static library for version-independent embedding of the Mozilla runtime
|
||||
Version: %MOZILLA_VERSION%
|
||||
+Requires: %NSPR_NAME% >= %NSPR_VERSION%
|
||||
Libs: -L${sdkdir}/lib -lxpcomglue -ldl
|
||||
Cflags: -DXPCOM_GLUE -I${includedir} %WCHAR_CFLAGS%
|
||||
diff -Nur mozilla-release.orig/xulrunner/installer/libxul.pc.in mozilla-release/xulrunner/installer/libxul.pc.in
|
||||
--- mozilla-release.orig/xulrunner/installer/libxul.pc.in 2011-12-19 22:11:38.126672110 +0000
|
||||
+++ mozilla-release/xulrunner/installer/libxul.pc.in 2011-12-19 22:14:04.375412141 +0000
|
||||
@@ -1,5 +1,6 @@
|
||||
prefix=%prefix%
|
||||
sdkdir=%sdkdir%
|
||||
+libdir=%libdir%
|
||||
includedir=%includedir%
|
||||
idldir=%idldir%
|
||||
|
||||
diff -Nur mozilla-release.orig/xulrunner/installer/Makefile.in mozilla-release/xulrunner/installer/Makefile.in
|
||||
--- mozilla-release.orig/xulrunner/installer/Makefile.in 2011-12-19 22:11:38.126672110 +0000
|
||||
+++ mozilla-release/xulrunner/installer/Makefile.in 2011-12-19 22:18:28.743135321 +0000
|
||||
@@ -108,6 +108,7 @@
|
||||
-e "s|%includedir%|$(includedir)|" \
|
||||
-e "s|%idldir%|$(idldir)|" \
|
||||
-e "s|%sdkdir%|$(sdkdir)|" \
|
||||
+ -e "s|%libdir%|$(installdir)|" \
|
||||
-e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
|
||||
-e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
|
||||
-e "s|%WCHAR_CFLAGS%|$(WCHAR_CFLAGS)|" \
|
||||
diff -Nur mozilla-release.orig/xulrunner/installer/mozilla-js.pc.in mozilla-release/xulrunner/installer/mozilla-js.pc.in
|
||||
--- mozilla-release.orig/xulrunner/installer/mozilla-js.pc.in 2011-12-19 22:11:38.126672110 +0000
|
||||
+++ mozilla-release/xulrunner/installer/mozilla-js.pc.in 2011-12-19 22:18:55.569571004 +0000
|
||||
@@ -7,4 +7,4 @@
|
||||
Version: %MOZILLA_VERSION%
|
||||
Requires: %NSPR_NAME% >= %NSPR_VERSION%
|
||||
Libs: -L${sdkdir}/lib %MOZ_JS_LINK%
|
||||
-Cflags: -I${includedir} -DXP_UNIX -DJS_THREADSAFE
|
||||
+Cflags: -I${includedir} -I${includedir}/js -DXP_UNIX -DJS_THREADSAFE
|
12
extra/xulrunner/shared-libs.patch
Normal file
12
extra/xulrunner/shared-libs.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -Nur mozilla-release.orig/browser/installer/Makefile.in mozilla-release/browser/installer/Makefile.in
|
||||
--- mozilla-release.orig/browser/installer/Makefile.in 2012-07-17 16:19:29.480356991 +0000
|
||||
+++ mozilla-release/browser/installer/Makefile.in 2012-07-17 17:32:41.250937293 +0000
|
||||
@@ -50,7 +50,7 @@
|
||||
MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in
|
||||
# Some files have been already bundled with xulrunner
|
||||
ifndef SYSTEM_LIBXUL
|
||||
-MOZ_PKG_FATAL_WARNINGS = 1
|
||||
+MOZ_PKG_FATAL_WARNINGS = 0
|
||||
endif
|
||||
|
||||
MOZ_NONLOCALIZED_PKG_LIST = \
|
Loading…
Reference in a new issue