core/linux-odroid-xu3 to 3.10.105-1

This commit is contained in:
Kevin Mihelich 2017-03-03 02:19:44 +00:00
parent b94ad1cb2c
commit e93157323d
3 changed files with 15 additions and 15 deletions

View file

@ -1,4 +1,4 @@
From 4e2d23b7c5160e772b3a787bb164fe1bca0cc0c7 Mon Sep 17 00:00:00 2001 From b2e8eb3c57c2c2c624ad92308ac3d2ec0f0ef622 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org> From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 8 Dec 2016 19:58:12 -0700 Date: Thu, 8 Dec 2016 19:58:12 -0700
Subject: [PATCH 1/2] exynos-ss GCC6 compatibility Subject: [PATCH 1/2] exynos-ss GCC6 compatibility
@ -8,7 +8,7 @@ Subject: [PATCH 1/2] exynos-ss GCC6 compatibility
1 file changed, 7 insertions(+), 7 deletions(-) 1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/arch/arm/mach-exynos/exynos-ss.c b/arch/arm/mach-exynos/exynos-ss.c diff --git a/arch/arm/mach-exynos/exynos-ss.c b/arch/arm/mach-exynos/exynos-ss.c
index 9ede727..e8c7836 100644 index 9ede7277bc7d..e8c7836f9807 100644
--- a/arch/arm/mach-exynos/exynos-ss.c --- a/arch/arm/mach-exynos/exynos-ss.c
+++ b/arch/arm/mach-exynos/exynos-ss.c +++ b/arch/arm/mach-exynos/exynos-ss.c
@@ -238,6 +238,13 @@ struct exynos_ss_interface { @@ -238,6 +238,13 @@ struct exynos_ss_interface {
@ -40,5 +40,5 @@ index 9ede727..e8c7836 100644
{ {
__raw_writel(val, S5P_VA_SS_SCRATCH); __raw_writel(val, S5P_VA_SS_SCRATCH);
-- --
2.10.2 2.11.1

View file

@ -1,4 +1,4 @@
From 047e14034745086df20f281dc4b16305bf8a2b8d Mon Sep 17 00:00:00 2001 From 8c2a2d97be6bc64335cbc0194bacab0940ba6909 Mon Sep 17 00:00:00 2001
From: Philip Pettersson <philip.pettersson@gmail.com> From: Philip Pettersson <philip.pettersson@gmail.com>
Date: Wed, 30 Nov 2016 14:55:36 -0800 Date: Wed, 30 Nov 2016 14:55:36 -0800
Subject: [PATCH 2/2] packet: fix race condition in packet_set_ring Subject: [PATCH 2/2] packet: fix race condition in packet_set_ring
@ -25,7 +25,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
1 file changed, 12 insertions(+), 6 deletions(-) 1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
index 2d454a2..c200b1d 100644 index 24f006623f7c..e38c69969c33 100644
--- a/net/packet/af_packet.c --- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c +++ b/net/packet/af_packet.c
@@ -3135,19 +3135,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv @@ -3135,19 +3135,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
@ -58,7 +58,7 @@ index 2d454a2..c200b1d 100644
} }
case PACKET_RESERVE: case PACKET_RESERVE:
{ {
@@ -3602,6 +3608,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u, @@ -3603,6 +3609,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
/* Added to avoid minimal code churn */ /* Added to avoid minimal code churn */
struct tpacket_req *req = &req_u->req; struct tpacket_req *req = &req_u->req;
@ -66,7 +66,7 @@ index 2d454a2..c200b1d 100644
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */ /* Opening a Tx-ring is NOT supported in TPACKET_V3 */
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) { if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
WARN(1, "Tx-ring is not supported.\n"); WARN(1, "Tx-ring is not supported.\n");
@@ -3683,7 +3690,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u, @@ -3684,7 +3691,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
goto out; goto out;
} }
@ -74,7 +74,7 @@ index 2d454a2..c200b1d 100644
/* Detach socket from network */ /* Detach socket from network */
spin_lock(&po->bind_lock); spin_lock(&po->bind_lock);
@@ -3732,11 +3738,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u, @@ -3733,11 +3739,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
if (!tx_ring) if (!tx_ring)
prb_shutdown_retire_blk_timer(po, tx_ring, rb_queue); prb_shutdown_retire_blk_timer(po, tx_ring, rb_queue);
} }
@ -88,5 +88,5 @@ index 2d454a2..c200b1d 100644
} }
-- --
2.10.2 2.11.1

View file

@ -4,12 +4,12 @@
buildarch=4 buildarch=4
pkgbase=linux-odroid-xu3 pkgbase=linux-odroid-xu3
_commit=3f578ac9ad76f7934e6f20531d13470b32803922 _commit=02603ddf8851b9296033bee8243d04d274eaefa0
_srcname=linux-${_commit} _srcname=linux-${_commit}
_kernelname=${pkgbase#linux} _kernelname=${pkgbase#linux}
_desc="ODROID-XU3" _desc="ODROID-XU3"
pkgver=3.10.104 pkgver=3.10.105
pkgrel=8 pkgrel=1
bfqver=v7r8 bfqver=v7r8
arch=('armv7h') arch=('armv7h')
url="https://github.com/hardkernel/linux" url="https://github.com/hardkernel/linux"
@ -23,9 +23,9 @@ source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.8.patch" "ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0002-block-introduce-the-BFQ-${bfqver}-I-O-sched-for-${pkgver:0:4}.8.patch"
"ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.8+.patch" "ftp://teambelgium.net/bfq/patches/${pkgver:0:4}.8+-${bfqver}/0003-block-bfq-add-Early-Queue-Merge-EQM-to-BFQ-${bfqver}-for-${pkgver:0:4}.8+.patch"
'config') 'config')
md5sums=('8d650d392f95a4b1f7586ae68b466635' md5sums=('cf5c3460cf4dec38e1b821bd324b7227'
'29bc7bd1a4cb2fbfb25a63c6dd993ffb' 'b38a203d9083d66e31196494513fd5a3'
'bda0fddf55f95c0e9a54b2522d8399eb' 'd366eb182dc5ba9fa033f0c36af921a0'
'003f1554be6b672100d2f2401a574d92' '003f1554be6b672100d2f2401a574d92'
'12ffe57584b4f2adcc3e184dc6948772' '12ffe57584b4f2adcc3e184dc6948772'
'9e78f9f5364f8ebb981aeb235dcb7415' '9e78f9f5364f8ebb981aeb235dcb7415'