core/linux-aarch64 to 4.6.0-1

This commit is contained in:
Kevin Mihelich 2016-05-16 02:58:34 +00:00
parent 1a149c2993
commit e9524436d4
6 changed files with 320 additions and 400 deletions

View file

@ -1,7 +1,7 @@
From c789031f4cfa8c7933c9857dd86f4151dae63a65 Mon Sep 17 00:00:00 2001
From 2bda5e9a99a6302da09b214ab269eb783f0bf50e Mon Sep 17 00:00:00 2001
From: Peter Robinson <pbrobinson@gmail.com>
Date: Sun, 3 May 2015 18:35:23 +0100
Subject: [PATCH 1/4] arm64: acpi drop expert patch
Subject: [PATCH] arm64: acpi drop expert patch
---
drivers/acpi/Kconfig | 2 +-
@ -21,5 +21,5 @@ index 82b96ee..bf5dc1a 100644
select PNP
default y
--
2.7.0
2.8.0

View file

@ -1,132 +0,0 @@
From bf131edcef6243ffad675d6aa010c89a8e0c7331 Mon Sep 17 00:00:00 2001
From: Kumar Gala <galak@codeaurora.org>
Date: Tue, 3 Mar 2015 15:39:07 -0600
Subject: [PATCH 2/4] devicetree: bindings: Document qcom,msm-id and
qcom,board-id
The top level qcom,msm-id and qcom,board-id are utilized by bootloaders
on Qualcomm MSM platforms to determine which device tree should be
utilized and passed to the kernel.
Cc: <devicetree@vger.kernel.org>
Signed-off-by: Kumar Gala <galak@codeaurora.org>
---
Documentation/devicetree/bindings/arm/msm/ids.txt | 65 +++++++++++++++++++++++
include/dt-bindings/arm/qcom-ids.h | 33 ++++++++++++
2 files changed, 98 insertions(+)
create mode 100644 Documentation/devicetree/bindings/arm/msm/ids.txt
create mode 100644 include/dt-bindings/arm/qcom-ids.h
diff --git a/Documentation/devicetree/bindings/arm/msm/ids.txt b/Documentation/devicetree/bindings/arm/msm/ids.txt
new file mode 100644
index 0000000..9ee8428
--- /dev/null
+++ b/Documentation/devicetree/bindings/arm/msm/ids.txt
@@ -0,0 +1,65 @@
+* MSM-ID
+
+The qcom,msm-id entry specifies the MSM chipset and hardware revision. It can
+optionally be an array of these to indicate multiple hardware that use the same
+device tree. It is expected that the bootloader will use this information at
+boot-up to decide which device tree to use when given multiple device trees,
+some of which may not be compatible with the actual hardware. It is the
+bootloader's responsibility to pass the correct device tree to the kernel.
+
+PROPERTIES
+
+- qcom,msm-id:
+ Usage: required
+ Value type: <prop-encoded-array> (<chipset_id, rev_id> [, <c2, r2> ..])
+ Definition:
+ The "chipset_id" consists of three fields as below:
+
+ bits 0-15 = The unique MSM chipset id.
+ bits 16-31 = Reserved. Should be 0
+
+ chipset_id is an exact match value
+
+ The "rev_id" is a chipset specific 32-bit id that represents
+ the version of the chipset.
+
+ The rev_id is a best match id. The bootloader will look for
+ the closest possible patch.
+
+* BOARD-ID
+
+The qcom,board-id entry specifies the board type and revision information. It
+can optionally be an array of these to indicate multiple boards that use the
+same device tree. It is expected that the bootloader will use this information
+at boot-up to decide which device tree to use when given multiple device trees,
+some of which may not be compatible with the actual hardware. It is the
+bootloader's responsibility to pass the correct device tree to the kernel.
+
+PROPERTIES
+
+- qcom,board-id:
+ Usage: required
+ Value type: <prop-encoded-array> (<board_id, subtype_id> [, <b2, s2> ..])
+ Definition:
+ The "board_id" consists of three fields as below:
+
+ bits 31-24 = Unusued.
+ bits 23-16 = Platform Version Major
+ bits 15-8 = Platfrom Version Minor
+ bits 7-0 = Platform Type
+
+ Platform Type field is an exact match value. The Platform
+ Major/Minor field is a best match. The bootloader will look
+ for the closest possible match.
+
+ The "subtype_id" is unique to a Platform Type/Chipset ID. For
+ a given Platform Type, there will typically only be a single
+ board and the subtype_id will be 0. However in some cases board
+ variants may need to be distinquished by different subtype_id
+ values.
+
+ subtype_id is an exact match value.
+
+EXAMPLE:
+ qcom,board-id = <15 2>;
+ qcom,msm-id = <0x1007e 0>;
diff --git a/include/dt-bindings/arm/qcom-ids.h b/include/dt-bindings/arm/qcom-ids.h
new file mode 100644
index 0000000..a18f34e
--- /dev/null
+++ b/include/dt-bindings/arm/qcom-ids.h
@@ -0,0 +1,33 @@
+/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 and
+ * only version 2 as published by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+#ifndef __DT_BINDINGS_QCOM_IDS_H
+#define __DT_BINDINGS_QCOM_IDS_H
+
+/* qcom,msm-id */
+#define QCOM_ID_MSM8916 206
+#define QCOM_ID_APQ8016 247
+#define QCOM_ID_MSM8216 248
+#define QCOM_ID_MSM8116 249
+#define QCOM_ID_MSM8616 250
+
+/* qcom,board-id */
+#define QCOM_BRD_ID(a, major, minor) \
+ (((major & 0xff) << 16) | ((minor & 0xff) << 8) | QCOM_BRD_ID_##a)
+
+#define QCOM_BRD_ID_MTP 8
+#define QCOM_BRD_ID_DRAGONBRD 10
+#define QCOM_BRD_ID_SBC 24
+
+#define QCOM_BRD_SUBTYPE_DEFAULT 0
+#define QCOM_BRD_SUBTYPE_MTP8916_SMB1360 1
+
+#endif
--
2.7.0

View file

@ -1,55 +0,0 @@
From 5a44db76201981d7afdc38ded3ff2100c8ec8370 Mon Sep 17 00:00:00 2001
From: Kumar Gala <galak@codeaurora.org>
Date: Wed, 11 Mar 2015 15:51:20 -0500
Subject: [PATCH 3/4] arm64: dts: Add Qualcomm MSM8916 & MTP8916 ids
Add qcom,msm-id and qcom,board-id to allow bootloader to identify which
device tree to boot on the MTP8916 boards.
Signed-off-by: Kumar Gala <galak@codeaurora.org>
---
arch/arm64/boot/dts/qcom/msm8916-mtp.dts | 3 +++
arch/arm64/boot/dts/qcom/msm8916.dtsi | 5 +++++
2 files changed, 8 insertions(+)
diff --git a/arch/arm64/boot/dts/qcom/msm8916-mtp.dts b/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
index b0a064d..2cdaa65 100644
--- a/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
+++ b/arch/arm64/boot/dts/qcom/msm8916-mtp.dts
@@ -13,10 +13,13 @@
/dts-v1/;
+#include <dt-bindings/arm/qcom-ids.h>
#include "msm8916-mtp.dtsi"
/ {
model = "Qualcomm Technologies, Inc. MSM 8916 MTP";
compatible = "qcom,msm8916-mtp", "qcom,msm8916-mtp/1",
"qcom,msm8916", "qcom,mtp";
+ qcom,board-id = <QCOM_BRD_ID(MTP, 1, 0) QCOM_BRD_SUBTYPE_DEFAULT>,
+ <QCOM_BRD_ID(MTP, 1, 0) QCOM_BRD_SUBTYPE_MTP8916_SMB1360>;
};
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
index 9153214..719bd9f 100644
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
@@ -14,10 +14,15 @@
#include <dt-bindings/interrupt-controller/arm-gic.h>
#include <dt-bindings/clock/qcom,gcc-msm8916.h>
#include <dt-bindings/reset/qcom,gcc-msm8916.h>
+#include <dt-bindings/arm/qcom-ids.h>
/ {
model = "Qualcomm Technologies, Inc. MSM8916";
compatible = "qcom,msm8916";
+ qcom,msm-id = <QCOM_ID_MSM8916 0>,
+ <QCOM_ID_MSM8216 0>,
+ <QCOM_ID_MSM8116 0>,
+ <QCOM_ID_MSM8616 0>;
interrupt-parent = <&intc>;
--
2.7.0

View file

@ -1,50 +0,0 @@
From a3cc1740dc9a65fc2ce33eb128870cdd95ef5145 Mon Sep 17 00:00:00 2001
From: Andy Gross <agross@codeaurora.org>
Date: Tue, 31 Mar 2015 14:26:15 -0500
Subject: [PATCH 4/4] arm64: dts: qcom: Add APQ8016 SBC support
This patch set adds support for the APQ8016 SBC.
Signed-off-by: Andy Gross <agross@codeaurora.org>
[Srinivas Kandagatla]: rebased on top of kumars original patch
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
---
arch/arm64/boot/dts/qcom/apq8016-sbc.dts | 3 ++-
arch/arm64/boot/dts/qcom/msm8916.dtsi | 4 +++-
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/arch/arm64/boot/dts/qcom/apq8016-sbc.dts b/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
index 825f489..b0cac53 100644
--- a/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
+++ b/arch/arm64/boot/dts/qcom/apq8016-sbc.dts
@@ -12,10 +12,11 @@
*/
/dts-v1/;
-
+#include <dt-bindings/arm/qcom-ids.h>
#include "apq8016-sbc.dtsi"
/ {
model = "Qualcomm Technologies, Inc. APQ 8016 SBC";
compatible = "qcom,apq8016-sbc", "qcom,apq8016", "qcom,sbc";
+ qcom,board-id = <QCOM_BRD_ID(SBC, 1, 0) QCOM_BRD_SUBTYPE_DEFAULT>;
};
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
index 719bd9f..6716515 100644
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
@@ -22,7 +22,9 @@
qcom,msm-id = <QCOM_ID_MSM8916 0>,
<QCOM_ID_MSM8216 0>,
<QCOM_ID_MSM8116 0>,
- <QCOM_ID_MSM8616 0>;
+ <QCOM_ID_MSM8616 0>,
+ <QCOM_ID_APQ8016 0>;
+
interrupt-parent = <&intc>;
--
2.7.0

View file

@ -4,10 +4,10 @@
buildarch=8
pkgbase=linux-aarch64
_srcname=linux-4.5
_srcname=linux-4.6
_kernelname=${pkgbase#linux}
_desc="AArch64 multi-platform"
pkgver=4.5.4
pkgver=4.6.0
pkgrel=1
arch=('aarch64')
url="http://www.kernel.org/"
@ -15,33 +15,23 @@ license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-arm64-acpi-drop-expert-patch.patch'
'0002-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch'
'0003-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch'
'0004-arm64-dts-qcom-Add-APQ8016-SBC-support.patch'
'config'
'linux.preset')
md5sums=('a60d48eee08ec0536d5efb17ca819aef'
'137460a1e32335e2eedc61fcfc2643fa'
'c8e84e01e8f88b47edba6a479942cc6e'
'66de90ece2f3dcae72ee4c27ddd37b38'
'29d5fafca011d80a8cfbffb5ebbfd327'
'f2f044e19e0e8d5e81034e5870c644c7'
'5945a927be50d9f2cd8127f1da6e4e3c'
md5sums=('d2927020e24a76da4ab482a8bc3e9ef3'
'dedf9caa72844bcf970f1515cd1bcfd5'
'4d95cba7a94f20f031f0f981589d633e'
'b5ef67d6086e20de7b82265f562f88b1')
prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
git apply --whitespace=nowarn ../patch-${pkgver}
#git apply --whitespace=nowarn ../patch-${pkgver}
# ALARM patches
git apply ../0001-arm64-acpi-drop-expert-patch.patch
git apply ../0002-devicetree-bindings-Document-qcom-msm-id-and-qcom-bo.patch
git apply ../0003-arm64-dts-Add-Qualcomm-MSM8916-MTP8916-ids.patch
git apply ../0004-arm64-dts-qcom-Add-APQ8016-SBC-support.patch
cat "${srcdir}/config" > ./.config

File diff suppressed because it is too large Load diff